Intel iGPU - no video output

Hello.

Currently, I'm trying to setup GPU passthrough for QEMU. However, while I was trying to do that, I discovered that the iGPU video output doesn't work (either black screen or no signal). I enabled iGPU Multi-monitor in BIOS and set CPU Graphics as default yet the issue still persists (only video output from dedicated GPU works). I should also point out that not even BIOS is visible via the video output from the motherboard. The Intel graphics chip is recognized by Manjaro.

Neofetch output:
OS: Manjaro Linux x86_64
Kernel: 5.2.11-1-MANJARO
Uptime: 1 hour, 24 mins
Packages: 1463 (pacman), 5 (flatpak), 4 (snap)
Shell: bash 5.0.9
Resolution: 2560x1440
DE: KDE
WM: KWin
WM Theme: Aritim-Dark
Theme: Aritim-Dark [KDE], Breath-Dark [GTK2/3]
Icons: Materia-Manjaro-Dark [KDE], breeze-dark [GTK2/3]
Terminal: konsole
Terminal Font: Fira Code Light 10
CPU: Intel i7-8700K (12) @ 4.700GHz
GPU: Intel UHD Graphics 630
GPU: NVIDIA GeForce GTX 1060 6GB
Memory: 3973MiB / 15897MiB

In MHWD the Intel GPU is displayed as unknown:

This are the working options you can chose from. Decide to one that suits you.


then do the

I guess you want the dGPU for that ...

Actually, I'd just like to use the iGPU in Manjaro and passthrough the nvidia card to the Windows VM. I don't want any hybrid solutions or whatever.

If i'm correct, when you installed the video-nvidia-435xx you might have made your system to run in PRIME mode, aka the dGPU.

On a hybrid GPU laptop, like yours, how can you avoid hybrid solutions ?

Oops, forgot to mention, it's a desktop. I just want Manjaro to use the intel igpu. Right now it doesn't output anything.

Ok, from terminal run:

sudo rm /etc/X11/xorg.conf.d/90-mhwd.conf && sudo mv /etc/X11/mhwd.d/nvidia.conf /etc/X11/mhwd.d/nvidia.conf_BCK

then
systemctl reboot

The iGPU (if set correctly in the BIOS) will take over and show the output, then you can continue with
https://wiki.archlinux.org/index.php/PCI_passthrough_via_OVMF
i think ... :thinking:

1 Like

Okay finally there's at least some output from the mobo. I can see BIOS and can boot from USB and see the video via the igpu but once I boot into Manjaro there's just black screen.

Is not clear for me. You boot from USB the live media install and after you install it it gives just black screen?

No, I meant I can boot into a live arch USB And i can see it via igpu but when I boot into my already installed Manjaro there's just black screen.

When you are on the grub boot menu to boot into Manjaro installed, press e to edit, add nomodeset after quiet (use space between the two) in the linux line, then press F10 to save and continue booting. If that works then is good news. If it doesn't work is still not bad news. Press Ctrl+Alt+F2 to switch to TTY2, and if that shows up, run this command:
systemctl enable haveged --now
Then switch back to TTY1 with Ctrl+Alt+F1 ... SDDM or KDE Plasma should load.

Oh I don't have a grub boot menu. I have installed it via UEFI. Should I just put it in grub config file and update-grub afterwards?

Okay it did something. I'm able to get to tty2 and execute the command. After that, however, kde doesn't launch. There's just a blinking cursor in the top left corner.

Edit: when I tried to run X, there was a Fatal error: no screens found.

if im not mistaken, for PCI passthrough to function the VM needs full exclusive control of the nvidia gpu. i dont think nvidia drivers should be installed at all on the host and only on the VM.

get yourself to a TTY and uninstall all the drivers and only reinstall video-linux even though reinstalling should not be necessary.

sudo mhwd -r pci video-nvidia-435xx
sudo mhwd -r pci video-linux
sudo mhwd -i pci video-linux

make sure the hdmi/dp cable is going to the motherboard and not to the nvidia gpu. if the kernel is still detecting the nvidia and trying to load drivers for it you can create this file/content

sudo nano /etc/modprobe.d/blacklist.conf

blacklist nvidia
blacklist nvidia_drm
blacklist nvidia_uvm
blacklist nouveau

get intel working first, then move on to pci passthrough.

1 Like

Hey, I reinstalled Manjaro with cable plugged to Intel, now it works. I also managed to get vfio-pci to bind with the Nvidia card. Now when I add it in virt-manager, the card outputs ovfm UEFI but nothing more. In win10 it shows up as Microsoft Basic vga adapter with code 31.

1 Like

Do you have your vfio-pci modules properly attached to the GTX 1060 ? Go again over the how too, and double check everything ...

1 Like

Yes, i blacklisted nouveau And used various guides and now it's using vfio-pci for the GPU and it's HDMI audio.
There are two vga adapters. One I suppose is the Nvidia card and the other is the virtual one.

Okay, I installed the Nvidia drivers and now it works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by