Intel Wi-Fi 6 AX200 driver sometimes not loading, now not at all

I recently upgraded my desktop computer with some wifi and bluetooth capabilities (amazon link).
And while the bluethooth part is working perfectly fine, unfortunately i got some issues getting my wifi to work properly.
The problem is, that the wifi is just not working, what is no surprise, if you look at the inxi -N output and see the driver not loaded.

It is clearly no hardware issue, because i also have installed Windows 10 on my SanDisk SDD as dualboot (only reason for that is I sometimes feel the need to play some rocket league and PUBG) and there it is working just as it should. And it even worked on manjaro sometimes, but i could find no pattern whatsoever when it was working and when not. And since a week or so, it is not working on manjaro at all, which is really pissing me off.
I know the driver for this chip exists in the kernel since 5.2, but i have no idea why it just refuses to load properly.

I already tried various solutions suggestet in some arch threads, like messing with the /etc/modprobe.d/iwlwifi.conf by putting
options iwlwifi power_save=0
or
options iwlmvm power_scheme=1
inside, or disabling mac randomization, but none of them seem to work for me.

And since I'm relatively new to the linux world, I don't know what to try else.
So I really hope some experienced users around here have experience with this module or just any other idea what could help to solve this issue, because all the answers I found in the internet so far, are not containing any useful solutions to my problem.

System:    Host: Davids-PC Kernel: 5.6.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.5
          Distro: Manjaro Linux
Machine:   Type: Desktop System: Gigabyte product: B450 AORUS PRO v: N/A serial: <root required>
          Mobo: Gigabyte model: B450 AORUS PRO-CF v: x.x serial: <root required> UEFI: American Megatrends v: F50
          date: 11/27/2019
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen L2 cache: 3072 KiB
          flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86269
          Speed: 1877 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2160 2: 2053 3: 4120 4: 2434 5: 3619 6: 2069 7: 4064
          8: 2960 9: 2590 10: 2053 11: 3593 12: 2068
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Gigabyte driver: nvidia v: 440.82 bus ID: 09:00.0
          Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1920x1080~60Hz, 2560x1440~60Hz
          OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes
Audio:     Device-1: NVIDIA GP106 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 09:00.1
          Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
          bus ID: 0b:00.4
          Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo bus ID: 3-3:3
          Sound Server: ALSA v: k5.6.12-1-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: 5.6.0-k port: f000 bus ID: 04:00.0
          IF: eno1 state: up speed: 1000 Mbps duplex: full mac: b4:2e:99:4e:ed:cb
          Device-2: Intel Wi-Fi 6 AX200 driver: N/A port: f000 bus ID: 08:00.0
Drives:    Local Storage: total: 3.62 TiB used: 1.43 TiB (39.4%)
          ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP510 size: 447.13 GiB
          ID-2: /dev/sda vendor: Toshiba model: HDWD130 size: 2.73 TiB
          ID-3: /dev/sdb vendor: SanDisk model: SDSSDH3 500G size: 465.76 GiB
Partition: ID-1: / size: 438.82 GiB used: 182.09 GiB (41.5%) fs: ext4 dev: /dev/nvme0n1p2
Sensors:   System Temperatures: cpu: 46.2 C mobo: N/A gpu: nvidia temp: 44 C
          Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 269 Uptime: 11m Memory: 31.36 GiB used: 2.21 GiB (7.1%) Init: systemd Compilers: gcc: 9.3.0 Shell: bash
          v: 5.0.16 inxi: 3.0.37

Hi. Welcome to the forums.

Have you tried this: https://wiki.archlinux.org/index.php/Network_configuration/Wireless#Rfkill_caveat

I'm not at home right now, but I remember I already runned "rfkill list" and soft blocked and hard blocked was both off.
Also I use a desktop machine and so I don't even have a hard switch for turning off wifi.
Maybe there was a button on the pcie card, but since I put it in my PC, I haven't touched it, so I really don't think that's the problem

Which is also quiet interesting to me, if I look at the ouput of:

lspci -k

it detects that the driver is in kernel module iwlwifi, but it's not in use, as it should be

Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a)
        Subsystem: Intel Corporation Wi-Fi 6 AX200
        Kernel modules: iwlwifi

Furthermore if I run

ip link

there isn't even a network interface created for my wlan, only for my ethernet connection

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether b4:2e:99:4e:ed:cb brd ff:ff:ff:ff:ff:ff
    altname enp4s0

and so I'm not even able to activate or set up one with something like

ip link set wlan0 up

Have you tested newer kernels or firmware?

This is likely a firmware issue, as that model has been having firmware problems of late.

I just quickly installed Linux 5.7rc5.d0510.g2ef96a5-1 experimental, but all outputs of the commands i mentioned earlier are the same, exept ip link, which is now:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether e6:be:68:c5:cb:d4 brd ff:ff:ff:ff:ff:ff
3: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether b4:2e:99:4e:ed:cb brd ff:ff:ff:ff:ff:ff
    altname enp4s0

so it tried to set up some sort of second ethernet connection, but I don't think that's anything, which is gonna help with my problem
internet
and wifi is still not working :confused:
and my bios version (F50) is also the newest one available

What does this return:

sudo modprobe iwlwifi && sleep 3 && sudo systemctl restart NetworkManager

Returns nothing and also seems to change nothing
Why did you delete this?
https://chromium.googlesource.com/chromiumos/third_party/linux-firmware/+/8fc2ecafa929152d032d5bafa0460c59c74ad930
For me it looked like, it would have been worth a try, but if you don't think so let me know

I deleted it because I think it was more for Bluetooth on the ax200.

If there was no error when you ran that command then that means the iwlwifi driver was loaded successfully. you should have returned an error if it was already loaded. You may be able to raise your adapter now after running that command.

In general I totally agree with you, but if
sudo modprobe iwlwifi
would really load the driver successfully, why can I run this command as often as I want and never receive an error?
Because if the driver would get loaded, the first time I run it, there should be some error if i try it more often than that, because it is already loaded, just as you described.
And even if I add some parameters like --syslog or --verbose I still don't get any output

This also doesn't change the ouput of inxi -N and when I experimented with this stuff a while ago, this was the only reliable indicator I remember, where you could see if the wifi would work or not.

Intel Wi-Fi 6 AX200 driver: N/A

meant the wifi wouldn't work
and if it was I think

Intel Wi-Fi 6 AX200 driver: iwlwifi

it would work

Hate to go OT, but if this is a desktop why not use Ethernet. Powerline Ethernet is the way to go if running cable is an issue.

Yeah looks like I'm stuck without wifi on Linux then...
It's not that of a big deal to me, just wanted to get a bit deeper into wifi spoofing and stuff, which is a little impractical, if you can't use wifi.
But thanks for your answers and suggestions anyway :slight_smile:
Maybe, if such kinds of problems are common with the AX200 (which they seem to be) this is hopefully going to be fixed in some future update

Yes these are relatively new adapters, so over time I would expect kernel support to improve.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by