Internet eratic after update


Since 2 updates or so, my internet connection got erratic. It means that a few minutes after booting, I get a question mark in place of the connectivity icon and internet work when it wants.

I use a usb wifi antenna that uses RTL8814AU drivers. I also use my iphone as a usb router. Both behave the same as mentioned.

I currently run Manjaro 18.0.4, kernel 4.19.59-1-MANJARO and Gnome 3.

Is someone aware of such issue with the latest iterations of the 4.19 linux kernel ? Or is it related to something else entirely ? It used to work flawlessly before.


More info would be nice:

Have you tried a newer kernel like 5.1 or 5.2?

As @Yochanan suggested, try a newer kernel. Start with linux51.

If that's no help, provide the outputs of the following:

inxi -Fxxxz

Please paste them then either highlight the formatted text then click the </> button.
Or but 3 backticks ``` before the pasted text and after.

Thank you for your replies @Sinister and @Yochanan !

Changing kernel to 5.1 changes nothing. It still happens ...

Here is the output of the commands :

$ lsusb
Bus 003 Device 002: ID 8087:8001 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8009 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 05e3:0743 Genesys Logic, Inc. SDXC and microSDXC CardReader
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 05ac:12a8 Apple, Inc. iPhone5/5C/5S/6
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 002 Device 006: ID 04d9:a04a Holtek Semiconductor, Inc. 
Bus 002 Device 005: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 002 Device 004: ID 0b05:1817 ASUSTek Computer, Inc. USB-AC68 802.11a/b/g/n/ac (4x4) Wireless Adapter [Realtek RTL8814AU]
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
$ inxi -Fxxxz
System:    Host: KISS-Computing Kernel: 5.1.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: Gnome 3.32.2 
           wm: gnome-shell dm: GDM 3.32.0 Distro: Manjaro Linux 
Machine:   Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
           Mobo: ASUSTeK model: MAXIMUS VII HERO v: Rev 1.xx serial: <filter> UEFI: American Megatrends v: 3201 
           date: 01/24/2017 
CPU:       Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 63988 
           Speed: 1299 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 1298 2: 1300 3: 1299 4: 1300 5: 1299 6: 1302 7: 1300 
           8: 1301 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: ASUSTeK driver: nvidia v: 430.26 bus ID: 01:00.0 
           chip ID: 10de:13c0 
           Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: gnome-shell resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 direct render: Yes 
Audio:     Device-1: Intel 9 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:8ca0 
           Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fbb 
           Sound Server: ALSA v: k5.1.18-1-MANJARO 
Network:   Device-1: Intel Ethernet I218-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0 
           chip ID: 8086:15a1 
           IF: eno1 state: down mac: <filter> 
           Device-2: ASUSTek USB-AC68 802.11a/b/g/n/ac (4x4) Wireless Adapter [Realtek RTL8814AU] type: USB 
           driver: usb-network bus ID: 2-10:4 chip ID: 0b05:1817 serial: <filter> 
           IF-ID-1: enp0s20u9c4i2 state: up speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 2.51 TiB used: 161.81 GiB (6.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08Y20A0 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 1A02 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08Y20A0 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 1A02 
           ID-3: /dev/sdc vendor: Crucial model: CT500MX200SSD1 size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> rev: MU02 
           scheme: MBR 
           ID-4: /dev/sdd vendor: Crucial model: M4-CT256M4SSD2 size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: 070H 
           scheme: MBR 
           ID-5: /dev/sde type: USB vendor: Generic model: STORAGE DEVICE size: 3.69 GiB serial: <filter> rev: 0828 
           scheme: MBR 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020 bus ID: 00:1f.2 chip ID: 8086.2822 
           rev: N/A 
           Supported md-raid types: raid1 
           Device-1: md126 type: mdraid status: active Components: online: sdb~c1 sda~c0 
           Info: raid: mirror blocks: 976759808 report: 2/2 UU chunk size: N/A 
           Device-2: md127 type: mdraid status: inactive Components: online: N/A spare: sdb~c0 
           Info: raid: sda[1](S) blocks: 5552 report: N/A chunk size: N/A 
Partition: ID-1: / size: 52.76 GiB used: 37.30 GiB (70.7%) fs: btrfs dev: /dev/sdd3 
           ID-2: /home size: 170.28 GiB used: 123.13 GiB (72.3%) fs: btrfs dev: /dev/sdd4 
           ID-3: swap-1 size: 14.96 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdd2 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 48 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 5% 
Info:      Processes: 338 Uptime: 3m Memory: 15.60 GiB used: 2.39 GiB (15.3%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           clang: 8.0.0 Shell: bash v: 5.0.7 running in: gnome-terminal inxi: 3.0.34 

Try rtl8814au-dkms-git from the AUR.

That's exactly what I'm using. But the issue still exist even if I use usb ethernet and disable wifi (thus using another network driver).

does this happen both with and without the vpn connected?

That's it ! Booting with VPN disabled fixed it.

Do you know what could be wrong ? How I can keep VPN AND network ?? ^^

1 Like

What VPN are you using?

:point_up_2:which vpn, and what client are you using to connect to it?
does waiting to start the vpn until after the system is fully booted also have the same behavior?

@Danielsuarez369 & @dglt

I'm using Riseup VPN -

And yes, booting without VPN and enabling it after the system is fully booted has the same output.

so your having a VPN issue with dropping connections.

Currently, RiseupVPN is only packaged for Linux using snap .

is that what your connecting with?

next time the vpn connection drops, check the log and post anything relevant

Yes I've installed the Snap package.

There's nothing in the log file when the connection drops, although there are some lines when it starts or is disabled.

I've read in their wiki that their VPN is very experimental at the moment, so I don't think I will bother to tinker more with it. Except if you've got a genius idea to share, I will stop using it altogether... Sorry to have bothered, I assume my setup is too specific for their experimental client to work flawlessly...

Thanks anyway :slight_smile:

i dont use snaps and dont ever intend to. if you want a good solid vpn give a try. as far as privacy goes you dont even give them an email address. connection speeds are awesome and they have wireguard servers.

I concur. I use network-manager-wireguard-git from the AUR with Mullvad. They also have an official app which is in the AUR as mullvad-vpn. Or you can use my improved version: mullvad-vpn-bin. :grin:

Thanks guys :slight_smile:

I will definitely consider Mullvad :wink:

the mullvad GUI app now also works with wireguard servers as well.

Yep. I just prefer managing my VPN via Network Manager. It's easier to toggle it on / off when needed. Also Wi-Fi networks with walled gardens often won't load the login portal with it connected, so I wait to enable the VPN until after I'm logged in.

the app also seems to break the wg-quick functionality. i've tried removing the app, reinstalling all wireguard packages and configuration files and still nothing. this is the first time i used the app just to test it out, damn you GUI! :angry:

now it's "RTNETLINK answers: Operation not supported" when i try to connect in cli.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by