internet / Network problems + printer not found

Hello everyone,

First, sorry for the long post and maybe stupid question.

I have almost no real computer skills but Winsows is just not doing it anymore for me. So I've been playing around with linux for a wile and came to the conclusion that manjaro might be the distro for me. (Before I installed Manjaro I ran Fedora 31, POP!_OS 19.10, Elementary 5.0 and Ubuntu 18.04 and all systems worked fine, so I'm pretty sure it's not the hardware.)
I have installed Manjaro Gnome on one of my laptops and everything seemed to be fine. I was able to create my user acount, run the updates, get some programs through pamac and install and tweak LibreOffice. After rebooting the pc to see if everything was in working order I wanted to link my printer.(using a wireless connection to the internet, yes not optimal but I'm not able to get a cable) For some reason Manjaro doesn't find my printer nor does it connect to the internet in general.

Now to the question.
Is there anything I can do to fix my network connection? I have the feeling that it is the root of my problems. My windows computer and Android phone do not have any connectivity problmens so I know its not the router or the wireless-disk.

Manjaro seems a realy nice OS/Distro and I would like to start learning the terminal syntax.
I'm using the latest stable version with GNOME GUI.

Thanks in advance.

Kind regards,
Alastor

Ps.: Please excuse te bad typing, englisch isn't my main language.

I'm using a HP Envy notebook with
CPU: Intel core i5-3230M CPU @2.60GHz x4
GPU: Intel HD Graphics 4000 (IVB GT2)
RAM: 6GB
Harddrive: 750GB

can you please open a terminal and reports

inxi -Fxxxza 

okey, what should I be looking for?

System:
  Host: hp-manjaro Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=704cad60-beb1-4b0c-9157-41dc52b0dc2d rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Gnome 3.36.3 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP ENVY 15 Notebook PC 
  v: 0887100000305B00000320100 serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: Hewlett-Packard model: 1961 v: 93.51 serial: <filter> UEFI: Insyde 
  v: F.56 date: 04/23/2014 
Battery:
  ID-1: BAT0 charge: 32.3 Wh condition: 48.9/48.9 Wh (100%) volts: 11.3/11.1 
  model: Hewlett-Packard Primary type: Li-ion serial: <filter> 
  status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20756 
  Speed: 1197 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1203 
  3: 1212 4: 1198 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: NVIDIA GK208M [GeForce GT 740M] vendor: Hewlett-Packard 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1292 
  Display: x11 server: X.org 1.20.8 driver: nouveau compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.0.7 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:
  Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe 
  vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 port: 4000 
  bus ID: 07:00.0 chip ID: 1814:3290 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 bus ID: 0e:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
Drives:
  Local Storage: total: 698.64 GiB used: 8.75 GiB (1.3%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541075A9E680 
  size: 698.64 GiB block size: physical: 4096 B logical: 512 B 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A590 scheme: GPT 
Partition:
  ID-1: / raw size: 690.15 GiB size: 678.31 GiB (98.29%) 
  used: 8.57 GiB (1.3%) fs: ext4 dev: /dev/sda3 
  ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 10 (default 60) cache pressure: 100 (default) dev: /dev/sda4 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: 0.0 C gpu: nouveau temp: 33 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 248 Uptime: 1m Memory: 5.70 GiB used: 950.4 MiB (16.3%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: zsh v: 5.8 
  running in: gnome-terminal inxi: 3.0.37

check also if rt816* in cat /etc/blacklist.conf

change to r8169
check if internet- network is ok

kernel 5.6 is EOL ( not more update )

you add after change in blacklist and reboot and internet ok

sudo pacman-mirrors --continent 
sudo pacman -Syyu
sudo pacman -S linux56-headers 

sudo mhwd-kernel -i linux54 
sudo pacman -S linux54-headers 
sudo mhwd-kernel -i linux419
sudo pacman -S linux419-headers 

reboot and press Esc , in Grub select detail > choose kernel5.4 or 4.19

each version kernel use proper firmware , status drivers r816* are not the same , check always for any kernel versions , keep always 2 versions or more

see for search about r8168 r8169
https://archived.forum.manjaro.org/search?q=r816

I'm realy feeling like an idiot.

"sudo mhwd -i kernel54"
gives:
Error: invalid use of option: -i/--install

~ >>> sudo mhwd -i kernel54                                                                                                                          
Error: invalid use of option: -i/--install

Usage: mhwd [OPTIONS] <config(s)>

  --pci					list only pci devices and driver configs
  --usb					list only usb devices and driver configs
  -h/--help				show help
  -v/--version				show version of mhwd
  -f/--force				force reinstallation
  -d/--detail				show detailed info for -l/-li/-lh
  -l/--list				list available configs for devices
  -la/--listall				list all driver configs
  -li/--listinstalled			list installed driver configs
  -lh/--listhardware			list hardware information
  -i/--install <usb/pci> <config(s)>	install driver config(s)
  -ic/--installcustom <usb/pci> <path>	install custom config(s)
  -r/--remove <usb/pci> <config(s)>	remove driver config(s)
  -a/--auto <usb/pci> <free/nonfree> <classid>	auto install configs for classid
  --pmcachedir <path>			set package manager cache path
  --pmconfig <path>			set package manager config
  --pmroot <path>			set package manager root

~ >>> sudo pacman -S linux54-headers                                                                                                              [1]
resolving dependencies...
looking for conflicting packages...

Packages (1) linux54-headers-5.4.44-1

Total Download Size:    9,43 MiB
Total Installed Size:  46,85 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
error: failed retrieving file 'linux54-headers-5.4.44-1-x86_64.pkg.tar.zst' from manjaro.ynh.ovh : Resolving timed out after 10000 milliseconds
error: failed retrieving file 'linux54-headers-5.4.44-1-x86_64.pkg.tar.zst' from ftp.free.org : Resolving timed out after 10000 milliseconds
error: failed retrieving file 'linux54-headers-5.4.44-1-x86_64.pkg.tar.zst' from ftp.vectranet.pl : Could not resolve host: ftp.vectranet.pl
warning: failed to retrieve some files
error: failed to commit transaction (invalid url for server)
Errors occurred, no packages were upgraded.

Okey, internet seems to be fixed and the kernels are installed.
Many thanks.

But for some reason GRUB doesn't appear when I boot. Is there an other way?
(this starts to feel like a bad joke, I'm terribly sorry)

does your system boot into the desktop but you see no grub is that the issues? that's easy to fix

that is to say it is working as intended... no reason to see grub unless you boot more than one system or ahave installed more than one kernel and wish to chose between them.

Are you wishing to choose between them?

you need to edit grub

well that's the issue, I want to switch kernels do to mine being EOL

1 Like

In this thread it says to hit esc or shift during boot to show grub so you can select the kernel you wish. Grub will show and you can select the kernel you want... and then you can go back to hiding the grub

or

GRUB_TIMEOUT_STYLE="hidden"

Replace in your /etc/default/grub file this line by GRUB_TIMEOUT_STYLE=menu using a normal editor like nano. Afterwards, sudo update-grub and reboot.

then run sudo update-grub and you will always and forever more see your grub on boot.

So, my system just died. I think I managed to gat a "bluescreen" in Linux XD

" Oh no! Somthing has gone wrong.
a problem has occurred and the system can't recover. Please contact a system admin"

turn it off for a few seconds and turn it back on take a deep breath

yeah, tried that, doesn't work.
Might need to reïnstall Manjaro , really hoped I wouldn't need to do this.

One thing we know, Manjaro is turning in to quite the adventure.
But I kinda don't want to go through al the crap of reïnstalling and tweaking everything.
Well thank God for coffee because I ain't gonna get anny sleep tonight.

what happens when you tried to boot manjaro? what did you see on your screen?

first black screen,
then the HP logo,
and finally the error message on a white background.

" Oh no! Somthing has gone wrong.
a problem has occurred and the system can't recover. Please contact a system admin"

tried to boot out of BIOS settings
( Esc, F9, Manjaro EFI)
same result

BAH!

Well you could follow the instructions to chroot into your system and see if you can even get in... or even boot from a livecd/dvd and see if you can access any of the partitions.. thats wherre i would start

Your kernel installation syntax posted earlier was incorrect, try:

sudo mhwd-kernel -i linux54 

So I did a complete clean reinstall of Manjaro. Was able to install my necessary programs and tweak them to my liking. This time I didn't need to manually partition my drive.

I also downloaded kernel 5.4.44-1 and 4.9.126.1 with Manjaro settings manager. (So far so good)
I noticed that my internet connection is still problematic and gets worse when I run on battery power. Is this connected to my kernel? (Currently running 5.6.16-1) If so, How do I get my Grub menu back to change it?

/etc/default/grub

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden

And would I still need to get that "blacklist r8169" file?

echo -e "blacklist r8169" | sudo tee /etc/modprobe.d/r8169_blacklist.conf

so yeah change the style from hidden to menu and i think your grub should show be sure to run sudo update-grub afterwards so that it takes effect on next boot.

are you using r8168 ? if you want to use r8168 you need to blacklist 89

Oftentimes if your network connection behaves differently on battery power this could be an issue with tlp.

Read this regarding tlp:

If memory serves I don't have tlp installed or activated.
tried it anyway. didn't work. Still network-problems when on battery power.

Forum kindly sponsored by