internet / Network problems + printer not found

To be fair I don't know what this r8168 / r8189 thing is, so could you tell me what it does or why I might need to change from 68 to 89?
I got the tip from stephane that this might help fix my network problem.
And I'm a bit held back from installing things that I don't know what they do, do to my system having crashed. And I really don't what to go over everything again, it's cumbersome and it takes a lot of time I can't afford to lose right now.

You'd want to peruse the entire thread linked... it's the driver for your internet. one is baked into the kernel and the other is not... if the one baked into the kernel isnt working properly then you can try the other.

[quote="LizziAS, post:22, topic:151475"]
peruse the entire thread linked
where can I find the thread?



May 24

Wrong way, use mhwd to install the driver.

Uninstall the dkms driver version you installed, then reboot.

Then do:

sudo mhwd -i pci network-r8168 


After a restart, do:

sudo modprobe -r r8168 && sleep 3 && sudo modprobe r8168 && sudo systemctl restart NetworkManager

If that command works to restart your r8168 adapter then the command can be automated by writing a service to reload your driver at startup.

Aragorn reacted with :point_up:

2 Replies

after that then you'll want to black list the other or maybe before...

Thanks for the info, gonna give it a try.

Does the Manjaro wiki have a manual with every step I need to take? Because I don't know how to uninstall dkms drivers. Nor do I know how to write a service to automate that command string.

I presume that you blacklist the other dkms by using:

echo -e "blacklist r8169" | sudo tee /etc/modprobe.d/r8169_blacklist.conf

Sorry if I sound like a complete moron, Linux is quite new to me.

if you copy and paste that entire line into a terminal it should take care of it for you

same for the two commands in the post above that one too

TBG is much more skilled than i and if you read the thread in its entirety he's the one who told me what to do so follow whatever they say..



Oftentimes if your network connection behaves differently on battery power this could be an issue with tlp.

Read this regarding tlp:

1 Reply

I followed your advice and copied the terminal commands. Internet still doesn't function when I'm on battery power.

First a very big thank you to all who have taken the time to try and help me to fix this problem. Even tho it doesn't work yet, I still want to thank you. I really love the Linux community, and the willingness to help a complete noob to fix his stupid problems.

But as I said, my internet is still no working when I run on battery power. :disappointed_relieved:

(A quick summary for all who is new to my problem. I have replaced my kernel (5.6.16-1 to 5.4.44-1) and my network drivers (r8169 to r8168). But my computer still doesn't connect to the internet when I'm running on battery power.)

I'm sorry, but I think you are mistaken about tlp not being installed with Gnome on Manjaro.

Generally TLP is installed by default on any laptop with Gnome on Manjaro. On new installs on desktop computers TLP may not be installed, but with a laptop it likely is.

You need to double check if tlp is installed (as it most probably is). Then you can mask tlp, or simply uninstall tlp to see if the battery issue goes away. That is not a proper fix though, as a power manager (tlp or other) is required on a laptop.

The best solution is to go through tlp's battery power settings and systematically change any setting regarding battery power and bluetooth/wifi. You can install tlpui if you do not want to edit tlp's root config file.

Be sure to reboot after changing only one setting at a time. Then check for results of the change after rebooting.

Many of the Ralink/Mediatek adapters currently seem to be having issues with their driver. The best chance for a fix is to test different kernel models. It might also be a good idea to try a real time kernel in this situation.

Testing older versions of the linux-firmware package may also be a possible fix for wonky wifi. You can search "downgrade linux-firmware" if you wish to test this method.

You can also try this fix:

Disable Network Manager's Power Saving

Disable Network Manager's WiFi power saving features with the following command:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

A setting of "0" will totally disable power saving features in Network Manager for your WiFi adapter. A setting of "2" or "1" will be less aggressive, but still leave power saving enabled. A setting of 2 is sometimes enough to eliminate problems, while decreasing battery life very little. A setting of "0" does increase power consumption marginally, but not enough to be a big issue.

Reboot after creating the /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf file.

This change will marginally increase your WiFi's power usage, but it may help with your issue. If you wish to revert the changes completely then delete the file:


1 Like

That is a powerhouse of great advice

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by