internet not working on browser, but cloud service..

ok! yes the forum I cannot ping, but the

ping -c4 46.43.9.146

connects...

is there a way to clean this up?

46.43.9.146 is the ip archived.forum.manjaro.org points to (at the moment). So it is a dnsproblem.
Please post output of

$ cat /etc/resolv.conf

cat /etc/resolv.conf

Generated by NetworkManager

nameserver 10.11.0.1
nameserver fdda:d0d0:cafe:1197::

Are this the IP's of your Router? Do you use a VPN or did you use a VPN in the past.

Can you ping both addresses. It is not that common for a DNS server to listen on the Subnet-Router anycast address. But a Home Router might do that.

As a work around add a DNS server in the conection config, like 1.1.1.1,8.8.8.8,9.9.9.9 or any other DNS server you trust.

If you have a working DNS you can install bind-tools and try to test the local DNS Server with

dig archived.forum.manjaro.org @10.11.0.1

or

dig archived.forum.manjaro.org @fdda:d0d0:cafe:1197::

yes i was using in the past mullvad, a vpn service. maybe that is the reason!

I will try your advice tomorrow when i m back on the desktop.

ok back on my desktop.

how do I put 1.1.1.1,8.8.8.8,9.9.9.9

into the config?

when I just write it into the resolv.conf, nothing changes. sorry I am bad with that stuff..

This are just 3 example IP addresses for public DNS Server. 1.1.1.1 is the cloudflare, 8.8.8.8 is Google and 9.9.9.9 is from IBM, PCH and GCA. You can use any DNS server IP you trust. Just pick one.

You need to open /etc/resolv.conf in a editor, like nano, and add a line like this

nameserver 1.1.1.1

The order of the entries are important. Make sure you put your line at top of the older entries. Only put one IP address after the nameserver key word.
You need to use sudo since you need root premissions to make changes in resolv.conf.

2 Likes

perfect, I got it, thank you so much!! and internet is back :slight_smile:

Glad your problem got solved.

Just to clarify: it was never gone. Name resolution was though. It's like loosing your telephone book - you can call any number, you just don't know which ones belong to your contacts.

1 Like

another thing: how can I keep a dns configuration? I typed in for example

nameserver 1.1.1.1 and saved

but everytime i restart the computer the resolv.conf shows the old non-working configuration again

The config showed:

Rather than directly editing the configfile try adjusting network settings in NetworkManager.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

I d like to give some feedback , although I got this solved, on my follow up issue i have since then:

The config showed:

Rather than directly editing the configfile try adjusting network settings in NetworkManager.

I do have the problem, that whatever i type in to the network manager, after reboot I do have the old (wrong ) configuration and the dns server adress missing. Any idea what i could do about this?

thank you!

Sometimes it helps to completly remove the connection in NetworkManager alltogether to let it redetect/recreate it.
Other than that, I'm out of ideas :white_flag:

You can make /etc/resolv.conf immutable so that NM can not alter it.

To write protect resolv.conf nameservers:

Change your nameservers by editing /etc/resolv.conf . Once you have made your edits, write protect that file.

chattr +i /etc/resolv.conf

The +i option (attribute) write protects the /etc/resolv.conf file on Linux so that no one can modify it - not even the root user.

If you need to remove the write protect attribute, use the following command.

chattr -i /etc/resolv.conf
1 Like

Here is another alternative that does not require write protecting /etc/resolv.conf. As an alternative to making resolv.conf immutable, you can instead set it to be overwriten by a Network Manager dispatcher script. You can have whatever custom nameservers you want written to /etc/resolv.conf whenever your connection is started.

Override the /etc/resolv.conf defaults set by Network Manager:



Create the Network Manager dispatcher script:

/etc/NetworkManager/dispatcher.d/nameserver.sh

With the following contents (set the address of any nameserver you prefer):

#!/bin/bash
#
# Override /etc/resolv.conf
#

echo "nameserver 127.0.0.1" | sudo tee  /etc/resolv.conf

Save the script, then make the script executable:

sudo chmod +x /etc/NetworkManager/dispatcher.d/nameserver.sh

Then, set the proper ownership and permissions for the script:

sudo  chown root:root /etc/NetworkManager/dispatcher.d/nameserver.sh && sudo  chmod 755 /etc/NetworkManager/dispatcher.d/nameserver.sh

Also, be sure the networkmanager-dispatcher.service is is enabled:

systemctl status NetworkManager-dispatcher.service

If the service was not already started then you must enabled it:

sudo systemctl enable --now NetworkManager-dispatcher.service

If you wish to write more than one nameserver to /etc/resolv.conf, then substitute the following line for both the Cloudflare servers:

echo -e "nameserver 1.1.1.1\nnameserver 1.0.0.1" | sudo tee /etc/resolv.conf

Or:

Substitute this line in the script if you would prefer to use Google's name servers:

echo -e "nameserver 8.8.8.8\nnameserver 8.8.4.4" | sudo tee /etc/resolv.conf
1 Like

thank you so much for these suggestions, I will try when I m back on my desktop and will give it a try!

1 Like

The chattr method is rather brute force and some think it excessive. The Network Manager dispatcher script method is far more elegant but a little more work.

The advantage of the dispatcher method is you don't have to remember some obtuse command that you rarely ever use when you want to change your nameservers.

1 Like

thank you all. I was going for now with the "quick and dirty solution" till i find more time to blend over to the elegant solution.

thanks and stay safe everyone!

1 Like

Forum kindly sponsored by