Internet working slower than on Windows 10, definitely not bias!

Hi! I have been using Ubuntu for many years now and I've dual booted Manjaro with Windows 10 now. For some reason websites load a lot slower on Manjaro than Windows and I haven't experienced this in Ubuntu before. I don't know where to really start, I've done some basic stuff like changing the ipv4 DNS and ipv6 to the one cloudflare mentions on their website. But that hasn't fixed the issue. At times the internet is so slow that youtube videos won't even load on my gigabit connection and I'll have to refresh the page several times in frustration.

Here's some basic info that may or may not be useful:
(I've combined three images below with a line separator since I can't post more than one image because I'm new :frowning: )

Try this and reboot, make a test and see if it is better

You can copy and paste the terminal output here ,see link for more info.

1 Like

Hi there. Please post your specs in text format (not images).

Post output of:

inxi -Fxzc0

Without more info here's a simple tip. Completely power down computer and router, unplug power supplies and LAN cable. Switch in a different LAN cable. Put all plugs back in and restart all.

It's very hard to work from pics, but it looks like it says your default gateway is Shouldn't that be for the default gateway.

You should also try blacklisting the r8168 driver, and test your NIC using the r8169 driver.

1 Like

Sure, I'll keep that in mind for the future. :slight_smile:

1 Like

Here's the output from inxi -Fxzc0: (I'll try to blacklist the r8168 driver and test using r8169)

[ares@pc ~]$ inxi -Fxzc0
System:    Host: pc Kernel: 4.14.54-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.1 Desktop: Gnome 3.28.2 
           Distro: Manjaro Linux 17.1.11 Hakoila 
Machine:   Type: Desktop Mobo: MSI model: B350M GAMING PRO (MS-7A39) v: 1.0 serial: <filter> 
           UEFI [Legacy]: American Megatrends v: 2.G0 date: 04/27/2018 
CPU:       Topology: Quad Core model: AMD Ryzen 5 1400 bits: 64 type: MT MCP arch: Zen rev: 1 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 59223 
           Speed: 3112 MHz min/max: N/A Core speeds (MHz): 1: 3112 2: 2983 3: 2974 4: 2982 5: 2961 6: 2976 
           7: 2975 8: 3008 
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X] 
           driver: amdgpu v: kernel bus ID: 1f:00.0 
           Display: x11 server: N/A driver: amdgpu resolution: <xdpyinfo missing> 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.19.0 4.14.54-1-MANJARO LLVM 6.0.0) 
           v: 4.5 Mesa 18.1.3 direct render: Yes 
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 580] driver: snd_hda_intel v: kernel 
           bus ID: 1f:00.1 
           Card-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel v: kernel 
           bus ID: 21:00.3 
           Sound Server: ALSA v: k4.14.54-1-MANJARO 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 v: 8.045.08-NAPI 
           port: f000 bus ID: 1b:00.0 
           IF: enp27s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    HDD Total Size: 1.14 TiB used: 17.90 GiB (1.5%) 
           ID-1: /dev/sda vendor: Western Digital model: WDS250G1B0A-00H9H0 size: 232.89 GiB 
           ID-2: /dev/sdb vendor: Hitachi model: HGST HTS541010A9E680 size: 931.51 GiB 
Partition: ID-1: / size: 65.90 GiB used: 17.90 GiB (27.2%) fs: ext4 dev: /dev/sda6 
           ID-2: swap-1 size: 2.93 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 42.1 C mobo: N/A gpu: amdgpu temp: 38 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 725 
Info:      Processes: 240 Uptime: 1m Memory: 7.81 GiB used: 1.29 GiB (16.5%) Init: systemd Compilers: gcc: N/A 
           Shell: bash v: 4.4.23 inxi: 3.0.12 

So I tried blacklisting the r8168 driver and remade the image using mkinitcpio -g IMAGE and rebooted. Then I ran inxi -Fxzc0 to make sure that driver line under 'Network' said r8169 but I noticed no difference in webpage loading times. So I read and found out that my card is a known nuisance. It recommends trying to switch off IPv6 to see if that helps, I tried opening the network settings GUI in Manjaro and setting IPv6 to 'disable' and rebooted for both r8169 and r8168 drivers. I did not make any configuration file changes to meddle with IPv6 though. Nothing is making a difference. Could you please expound upon your default gateway not being thought? My Win10 ipconfig yields the following:

Ethernet adapter Ethernet 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : Home
   Link-local IPv6 Address . . . . . : fe80::298b:5426:1c30:8f04%6
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

I noticed that the default gateway is indeed which is the same on Manjaro, so I don't know if that is a problem.

By the way, my /etc/dhcpcd.conf looks like:

# Use the hardware address of the interface for the Client ID.
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
# Some non-RFC compliant DHCP servers do not reply with this set.
# In this case, comment out duid and enable clientid above.

and NOT:

# Use the hardware address of the interface for the Client ID.
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
# Some non-RFC compliant DHCP servers do not reply with this set.
# In this case, comment out duid and enable clientid above.

as per @bogdancovaciu 's instructions, although that hasn't fixed the issue. Thanks for the help though bogdan.

If you go into the connection properties in Network Manager and select IPv4 tab on the right side. You should be able to set your default gateway to Perhaps your router is different, but every router I've had uses that as the default gateway out of the box.

Also while you're in your connection properties disable IPV6 from within network manager.


Thanks for the reply! Do those network changes need a reboot to take effect?

It worked! I disabled IPv6 and disabled and reenabled the connection and somehow my DNS is set to but it works like a charm! :slight_smile: Thanks everyone for their help.

1 Like

That means you are getting your DNS from your router. Lookup how to override that via something like the Arch Wiki ... or go change your routers DNS settings.


That was the first step. And as was said here


The connection should be set to Automatic on IPV4 if the router works as DHCP server.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by