Invalid or Corrupted Package while Trying to Do Full System Upgrade

Hi. I tried to do a full system upgrade. Now using kernel 4.19.59-1. I got an error message that says, "Error: could not open file /var/lib/pacman/local/dnsmasq-2.80-3/desc: No such file or directory", then when I click the Apply button, I get an additional "Invalid or corrupted package".

I also tried Jonathon's "nuclear option" Invalid or Corrupted Package

sudo rm -fr /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Syyu

but I still get the same error message.

Can someone please help me?

See here for information on how to solve this issue:

3 Likes

thank you @bill_t! I will try this out.

1 Like

Hi @bill_t. Didn't work.
After doing step # 4
error message is still this

sudo pacman -S dnsmasq
resolving dependencies...
looking for conflicting packages...
error: could not open file /var/lib/pacman/local/dnsmasq-2.80-3/files: No such file or directory
warning: could not fully load metadata for package dnsmasq-2.80-3
error: failed to prepare transaction (invalid or corrupted package)

The good side of it is I now understand which package not to include in updates so I can continue updating the other packages hehehe. :grin:

sudo rm -fr /var/lib/pacman/local/dnsmasq-2.80-3

sudo pacman -U http://mirror.inode.at/manjaro/stable/extra/x86_64/dnsmasq-2.80-4-x86_64.pkg.tar.xz

sudo pacman-mirrors -f5 && sudo pacman -Syyu

1 Like

thanks @admdb! it worked!

Just in case you encounter the same error again in the future (hopefully not).
The instructions from the linked thread did work, but you got the same error for a different file this time.

In this case you should have repeated the steps from the linked thread for this file as well

sudo touch /var/lib/pacman/local/dnsmasq-2.80-3/files

and then proceeded with the system update.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by