invalid or corrupted package:

I got the notification about updates available for my installed applications and when I try to update them with Pacman gives the warning Warning: dependency cycle detected:
Warning: bashrc-manjaro will be installed before its bash dependency
but still continues with the update. This is normal as Pacman knows how to counter the issue but when all the updates are downloaded and it checks their integrity, it shows that some package is corrupt. It also happens when I try to download a new package. I have already refreshed the keys once but it doesn't seem to work. I am going it again but if there are any other suggestions, I would love to hear them. Thanks in advance!

You could remove possible partially downloaded packages with:
sudo find /var/cache/pacman/pkg/ -iname "*.part" -exec rm {} ;
and then:
sudo pacman-mirrors -f7 && sudo pacman -Syyu

If that doesn't help, clean the pacman cache from currently not installed packages, by running:

sudo pacman -Sc
and then
sudo pacman -Syyu
to update.

If still no joy, clean the whole cache:
sudo pacman -Scc
followed by
sudo pacman -Syyu

1 Like

The first command gives an error : find: missing argument to `-exec'

Try putting a \ right before ; at the end (no space in between).

You may achieve the same result with:
sudo rm /var/cache/pacman/pkg/*.part

4 Likes

Thank you so much. The command worked.

1 Like

Thank you, had the same problem, worked perfect, just with the \ before ;

1 Like

I think there have been problems with a mirror that caused this. At least I had to update the mirrorlist.

Thank you @Marte! Cleaning the cache worked for me. So thank you again!!

1 Like

Glad that you got your issue resolved!

And welcome to Manjaro community!

:bouquet:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by