Is it possible that Manjaro is blocking a W10 installation?

So i got rid of my w10 and migrated to Manjaro. I have been using it for some weeks now so I am a complete noob. Today I decided to try to make a dual-boot to also have a w10 disponible when I need it. When I try to boot the USB to install it gives me errors when selecting the disk. It says it can't create a new partition on the disk and give me an error code that I could not find anywhere on google "error 0xf0460570". I tried all solutions I could find for disk errors on windows installations like creating the partition though commands, changing the disk format, etc.

I'm thinking that my Manjaro installation could have something to do with it cuz when i turn my pc on it opens this.

86801597_219053175912369_52494387371835392_n

I don't have any w10 in any disk but i show those two there, when i try to open just give me an

"error: no such device: 44R46945A4693A96

Setting partition type to 0x83

error invalid signature

Press any key to continue"

Then send me back to the screen of the photo when I press anything.
Could it have something to do with this? And if so how can I fix it?

Model: ATA TOSHIBA MK5075GS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  500GB  500GB  primary


Model: ATA TOSHIBA HDWD110 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 1      1049kB  525GB   525GB  primary  ext4
 2      525GB   1000GB  475GB  primary  ntfs


Model: ATA SanDisk SSD PLUS (scsi)
Disk /dev/sdc: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  231GB  231GB   primary  ext4
 2      231GB   240GB  9449MB  primary  linux-swap(v1)


Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdd: 7799MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      4194kB  7798MB  7794MB  primary  ntfs
 2      7798MB  7799MB  524kB   primary               lba 

Please boot into your Manjaro, open a terminal and run the following command:

sudo parted -l
(that is lowercase L)

Copy the whole output and post back here. Use </> button to format for better readability. This will give community members some info on your disk set-up and hopefully some idea about how to assist you to solve the issue.

1 Like

I edited the post w/ the results. Thank you for your help.

First install Win 10, then Manjaro.
Probably data from the boot sector/MBR are displayed.

And then always read the instructions.
Especially if you are a beginner.

Windows doesn't know any other formatting than its own so it thinks that there is no space on the hard disk.

Do I really have to reinstall everything?
I'm not formating the drive on Manjaro. The problem is that the w10 disk management doesn't seem to be able to format it, except by using the ■■■■■■■■ and doing it by cmd. And even wen is formated there is not able to install.
I read all the instructions I could find when was migrating. I decided to make the dual-boot like today.

:man_shrugging:

Go back into the disk utility in Manjaro and erase the NTFS partitions you made. Create a new partition on the desired disk and leave it unformatted. If you are going to shrink your existing Manjaro partition then you will need to use a live USB to do so. Then go back into the Windows installation and select that partition and format from the Windows installer. Make sure you are using the proper configuration between x86 or x64, MBR/BIOS or GPT/EFI. If you are still experiencing issues it could be a bad Windows ISO. Make sure you are using the ones from the Microsoft website and that you are writing them using WoeUSB.

Also, be aware that when you install Windows, it will erase GRUB bootloader. You will need to boot from a Manjaro live USB again to put it back.

If your machine can run VirtualBox, that might be the easier option. But whatever you do, don’t hijack your integrated graphics.

2 Likes

Probably not. But the reality is, you admitted in post 1 you're a complete noob. Unfortunately, as @SGS suggested. Windows doesn't understand anything except that everything should be Windows all of the time. The concept of dual boot doesn't even exist in Windowsland. It's very highly recommended if you intend to dual boot W10 and (as far as I know) any Linux distro, you always install W10 fist. Even if you manage to somehow get all of W10 installed afterwards, it will almost certainly break your grub menu, and a whole host of other issues for you to then work through after. By far your easiest course of action would be to backup anything special currently, and then install W10, and then follow the information setup in the Manjaro wiki to dual boot.

4 Likes

I downloaded 2 .iso on the Microsoft website in different languages (English and Portuguese) and both i made on WoeUSB using different flashdrives (just in case) I tried to leave a disk unformatted and leave an open space on another, the same problem occurred in all instances.
Thank you very much for your help though.

Hmmm. I’ve done reverse dual boots (installing Windows after Linux) before and haven’t ever had this issue. I am going to have to agree with the rest of the community in this case, reinstall Windows 10 as the only OS on the drive and then run the Manjaro installer. You can preserve your current Manjaro system on another USB with timeshift and then restore it after the installation has finished.

You’re welcome. We’re always happy to help here at the Manjaro forums.

2 Likes

Not saying that this is the case, only a hunch.

Since the partition table for all your disks is msdos, perhaps you would need to boot your Windows installation usb in legacy/mbr/bios mode. Could it be that you boot up your usb in uefi mode?

2 Likes

Frequently - I have been seeing issues which appears to relate to the system type.

Many systems - born with Windows - appears to have CSM (Legacy boot) enabled and some vendors appears to install Windows as a BIOS/GPT system rather than EFI/GPT.

This is creating issues hard to diagnose - suffice to say - the two modes are not compatible - from a boot loader point of view.

The only way those two may coexist is if you use the firmware's boot override to select which one to load and even then I am not sure it always play out well.

The only way to ensure compatibility between operating systems is to disable either of them.

It is highly recommended to disable CSM (Legacy boot) and stick to EFI as EFI is the newest standard and the one recommended by Manjaro.

Some will not agree and that is fine by me - those few also knows exactly how to install and configure their system - but the majority of users should really disable CSM in the system's firmware.

This will prevent a lot of hard to troubleshoot issues - and will also make it a lot easier to follow the existing guides - which all assume EFI as the system's device loader.

3 Likes

When you start the computer with one of your Win USBs inserted, does the MS Windows installer actually launch?

And welcome to the Manjaro forum, by the way!

Are you still trying to use the GRUB menu to load windows? If so, stop, use the BIOS to load windows(disable secure boot in the BIOS, enable UEFI in BIOS, different for every computer, try F12 for boot options, or check manufacture for boot option function key). I say because you’ve given no clear details on how you have been trying to boot windows after downloading the WIN 10 ISO.

I’ll YELL it again, STOP TRYING TO LOAD WINDOWS FROM THE GRUB

Yes, it does. He seems to be unable to install in any disk i try.

I wasn't. Sorry if I didn't make the text clear. I was trying to boot through the bios via USB. The problem isn't opening the win 10 installer. He opens just fine. It just seems unable to install te OS in any disk i select.

Can you tell us if the motherboard is old school BIOS or modern UEFI?
If you have UEFI, Windows probably want your drives to be gpt instead of msdos before it will install.
On which drive and partition do you want Windows?

It is a modern UEFI. I was initially trying to instal on the 500gb one (TOSHIBA MK5075GS), but i also tried to instal on the other hdd on the second partition but got the same error.

I know nothing about UEFI, but I would dare to try this:
Use Manjaro to set the 500 Gb Toshiba drive to gpt. Then physically unplug the other drives and launch the Windows USB.

4 Likes

This worked... i don't know why, but worked. I just unplugged and all worked fine. Now is all plugged back again and is still working fine.

2 Likes

Forum kindly sponsored by