Is there a way to get the current stable as a bootable iso for UEFI32?

You may try with 18.1.0-rc8 ISOs.

That did not work.

I found a number of problems with that Howto, starting with the fact that you need to unzip the .7z and put it into the correct place :slight_smile:
I've gotten over the 'unknown file system', but now 'normal.mod' isn't found, although i think i put it anywhere where it would make sense. Does it have to be on the ISO itself, and if so, which path would be the correct one (i think i could figure out that last bit by myself, just asking out of lazyness)

You also need the grub module folder for /boot/grub/i386-efi/ on the liveUSB main partition (not the ESP partition) or it still won't boot. The normal.mod not found is what you get with the right bootia32.efi and the missing folder! Good progress.

okay, will eat first, then smuggle it into the iso and report. :slight_smile:

1 Like

I found better instructions, though at this point, you are almost done!

I'm about to try using Manjarox32 to overlay the .efi folder and i386-efi file onto Manjaro 18.1-rc8 XFCE (64 bit).

Edit: It's easy enough to add bootia32.efi to the EFI partition (MISO-EFI) of the liveUSB, but the iso9660 filesystem is designed as read-only (main liveUSB partition). So it is not practical to delete the i386-pc folder and replace it with the i368-efi folder. My standard hack (with unetbootin) is more expedient. The proper way would be to remaster the ISO.

well, remastering the iso doesn't sound too hard to do, does it?
Trying a manjarox32 install now. do you know if i can later use architect to change the system to 64 bit while keeping the 32bit efi?

Sad to say, I've never used Architect. But an old trick from my debian days was to install a 32 bit ISO first and then re-install with a 64 bit ISO to all the same partitions, but skipping install grub on the re-install. You'd have to override the ESP mount point if you use Calamares. Architect should allow you to skip grub! You'll still need the /boot/grub/i386-efi/ folder, which won't be there unless you do not format root during the second install.

Weidly, i now did a full graphical install of Manjarox32, and get dopped to grub rescue on reboot, compaining about 'no such device: [seemingly random long numerical with hyphens].
I guess something goes wrong with the device labelling?
But i think i'll leave it at that for today.

That sounds like a partition UUID. If you plug your liveUSB back in, it will probably boot, but probably to the liveUSB rather than the new install. One or more partitions were likely pointing to the USB instead of the host storage during the install. The real ESP (efi partition) needs to be assigned a mount point of /efi/boot during manual partitioning.

This guide by one of our grub experts will probably get your system booting. Otherwise...

The output from
sudo blkid
cat /etc/fstab
inxi -Fxxz
would be helpful. These can be run from the liveUSB in a terminal. The fstab should be from the host storage (the root partition of your install) rather than from the liveUSB.

That's the weird thing about it - it was no manual partitioning. Automatic partitioning with encryption and a swap partitition for hibernation. changed almost nothing besides timezones, keymap and such.
And i just did it again with the exact same result.

when shutting down, it did fail to unmount /boot/miso/mnt or some path like that. But other than that i saw no irregularities.

Well, I probably won't be much help then, I've never trusted automatic partitioning! I don't use encryption either. ../miso/.. references something on the liveUSB, so Calamares probably got confused... I always triple check what it claims it is going to do with the partitions. Partition errors are hard to undo.

I updated my last comment with a reference to this popular fix grub tutorial. It does presume that the install was successful except for grub.

Another thought. I remembered that on my baytrail device, it supports an SD card. The complication is that the SD card (mmcblk0) shows up before the main storage (mmcblk2). This confuses most distro installers, which inevitably try to put grub on the wrong device. Further, on my T100, the SD card is off at boot time so grub on the SD card could never work. /home works though.

I still don't know what device you are working with (inxi -Fxxz) or the partitions in question (blkid, lsblk).

What specific hardware are you trying to install to?

I've modified the XFCE 18.1-rc8 liveUSB to boot on my Asus T100CHI which has UEFI32. Calamares defaulted to my SD card (mmcblk0), but I was able to change it to use my actual on-board storage (mmcblk2) instead. This is why I triple check the partitions and use manual partitioning. The first install failed with

Installation Failed

Boost.Python error in job "machineid".

Command 'system-machine-id-setup' died with <Signal.SIGHUP:1>.


File "/usr/lib/calmares/modules/machineid/",line 64, in run check_target_env_call("*systemd-machine-id-setup")

File <"string">, line 3, in <module>

I restarted the installer (again setting efi partition (mmcblk2p1) to /boot/efi and mmcblk2p7 to /), but this time I formatted the root partition. Then the installation worked including grub (UEFI32). The machine rebooted successfully to grub menu and I selected XFCE 18.1.0-rc8 which loaded fine. Except for hacking the liveUSB to add bootia32.efi and the i386-efi grub modules (sourced from mx-linux for my fat32 liveUSB), Manjaro XFCE 18.1-rc8 (64 bit) installed as long as I formatted the root partition. The key was manual partitioning, verifying the right storage device and setting the efi partition.

Asus T100TA

My T100CHI is from the same product family. Boot issues were really common with those transformer 2-in-1's. Please post lsblk from a terminal from the liveUSB.

In fact, three years ago I tried to boot Ubuntu X64 with grub for UEFIia32. The process is not difficult. The main point is to select the correct module when generating bootia32.efi. Usually, bootia32 is generated to integrate all the required modules. Efi would be a good idea, which would avoid quite a lot of trouble later, and finally use grub2 to boot the ISO.
Now, I no longer use that weird UEFI for ia32 tablet, my new tablet uses the normal UEFI for amd64.:grin:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by