Is there any way to make lightdm keep my music playing?

Hi! I'm using Manjaro Linux 18.0.2 XFCE without much modification. Clean installed since 18.0.0.
After some time using my laptop with this, I notice something not really important but would really cool and I think should work because some people say it should work.

I use light-locker (manjaro xfce default lockscreen) and lightdm (manjaro xfce default display manager). However, I see that everything else is run in tty7 while lightdm is automatically launched in tty8.
I use audacious and vlc for music and have tested without any luck.

I don't know any other detail i should give, just tell me what info i need to provide:
System:
Host: ccxex Kernel: 4.19.13-1-MANJARO x86_64 bits: 64
Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux
Machine:
Type: Laptop System: Acer product: Nitro AN515-52 v: V1.19
Mobo: CFL model: Freed_CFS v: V1.19 UEFI: Insyde
v: 1.19 date: 07/13/2018
Memory:
RAM: total: 3.70 GiB
CPU:
Topology: Quad Core model: Intel Core i5-8300H
Graphics:
Device-1: Intel UHD Graphics 630
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]

Play CMus (just an example for console player) in other tty? :wink:

Can they also help?..

Do you need to not stop playing music while locking the screen or something else?

It isn't a solution, but this works on Plasma with SDDM. I don't know if it can work on xfce4 and SDDM..

This can be tuned:
/etc/systemd/logind.conf, parameters NAutoVTs and ReserveVT (default: 6)
/etc/lightdm/lightdm.conf, parameter minimum-vt (default: 7)
Normally you shouldn't need to change those.

Now to your issue.
So you want the music to keep playing even when the screen is locked with light-locker?

1 Like

Maybe you could try this:

I only tried the first option of the linked page

and it worked (using VLC and Audacious).

1 Like

Hi, Adding user to group 'audio' solves the problem. Thanks.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by