Is there only one way to establish direct pppoe connection?

The problem is that I can't connect to the Internet through anything but KDE. I tried XFCE, GNOME, MATE (Gnome 2 descendant). I don't know if it's a bug or as one guy assumed: may be I have not real DSL. I plug in cable directly into network card, no additional equipment.
2-3 years ago I was able to establish DSL pppoe with any DE. But these days those DE's (their GUI network manager) give me Autoethernet in the list of connections instead of what were setting up. In *buntus I had pppoeconf package which saved the day, then they dropped support it (I used command line in this case, though that way I was no able to share Wi-Fi (no easy way at least)).
In Network Manager I select DSL, set service - pppoe, type in login and password.
Is there alternative way to setup such connection (with GUI preferably) in those DE's without acquiring a router?

The principle is the same on each DE. Open up Network Manager (Edit Connections) and click on the + button
image

By default will show the Ethernet one.
image

But you click on it and select the DSL/PPPoE one, from the list, and then click Create
image

image

The rest should be straight forward, chose the correct interface, username and password ...

4 Likes

I know that, of course, that's exactly what I do, what I described, just I'm looking for alternatives in GUI or in command line.

OK, but that also has to do with the fact that almost every Linux environment initially assumes that your system will be assigned an address by DHCP via your network.

You also wrote that you were currently only successful with KDE (network). Now @bogdancovaciu has shown you a good way how it works with gnome. Why is it failing now and why do you want to use the command line to do this?

2 Likes

No - there is not.

Your ISP requires you to authenticate - this cannot be changed.

Your system is only assigned an IP address after authentication so any solution which omits the authentication are doomed to fail.

Please make use of a firewall - blocking inbound connections - as your assigned IP address may be on a public network - making your system prone to attempts to take control of your system.

Now @bogdancovaciu has shown you a good way how it works with gnome.

It has to be done with Gnome the same way as with KDE, no difference here.
The thing is that with KDE I'm getting what I'm setting up and with Gnome if I do the same it gives me not-working Autoethernet.

Why is it failing now and why do you want to use the command line to do this?

It's not failing now on KDE, it's fine on KDE as always. But XFCE used to be my favorite.
And if GUI-way doesn't work in some DE, then command line is the way to go.

To use a firewall, control of my system? People, you're freaking me out, I may switch to Windows.:anguished:
I thought as Linux doesn't open any ports when not necessary I don't need to use Firewall and/or think about Firewall rules.

The screenshots i provided are from XFCE actually :slight_smile:
on Gnome is a bit different tho:

  • Open Terminal and run this command
    nmcli con edit type pppoe con-name "Desired Name of connection"

This opens a REPL to manage the PPOE connection you are creating.

  • Enter the following commands, to save your PPOE credentials, one by one:
    set pppoe.username Your_Username
    set pppoe.password Your_Password

  • Press Enter -> type save then exit command to start using it.

In the window where you set the service name, username and the password from ISP, you have to assign the interface you want to use for that connection.

So, in XFCE if the Ethernet is called for instance enp0s3 that is the one you select as Parent Interface from the dropdown menu, right before the Username.

image

2 Likes

If you are getting a public IP address then your system will be exposed directly to the internet.

Any computer connected directly to the internet should be secured. It is the same as using a coffee-shop network - you are expected to secure your system.

Don't freak out - be responsible - secure your system while on public networks - and even if you are home - connected to the internet using PPPOE - you may be connected directly to a public network.

You can check it while connected by executing

nmcli device show | grep IP4

Then get your public ip

curl -s https://get.geojs.io/v1/ip

If your systems IP address is the same as your public IP or in the same subneet - you are connected directly to the internet and without firewall you exposed.

1 Like

It seems I fine. As I understood IP4.ADDRESS[1] or IP4.GATEWAY should not match completely or match part of numbers of IP from curl -s https://get.geojs.io/v1/ip

nmcli doesn't know exit command.

If exit is not working after you saved the config, then use quit ...

1 Like

sorry! Of course I meant xfce and not gnome (the right matched but the wrong one written). :wink:

Buy a router (without a modem) for little money, then you have basic functions from scratch and can do without the entire configuration with pppoe and so on.

xfce, gnome - I tried them all, it's the same. No difference in network managers, may be slightly different layout.
Not gonna buy a router, nmcli works like a magic.:+1:

1 Like

All this time, for about 2 years, nobody nowhere could help with that, not even askubuntu, only here on Manajro fourm - finally solution (nmcli). Thanks a lot bogdancovaciu.

2 Likes

GUI network manager actually does it in XFCE 4.14 on Manjaro 18.1.4 (to my surpise), unlike in XFCE of the same version in Xubuntu.
Just before that I tried Xubuntu, I had a disk with Xubuntu - nmcli was the only way to do it there.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by