Issue booting into Manjaro and Windows

So yesterday my PC was working perfectly fine and it has been for weeks, I was last running Windows before I put my PC on hibernate. Now whenever I boot my PC up it goes straight into grub recovery and I can't figure out how to get it to boot. I have Windows installed on an SSD, and Manjaro installed on my secondary hard drive. I originally had grub installed on the SSD and everything would dual boot perfectly. Now I just get this error trying to boot.!


Read this:

Also, you can turn your phone horizontally to take photographs of landscape subjects. It's also nice to reduce the resolution and/or increase the compression when uploading images directly to the forum; there's nothing in the image which requires high resolution and high quality reproduction.

I've gone ahead and cropped and compressed the image to reduce its size by 99% with zero loss of information.

Try this.

1 Like

I tried to follow this method but while trying to mount the root partition it failed.

In what way?

I got no such file when searching.

When I tried to mount the root partition so I could chroot into it, it said mount failed.

Can you more specific?

I am using the architect live CD, when I got to system rescue and attempt the chroot Option it says to mount the partitions first. Well when I go to prepare installation and mount partitions, and I select my root partition of 242gb, it says "Mount Failed!"

That's not the method in the wiki page I linked to.

Please read it carefully and try again. The process works, otherwise I wouldn't link to it. I myself have used it numerous times to fix both Manjaro and Ubuntu systems which have stuck at a GRUB prompt, so I know it works.

My issue is no mater what method I try(I have already reinstalled grub using an arch live usb) my system seems to not be able to access/mount my drives.

If that's the case then a manual mount command would provide some specific error information rather than a useless "Mount Failed!".

This is what I get when I try and mount my partition for my Manjaro root.

I also get the same thing when attempting to use the chroot

OK, looks like it needs an fsck. Disclaimer: This process is potentially destructive (but there's no way around that).

umount /dev/sdb1
fsck -fy /dev/sdb1
1 Like

This is what it returned and I believe it may be mounted now.

OK, great. You can either try a reboot now (as the partition mounts the fsck may have solved the issue), or try chroot'ing in to check.

1 Like

Well I don't know what just happened but I believe that fsck command fixed everything. I can boot into any operating system find now.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by