Issue: manjaro Stuck during boot

You need to remove 1 space between rw and resume, so that it only has one space in between...... and after that try to press CTRL+X

And show me the error logs....

Is this a new installation and you cannot boot into it?
Or an old installation that you had booted into it before and now it cannot boot?

Also, try thefallenrat suggestion and if it can boot into prompt, next (only if can boot into prompt), try adding 'achi=off' to your kernel parameters.

I have booted into the os. It was installed today morning and I updated and installed a few things and then I installed nonfree GPU driver from the manjaro settings

Let me guess, you have 2 driver installed correct?

If nothing else works, you might want to try installing and applying a new Kernel. You need to chroot into your OS from a live cd (see this thread)

After you successfully chroot:

mhwd-kernel -li
to see what Kernel you are using

mhwd-kernel -l
to see available versions

mhwd-i linux-xy
to install another kernel

This did it for me when my Installation broke after the last update (had to install 4.11)

Ahh... why don't you say so earlier?
Isn't that obvious that you need to say it?
I'll leave here now as I'm not good in graphics.
Good luck.

I think free was installed and then I also installed nonfree...I did remove the free one later from a live disk

Does this resulted in happy ending (sucessfully boot)?
If not, I think you switch back to free just to see what happen...
If that doesn't working either then you could try to switch into new kernel, or maybe restore grub ?

I tried removing the nonfree driver but it kept saying script failed and it would not remove.

Did you tried chrooting into your main system first, right?

Anyway I'm calling @anon35400795 since he's the one whos expert on this...

Yeah I chrooted into the main system and then changed stuff

Ok, while we waiting for @anon35400795 to come to the rescue, let's troubleshooting this!!!

Can you show whats the output of ...

mhwd -li -d --pci

[manjaro@manjaro-gnome ~]$ sudo manjaro-chroot -a
==> Mounting (ManjaroLinux) [/dev/sda2]
--> mount: [/mnt]
--> mount: [/mnt/boot/efi]
--> mount: [/mnt/home]
[manjaro-gnome /]# mhwd -li -d --pci
NAME: video-catalyst
VERSION: 2017.03.12
INFO: Closed source catalyst drivers for linux.

Weird......It doesn't show any free drivers available for this...
Maybe this is a kernel issues...Can you try installing another kernel (preferably4.9 and **4.11) to see what happen?

4.9 is already installed. I installed 4.11. Should i reboot into it?


It gets stuck in 4.11 too...odd

I don't mind reinstalling the os buy I don't want to update and install all the software again. If I replace the partition and install using the option in the installer would it remove all the installed software?

Or maybe copied all files in /var/cache/pacman/pkg/ to your other hard drive and after reinstalling it, copied back to your main partition..... That way, you don't need to download all the packages when updating

Forum kindly sponsored by