Issue: manjaro Stuck during boot

I tried removing the nonfree driver but it kept saying script failed and it would not remove.

Did you tried chrooting into your main system first, right?

Anyway I'm calling @anon35400795 since he's the one whos expert on this...

Yeah I chrooted into the main system and then changed stuff

Ok, while we waiting for @anon35400795 to come to the rescue, let's troubleshooting this!!!

Can you show whats the output of ...

mhwd -li -d --pci

[manjaro@manjaro-gnome ~]$ sudo manjaro-chroot -a
==> Mounting (ManjaroLinux) [/dev/sda2]
--> mount: [/mnt]
--> mount: [/mnt/boot/efi]
--> mount: [/mnt/home]
[manjaro-gnome /]# mhwd -li -d --pci
NAME: video-catalyst
VERSION: 2017.03.12
INFO: Closed source catalyst drivers for linux.

Weird......It doesn't show any free drivers available for this...
Maybe this is a kernel issues...Can you try installing another kernel (preferably4.9 and **4.11) to see what happen?

4.9 is already installed. I installed 4.11. Should i reboot into it?


It gets stuck in 4.11 too...odd

I don't mind reinstalling the os buy I don't want to update and install all the software again. If I replace the partition and install using the option in the installer would it remove all the installed software?

Or maybe copied all files in /var/cache/pacman/pkg/ to your other hard drive and after reinstalling it, copied back to your main partition..... That way, you don't need to download all the packages when updating

Would that have all my gnome settings and software settings?

As for that you need to copy config files (Don't know which one is the one, cause I'm not gnome user...) in your /home/<your_username>/ ,,,

Home partition is a different partition so that would not be changed I'm guessing

1 Like

Yup. As long if you used the same username as before...

Ok then

See this also :

I just reinstalled. If I get another issue I'm definitely switching to a different os as I've had too many issues with manjaro. Thank you for your help and time.

Just dont try to use catalyst in 2017. Its deprecated, slow and needs an completely own graphicsstack to work. It's only good for fallback reasons (and advanced OpenCL users) in Manjaro.

Ok, i reinstalled the OS and now i have more I cant install google-chrome

Forum kindly sponsored by