issue with installing nvidia driver

hello! i'm trying to install nvidia driver on my dual boot windows-manjaro laptop with this hardware info

laptop

Removed

after install

Removed

installation process

sudo mhwd -a pci nonfree 0300 Details removed

i rebooted and then checked if working

mhwd -li

`mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI


Warning: No installed USB configs!

`

it looked fine to me, but i'm a newbie so i don't know much and so i proceeded to configure nvidia settings and got this error

error

`sudo nvidia-settings

(nvidia-settings:6484): GLib-GObject-CRITICAL **: 15:19:11.817: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work, but
       values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for
       possible values and descriptions.

`

i cannot further follow instructions here https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup since i don't have X Server Display Configuration setting showing up

screenshot

Removed

i don't know what to do next, i tried searching for my problem in the forum and on the net, but i can't seem to find it. i'm planning to do this

graphics manager

https://archived.forum.manjaro.org/t/install-drivers-for-nvidia-geforce-gtx-1050-without-bumblebee/114828/3

after i succed with the installation so that i can easily switch between intel and nvidia in the future

what should i do next? again, i really am a newbie, so i'm not even sure if i'm doing this the correct way or if i'll be able to set up that graphics manager afterwards, but my laptop is a hybrid intel-nvidia graphics so i want to take advantage of that.
thank you very much!

You have the best of both worlds! (The hybrid driver) and should install optimus-manager-qt :

pamac install optimus-manager-qt 

and then run it every time you want to switch between nVidia and Intel...

optimus-manager-qt

Or add optimus-manager-qt to your startup applications so that it's just a point and click away.

Alternatively, if you only want nVidia (worse battery life though) and no Intel at all, you should remove the hybrid driver and install the nVidia driver only!

As it needs a lot of parameters, better go here as that is written by our resident expert on optimus.

1 Like

using the video-nvidia-440xx driver package on an optimus laptop require further configuration.

1 Like

i installed it, added to my start up applications and rebooted, then i tried to switch to nvidia to see if it's working and 2 messages poped out

1

runtime d3 power management

2

patched gdm

so i assume i have to follow this https://archived.forum.manjaro.org/t/guide-install-and-configure-optimus-manager-for-hybrid-gpu-setups-intel-nvidia/92196

Yes, please! And thanks @dglt for pointing you in the right direction!

Original post edited to remove incomplete instructions and point you in the right direction

1 Like

i followed that guide in doing

sudo pacman -S optimus-manager

and i already got optimus-manager-qt
i cannot disable bumblebee, i suppose i don't have it installed
i have no graphic related configs in /etc/X11/xorg.conf.d/ to disable
i have no Xorg graphic configurations in /etc/X11/ to disable
i already have gdm-prime installed
WaylandEnable=false was already without # at the begining of the line
and optimus-manager-qt is already loading at start up

when i do systemctl status optimus-manager.service this is what shows up

optimus manager status

Removed

i rebooted and i still get those 2 pop up messages when i try to switch

also when i try sudo nvidia-settings this error comes up

ERROR: Unable to load info from any available system

@michaldybczak As you're our resident expert on Optimus, can you have a look at the above issues?

@Mihnea Can you edit your last post to remove the empty lines in your optimus manager status details section so it's easier to read for our time-starved resident explert, please, please, please?

:unicorn::unicorn::unicorn:
:rainbow::rainbow::rainbow:

Try the switch few times and please, post log outputs (maximize terminal's window and then copy the data):

journalctl -u optimus-manager.service

journalctl -u gdm.service

journalctl -k

See xorg logs at /var/log/Xorg.xxx.log or ~/.local/share/xorg/Xorg.xxx.log

Sounds as you did all correctly, but let's see what logs tell us. If you're still having the pop-up about having not patched gdm version, somethings is off at this point. Check if you have those two packages: xorg-xrdb, xorg-xhost. If not, install them and check again the switch.

Outputs Removed

i do have those packages installed

Looks like a wrong optimus-manager config. You'd better start with the most simple config, this means disabling optimus-manager. Do sudo systemctl disable --now optimus-manager.service, then install prime-run: sudo pacman -S prime-run. Your GPU is quite modern so you don't need tricky things like bbswitch and acpi_call.
Now reboot and try running prime-run inxi -Gxxz. Post here the output.

Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA vendor: Acer Incorporated ALI driver: N/A bus ID: 01:00.0 
  chip ID: 10de:1f91 
  Display: x11 server: X.org 1.20.7 driver: modesetting,nvidia 
  unloaded: intel,nouveau alternate: fbdev,nv,vesa compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: N/A v: N/A direct render: N/A 

i thought using bbswitch had something to do with better power management when switching

For older generations of Nvidia GPUs. Maybe for new ones too, but I know no one who I'd say that.

Clearly something's wrong with Nvidia driver installation. Try a) removing everything "nvidia", "bbswitch", "acpi_call" with pamac or pacman (like linux54-nvidia, etc), b) go to Manjaro Settings Manager, uninstall all Nvidia configs make sure only video-linux is installed, then c) install video-hybrid-intel-nvidia-440xx-prime and reboot.
After that, prime-run inxi -Gxxz should show something similar to this:
OpenGL: renderer: GeForce MX150/PCIe/SSE2 v: 4.6.0 NVIDIA 440.59 direct render: Yes

i found only nvidia-440xx-utils and nvidia-prime in pamac and removed them, no bbswitch and no acpi_call installed
removed video-hybrid-intel-nvidia-440xx-prime, now there's only video-linux, video-modesetting and video-vesa left
installed back video-hybrid-intel-nvidia-440xx-prime with manjaro settings manager

installation
> Installing video-hybrid-intel-nvidia-440xx-prime...

Sourcing /etc/mhwd-x86_64.conf

Has lib32 support: true

Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-440xx-prime/MHWDCONFIG

Processing classid: 0300

Sourcing /var/lib/mhwd/scripts/include/0300

:: Synchronizing package databases...

core is up to date

extra is up to date

community is up to date

multilib is up to date

resolving dependencies...

looking for conflicting packages...

Packages (4) lib32-nvidia-440xx-utils-440.59-1 linux53-nvidia-440xx-440.59-1 nvidia-440xx-utils-440.59-1 nvidia-prime-1.0-1

Total Installed Size: 402.06 MiB

:: Proceed with installation? [Y/n]

checking keyring...

checking package integrity...

loading package files...

checking for file conflicts...

checking available disk space...

:: Processing package changes...

installing nvidia-440xx-utils...

==> If you run into trouble with CUDA not being available, run nvidia-modprobe first.

Optional dependencies for nvidia-440xx-utils

gtk3: nvidia-settings [installed]

xorg-server-devel: nvidia-xconfig

opencl-nvidia: OpenCL support

installing nvidia-prime...

installing lib32-nvidia-440xx-utils...

Optional dependencies for lib32-nvidia-440xx-utils

lib32-opencl-nvidia-440xx

installing linux53-nvidia-440xx...

In order to use nvidia module, reboot the system.

:: Running post-transaction hooks...

(1/6) Creating system user accounts...

(2/6) Reloading system manager configuration...

(3/6) Arming ConditionNeedsUpdate...

(4/6) Updating module dependencies...

(5/6) Updating Kernel initcpios for Nvidia-DRM...

==> Building image from preset: /etc/mkinitcpio.d/linux53.preset: 'default'

-> -k /boot/vmlinuz-5.3-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.3-x86_64.img

==> Starting build: 5.3.18-1-MANJARO

-> Running build hook: [base]

-> Running build hook: [udev]

-> Running build hook: [autodetect]

-> Running build hook: [modconf]

-> Running build hook: [block]

-> Running build hook: [keyboard]

-> Running build hook: [keymap]

-> Running build hook: [resume]

-> Running build hook: [filesystems]

==> Generating module dependencies

==> Creating gzip-compressed initcpio image: /boot/initramfs-5.3-x86_64.img

==> Image generation successful

==> Building image from preset: /etc/mkinitcpio.d/linux53.preset: 'fallback'

-> -k /boot/vmlinuz-5.3-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.3-x86_64-fallback.img -S autodetect

==> Starting build: 5.3.18-1-MANJARO

-> Running build hook: [base]

-> Running build hook: [udev]

-> Running build hook: [modconf]

-> Running build hook: [block]

-> Running build hook: [keyboard]

-> Running build hook: [keymap]

-> Running build hook: [resume]

-> Running build hook: [filesystems]

==> Generating module dependencies

==> Creating gzip-compressed initcpio image: /boot/initramfs-5.3-x86_64-fallback.img

==> Image generation successful

(6/6) Updating the desktop file MIME type cache...

xorg configuration file: '/etc/X11/mhwd.d/nvidia.conf'

> Successfully installed video-hybrid-intel-nvidia-440xx-prime

Done ...

rebooted and prime-run inxi -Gxxz still shows

Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA vendor: Acer Incorporated ALI driver: N/A bus ID: 01:00.0 
  chip ID: 10de:1f91 
  Display: x11 server: X.org 1.20.7 driver: modesetting,nvidia 
  unloaded: intel,nouveau alternate: fbdev,nv,vesa compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: N/A v: N/A direct render: N/A 

there should be a warning with video-vesa, just having it installed causes problems even if it's not being used, remove video-vesa, you also dont need video-modesetting.

remove all drivers first and start clean

sudo mhwd -r pci video-linux
sudo mhwd -r pci video-vesa
sudo mhwd -r pci video-modesetting
sudo mhwd -r pci video-hybrid-intel-nvidia-440xx-prime

when your done with that

sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime

reboot

so i'll remove video-vesa, video-modesetting and video-linux as well first? is that safe?

yes it's safe, just dont reboot until you run all of those commands. get rid of any/all video packages listed from mhwd -li before doing anything else. then install that 1 nvidia mhwd package. then reboot

ok, thank you!

i've done that, here is mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI


Warning: No installed USB configs!

and here is prime-run inxi -Gxxz

Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA vendor: Acer Incorporated ALI driver: N/A bus ID: 01:00.0 
  chip ID: 10de:1f91 
  Display: x11 server: X.org 1.20.7 driver: modesetting,nvidia 
  unloaded: intel,nouveau alternate: fbdev,nv,vesa compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: N/A v: N/A direct render: N/A 

are you sure your up to date?

sudo pacman-mirrors -f5
sudo pacman -Syyu

did you reboot after?

also post

lsmod | grep -i nvidia
pacman -Qs 'xf86-video|vesa|nvidia|bbsw|prime|optimus|bumble'

Forum kindly sponsored by