Issues After and Suggestions for Manjaro Architect Install

Okay so I wanted try out the Linux Mint Beta on my laptop and things didn't seem to turn out well. Came back to Manjaro XFCE and decided to try the Architect installer. Everything worked, including encryption, ZSH, and BTRFS, except I've found a few issues.

  1. When I booted up for the first time, Network Manager was not enabled. Luckily I knew what systemctl was and that was a quick fix. But I feel like it should've just been there in the first place.

  2. I can't seem to browse for network shares in Thunar. gvfs and gvfs-smb are installed, but other plugins relating to Thunar and networking aren't. Luckily, I installed all that I could find and rebooted, it works now.

  3. I had to manually set an uppercase name after the install for my user with Mugshot. Of course Unix usernames have to be lower case, but I feel like allowing for the user's name to be uppercase as well would be helpful.

  4. The XFCE install includes both xfce4-screensaver and light-locker which conflict, preventing a login after locking the screen. Disabling one or the other fixes the issue, however.

That was pretty much it. But I also have some suggestions relating to this topic.

  1. Zsh should be enabled by default. There are very few differences with Bash and this nice prompt and configuration out of the box seems to just be going to waste.
  2. If so much stuff can be configured with Architect, I feel like kernel parameters should be able to be tweaked too. I know that there are multiple bootloaders for the installer but I think it could be achievable.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by