Issues booting after attempted update

This morning, I began updating via pamac, then walked away to take a shower while that went through. About 20-30 minutes later, I return to my machine to find that the screen is off, and it won't "wake up" or respond to any input. So I force the machine to shutdown by holding down the power button. Upon rebooting, I can't boot at all via kernel 4.14, and I am only able to get to a terminal session using kernel 4.15. Here are some screenshots involving the boot problems, as well as the output of inxi -Fx (note: bluetooth had never been working, but the thing about the dell_smbios is new, and notable in that I'm using an Acer machine.)

I've tried updating via pacman in the terminal, but I don't seem to be able to get to the internet via ethernet or wifi, and as such it isn't working (I still tried because I thought maybe something was cached or something from earlier).

I haven't been able to find any way to connect to wifi via the terminal (everything I've found involves using "ifconfg," which is a package that I don't have in the KDE edition), so I feel like that might be a first step. I also have the live USB with me if there's anyway to update my system through the USB.

I am fairly inexperienced, so I'm sorry for whatever stupid thing I'm not doing or that I should have already tried.

Thanks in advanced for any help.


1 Like

So I was able to connect to wifi, after which I ran

sudo pacman-mirrors -f 3
sudo pacman -Syyu

A lot of things seemed to update, but there was an error involving linux414, and now there is kernel panic trying to boot from 4.15, and 4.14 still doesn't even start booting (something about "error: premature end of file /boot/vmlinuz-4.14-x86_64").

picture of kernel panic trying to boot via 4.15
picture of error regarding 4.14 while updating

Try removing and reinstalling linux414,

sudo pacman -R linux414
sudo pacman -S linux414


sudo mkinitcpio -P
sudo update-grub

to rebuild the initramfs and make sure GRUB sees the correct version.

Is there a way to run that without booting? At the moment I can't boot into the system at all.

If you can't boot into the system you need a chroot ( or you might try Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader

1 Like

Using Grub from the live CD hasn't helped, because I still encounter kernel panic trying to boot. I've tried to chroot using the live CD as well, but mhwd-chroot says "No linux system found !" and trying to manually mount my manjaro partition (via mount /dev/sda2 /mnt) gives the error "unknown filesystem type 'ext4'." Similarly, I tried manjaro-chroot -a and was shown these errors:

==> Mounting (ManjaroLinux) [/dev/sda2]
 --> mount: [/mnt]
mount: /mnt: unknown filesystem type 'ext4'.
Can't open /mnt/etc/fstab: No such file or directory.
mount: /mnt/proc: mount point does not exist.
mount: /mnt/etc/resolv.conf: mount point does not exist.
chroot: failed to run command '/bin/bash': No such file or directory
 --> umount: []
umount: bad usage
Try 'umount --help' for more information.

Uh. That's... interesting. Which edition and version image are you using? Have you verified its checksum?

ext4 is included in every kernel so there's no way it should be an "unknown filesystem".

17.1.6, KDE

I can't remember if I verified the checksum when I created the USB, but this is the same USB I used to install the system originally.

One thing to try would be a

modprobe ext4

from within the live environment, but why this module should be missing/unloaded is beyond me...

I don't know if it can help but an easy fix could be to switch to the unstable branch hoping that you get different versions for broken packages and their dependencies.

And then just switch back again.

Alright, so I finally got chrooted into my manjaro partition from the live CD, and I ran pacman -R linux414 and got this message:

error: could not open file /var/lib/pacman/local/linux414-4.14.23-1/desc: No such file or directory
warning: could not fully load metadata for package linux414-4.14.23-1
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: linux414-bbswitch: removing linux414 breaks dependency 'linux414'
:: linux414-nvidia: removing linux414 breaks dependency 'linux414'
:: linux414-r8168: removing linux414 breaks dependency 'linux414'

OK, this is fine and a good step forwards. Let's ignore the dependencies for now,

sudo pacman -Rdd linux414
sudo pacman -S linux414

If that doesn't work, you'll have to install the package directly, forcing it to ignore the missing metadata:

sudo pacman -U --force

(You should also rebuild your initramfs for kernel 4.15 which should at least get that one booting.)

try: pacman -Scc and then retry removing that other stuff with pacman -Rns

1 Like

This is what I had to do to get the kernel installed, which seems to have been successful. As of now, I see entries in grub for both 4.15 and 4.14, but trying to boot into either results in kernel panic, and the system doesn't boot. I also rebuilt the initramfs as you mentioned before.

If I'm reading the error correctly when booting, it seems like the issue is that "kernel panic -
not syncing. No working init is found." (Link to photograph of the errors)

OK, one step closer. According to you need to

sudo pacman -S filesystem

You might also rebuild the initramfs again, just for completeness' sake.

I think you are way underselling yourself. You have far more persistence than I would have in this predicament. I would have broken down and reinstalled an imaged backup long ago. You should be lauded for how well you've progressed so far. Most people would have given up repairing this by now. I am impressed with your skills and persistence, and I hope you can resolve your issue.

Good luck.

1 Like

This is a pretty new system, and I hadn't gotten around to making an imaged backup yet. I'm actually leaning pretty heavily toward a re-install at this point, especially since all of the important data is backed up. I'm just too lazy to get everything re-installed and downloaded and whatnot.

I think most would have broken down and re-installed long ago. You have done well.

no don't do that it does not teach you nothing learn how to fix things then you can help others.:blush:

1 Like

Forum kindly sponsored by