Issues enabling "smooth boot" -Testing

Do you mean this link? Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader

Tried it but search.file would result with "Could not find /etc/manjaro-release"

Never the less i solved it by reinstalling Manjaro. It is not my main computer so nothing critical is stored on it.

That means the basic installation is not done.

Okay, now try the search.file command. Use any grub prompt, not necessary from the install media grub. If it is not there, you have a typo.

Hello all, so after performing the stable update 2018-10-8 yesterday (which worked btw) I tried to activate smooth boot.

I followed the description that philm posted. After the first reboot I borked the system and went into grub rescue. Big thanks to user @gohlip for his rescue thread which I used to save my beacon. Now the system works properly again... with the standard boot. I still want to give smooth boot a shot so I am asking for assistance.

Going to comment the process philm posted and describe my theories.

  • install linux418 or linux419 ____I already had 4.18 installed
  • install grub-quiet ____this I have done with pacman via terminal, in the process I was asked to remove grub due to conflicts with grub-quit which I did
  • reinstall grub to MBR (Attention: use the correct cmd for your system!)
    • EFI: sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck ____I used this command because I have efi installed
    • BIOS: sudo grub-install --recheck /dev/sd[X] (change [X] for your device letter. Check via lsblk -f )
  • reboot to see if all is still booting fine ___After doing this I went straight to grub rescue
  • check that you have loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 in /etc/default/grub under GRUB_CMDLINE_LINUX_DEFAULT or GRUB_CMDLINE_LINUX
  • sed -i -e 's|fsck||g' /etc/mkinitcpio.conf
  • sudo mkinitcpio -P
  • sudo update-grub
  • reboot your system

So I have a few theories what might have caused issues:

  • I once set the grub resolution to hd in the /etc grub file because it was blurry
  • I once set the "show grub during startup" time to 0 because I wanted the system to immediately boot without the choose "Advanced options" ...
    Those 2 changes worked so far without issues.

I think that perhaps in the command sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck I should add the drive partition to "=/boot/efi" because my root directory is in sda3 while my efi (boot) partition is in sda4 . Does this matter?

My system is AMD Ryzen 5 with Manjaro stable running the newest stable update and gnome 3.3

Let me know which stats are further needed...tks

I had the same issues. After I was able to fix my issue, I tried it again. But this time I did not reboot after reinstalling grub and it worked! So maybe the reboot is too early at this stage?

It seems to me that you needed to do sudo update-grub after grub-install. I am not sure but I think grub-quiet config generation scripts are slightly different from usual grub ones.

I tried this as well now and had to visit mr. grub rescue again. :thinking:

Btw. do I have to switch to testing in order to install it correctly? Bc. I thought that as of the latest stable this was not necessary anymore...

When doing the

sudo mkinitcpio -P

step I noticed:

==> Building image from preset: /etc/mkinitcpio.d/linux418.preset: 'default'
-> -k /boot/vmlinuz-4.18-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.18-x86_64.img
==> Starting build: 4.18.12-1-MANJARO
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [autodetect]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
cannot open file at
-> Running build hook: [resume]
-> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.18-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux418.preset: 'fallback'
-> -k /boot/vmlinuz-4.18-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.18-x86_64-fallback.img -S autodetect
==> Starting build: 4.18.12-1-MANJARO
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
cannot open file at
-> Running build hook: [resume]
-> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.18-x86_64-fallback.img
==> Image generation successful

Could this "cannot open file at" be the problem?

@Coffeetron, still referring to the link, use the livecd media, start in uefi mode and at grub prompt..

grub> search.file /etc/manjaro-release  root
grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.18-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.18-x86_64.img
grub> boot

Tell us if this boot to your OS.
If it does. at booted installed Manjaro OS terminal,
Provide

ls /etc/grub.d
cat /etc/mkinitcpio.conf | grep HOOKS
findmnt -s
sudo blkid

ps - warning - next step -You may need to uninstall all grub thingies.., grub, grub-quiet, grub-quit (?), grub-customiser, remove all things in /etc/grub.d, rename /etc/default/grub, reinstall grub, do a grub-install and do an update-grub.
Warning in advance.
BTW, did you install grub-customizer or had in the past?

Hi, I am already booted in my OS thanks to your thread... the

grub> search.file /etc/manjaro-release root
grub> configfile /boot/grub/grub.cfg

commands helped me to get back.

Here my outputs:

> [mgm@Zeus-002 ~]$ ls /etc/grub.d
> 00_header  01_menu_auto_hide  10_linux  20_linux_xen  30_os-prober  40_custom  41_custom  60_memtest86+  README

the mkinitcpio.conf:

> [mgm@Zeus-002 ~]$ cat /etc/mkinitcpio.conf | grep HOOKS
> # HOOKS
> # This is the most important setting in this file.  The HOOKS control the
> # order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
> #    HOOKS=(base)
> #    HOOKS=(base udev autodetect block filesystems)
> #    HOOKS=(base udev block filesystems)
> #    HOOKS=(base udev block mdadm encrypt filesystems)
> #    HOOKS=(base udev block lvm2 filesystems)
> HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems"

findmnt -s

[mgm@Zeus-002 ~]$ findmnt -s
TARGET        SOURCE                                    FSTYPE OPTIONS
/boot/efi     UUID=38C9-AFAF                            vfat   defaults,noatime
/               UUID=9d62f33e-bb2f-4b5b-a9a0-3acf49e9179a ext4   defaults,noatime,discard
swap          UUID=d4e014e9-7ee9-47db-9e24-989e697a64b6 swap   defaults,noatime,discard
/home         UUID=7bb28de2-b618-403a-b2aa-4ce208750f7f ext4   defaults,noatime,discard
/tmp          tmpfs                                     tmpfs  defaults,noatime,mode=1777
/mnt/mDC.Zeus LABEL=mDC.Zeus                            auto   nosuid,nodev,nofail,x-gvfs-show

and blkid:

[mgm@Zeus-002 ~]$ sudo blkid
[sudo] password for mgm: 
/dev/sda1: UUID="d4e014e9-7ee9-47db-9e24-989e697a64b6" TYPE="swap" PARTUUID="920d24cd-100d-400c-9cd3-96987ccc41bb"
/dev/sda2: UUID="7bb28de2-b618-403a-b2aa-4ce208750f7f" TYPE="ext4" PARTUUID="61e169ec-9806-4c18-bdf9-3dd8782fefd6"
/dev/sda3: UUID="9d62f33e-bb2f-4b5b-a9a0-3acf49e9179a" TYPE="ext4" PARTUUID="4eaa2438-b323-4955-ac7c-8095950ec668"
/dev/sda4: UUID="38C9-AFAF" TYPE="vfat" PARTUUID="701de1d9-33ad-44bf-8efb-4e58f2657568"
/dev/sdb1: LABEL="mDC.Zeus" UUID="58e62e91-ddd0-49b5-bf1e-71f0aff5086c" TYPE="ext4" PARTLABEL="mDC.Zeus" PARTUUID="6e098444-4c64-4ed7-95e4-55b1cae5d2db"
/dev/sdc1: LABEL="m.64GB.TUW" UUID="1CE4B06B47B6E623" TYPE="ntfs" PTTYPE="dos" PARTUUID="bdf86c4b-01"

I never had grub-customizer in the past... The only things I did in Grub was once edit the resolution to 1920x1080 and set the time which grub lets me choose "Manjaro or Manjaro Advanced" to 0. But this must have been overwritten after I reinstalled it when I broke it prior.

What I found weird is that when running:

[mgm@Zeus-002 ~]$ sudo mkinitcpio
==> Starting dry run: 4.18.12-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
cannot open file at
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Dry run complete, use -g IMAGE to generate a real image

that the hooks resume and filesystems could not be opened....

I checked with

[mgm@Zeus-002 ~]$ mkinitcpio -L
==> Available hooks
autodetect	btrfs		encrypt		fw¹		keymap		mdadm_udev	mmc¹		pata¹		scsi¹		sd-shutdown	sleep		udev		usr
base		consolefont	filesystems	hostdata	lvm2		memdisk		modconf		resume		sd-encrypt	sd-vconsole	strip		usb¹		v86d
block		dmraid		fsck		keyboard	mdadm		mhwd-fb		openswap	sata¹		sd-lvm2		shutdown	systemd		usbinput²	virtio¹

¹ This hook is deprecated in favor of 'block'
² This hook is deprecated in favor of 'keyboard'

and they should be there :thinking::thinking::thinking:

thank you!

btw. the /etc/default/grub file might be useful as well:


GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet vt.global_cursor_default=0 loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

The HOOKS part in /etc/mkinicpio.conf looks okay to me.
But if others looking at it can see anything wrong, especially this messages below, please jump right in. I don't understand why there should be these messages.

But I think all looks okay. Don't worry.

Now the very good news.

It means your kernels (and initramfs files) are very okay.

ps: not to frighten you, but if you ever find difficulty somewhere along fixing it up.
You can always use this to boot up. That's the reassuring part, not the frightening part.

Now another small thing to just make sure it is not a issue. Perhaps just to please me.
Can you comment out the fstab line of
/mnt/mDC.Zeus LABEL=mDC.Zeus auto nosuid,nodev,nofail,x-gvfs-show

I never like fstab with /mnt/xxx/xxxx. To me, that's wrong. But yes, some have worked it.
After fixing the problem, you can add back and see if it has any problem, most likely not.
But..just do it for my sake. Thanks.

Okay. Let's get to work. Remember, if we mess up anything, you can always boot back.
Do not reboot, shutdown at all until all the following below is done.

sudo pacman -R grub-quiet
sudo mv /etc/default/grub /etc/default/grub.old
sudo mv /etc/grub.d /etc/grub.d.old

If you have problems renaming the above 2, use "-Rf"
like...sudo mv -Rf /etc/grub.d /etc/grub.d.old
If not necessary, don't need to use "-Rf" (some DE's can be picky and some may not even allow this)
If still have difficulty, list those things in it and remove them, manually and one by one.

Continue..reinstall grub and if necessary force reinstallation

sudo pacman -S grub
sudo grub-install
sudo update-grub

Good luck.

ps: If all work and all is fine, I have a controversial statement.
Do not install grub-quiet.
There are other ways to make grub menu 'silent' without installing grub-quiet.
(Though I cannot say offhand what these are - I don't do it but I know it can be done
Have helped others doing it here in this forum but I have forgotten, or cannot recall)
Ubuntu's developers doing grub things are okay, but not RH (or Arch :rofl:)

Indeed, grub rescue was a nightmare and with the ISO it worked nicely. I hope that I won't have to resort to it again but if I have its nice to have this option.

I have amended that, can confirm that it works.

I went through the steps and everything is working! :smiley:

Well tbh there was no "practical" advantage in installing grub-quit. I fancied the boot logo and since I updated the system I was thinking of trying it out. :sweat_smile: Its not an issue not having it and if I have the time I might give it another shot in the future...

Again, thank you for the help!

You're welcome.

Ah, but I won't help you next time. LOL :rofl:

Cheers.

1 Like

You have resume hook in your mkinitcpio.conf, but no option for resume device in /etc/defauld/grub. You need to modify GRUB_CMDLINE_LINUX to look like "resume=UUID=d4e014e9-7ee9-47db-9e24-989e697a64b6" in order to have working suspend-to-disk aka hibernation. I am not sure if this is related to that cannot open file at though.

Correct. But as OP has 'resume' in HOOKS line and fstab is correct, by asking to do again 'grub-install', that would have taken care of by itself. But yes, you are correct and worth noting.
Cheers.

Is this an existent file? :smile:

1 Like

thanks for pointing that out. This has to do with the latest stable update that I have done recently. It hasn't caused issues and I didn't take the time to investigate yet. After the system update I would have during the boot screen a message along the lines "hibernation is not set" or "hibernation not working"...
I added that line, updated grub and the "error" message disappeared.
Tks!

Good question! This was me after searching through forum 10¹⁰ trying to "adjust" things. :joy:

All set again!

Hi!

Upon trying sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck I get

grub-install: error: attempt to install to encrypted disk without cryptodisk enabled. Set `GRUB_ENABLE_CRYPTODISK=y` in file `/etc/default/grub`.

Searching the Web gives mixed results on whether I should or should not enable this option. What is the most appropriate solution here? Thanks.

Tricky question:
Do you have encryption setup for your disks/system?

Forum kindly sponsored by