Issues enabling "smooth boot" -Testing

Sure, I have full-disk encryption set up during install. However, the GRUB_ENABLE_CRYPTODISK=y in /etc/default/grub is commented out (and always has been).

That's interesting, while IIRC it is a needed option for encryption. Or when grub is on encrypted partition..?

I opted for the automatic (default) partitioning during install with full-disk encryption enabled - there was no choice of whether or not to encrypt the /boot partition.

That is really strange. What I think happened with your system was grub-quiet had installed its own /etc/default/grub config file with GRUB_ENABLE_CRYPTODISK=y commented out, and you discovered that setting only when the error showed up. Or maybe you edited config manually when those .pacsaves and .pacnews appeared, and you didn't notice # when copypasting.
Darn English! I'm not sure if I'm correct when writing pacsaves and pacnews - I hope everyone would understand what I meant.

1 Like

This has to be set to zero. I've fixed it now in revision 17.

Yes, indeed, this happened after I installed grub-quiet...

does it make a big difference installing grub-quiet via pamac other than pacman?

any further steps necessary if you have this gpt partition layout: boot/efi, boot, root, home, swap?

ok, i gave this a try (efi, kernel 4.18-15), followed the instructions step by step - everything went fine, except that i had to use:

sudo sed -i -e 's|fsck||g' /etc/mkinitcpio.conf in order to have permissions for making changes to the conf.

now when i boot up, nothing actually changed at all.

i still see grub menu, hit enter & choose manjaro to speed up booting. no boot logo. there is also the usual short bootup messages regarding the zram disk that i have set up, except for this error:

“ERROR: resume: no device specified for hibernation”

p.s.: what is the consequence of removing fsck from mkinitcpio.conf?

I have a similar problem as xtristanx.

I followed the steps and everything went fine, but it only shows me a black screen instead of the manufacturer logo, but it boots. It also shows me an error message before showing me the log in screen.

“ERROR: resume: no device specified for hibernation”

This didn’t showed before.

1 Like

update:

i still had GRUB_TIMEOUT=5

changing it to 0 actual hides grub and shows the boot logo.

the hibernation error still persists of course.

but now i can not enter grub anymore (holding f8 or shift).

edit:

i just found out about a grub.pacsave which is differing quite a lot to the new grub file

edit 2:

i just had a look at the journald-protocol. there is some new sddm, sddm-helper and systemd/sddm-service errors/coredump never seen before:

20.10.18 19:31	sddm	Failed to read display number from pipe
20.10.18 19:31	sddm	Display server failed to start. Exiting
20.10.18 19:31	sddm-helper	Received a wrong opcode instead of REQUEST: 0
20.10.18 19:31	systemd	sddm.service: Main process exited, code=dumped, status=6/ABRT
20.10.18 19:31	systemd-coredump	Process 388 (sddm) of user 0 dumped core.

Stack trace of thread 388:
#0  0x00007fe8aaffed7f raise (libc.so.6)
#1  0x00007fe8aafe9672 abort (libc.so.6)
#2  0x00007fe8ab3b67fc _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5)
#3  0x000056172b77c1f3 n/a (sddm)
#4  0x000056172b7bbc2e _ZN4SDDM4Seat13createDisplayEi (sddm)
#5  0x000056172b7bbe72 _ZN4SDDM4SeatC2ERK7QStringP7QObject (sddm)
#6  0x000056172b7bde41 _ZN4SDDM11SeatManager10createSeatERK7QString (sddm)
#7  0x000056172b7bec62 n/a (sddm)
#8  0x00007fe8ab5d1bd0 _ZN11QMetaObject8activateEP7QObjectiiPPv (libQt5Core.so.5)
#9  0x000056172b7bceb0 _ZN4SDDM10LogindSeat19canGraphicalChangedEb (sddm)
#10 0x000056172b7bdd38 _ZN4SDDM10LogindSeat17propertiesChangedERK7QStringRK4QMapIS1_8QVariantERK11QStringList (sddm)
#11 0x000056172b7bfacb _ZN4SDDM10LogindSeat11qt_metacallEN11QMetaObject4CallEiPPv (sddm)
#12 0x00007fe8abe8d9ef n/a (libQt5DBus.so.5)
#13 0x00007fe8ab5d2352 _ZN7QObject5eventEP6QEvent (libQt5Core.so.5)
#14 0x00007fe8ab5a7c17 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5)
#15 0x00007fe8ab5aaccc _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5)
#16 0x00007fe8ab5fb9d4 n/a (libQt5Core.so.5)
#17 0x00007fe8a9d073cf g_main_context_dispatch (libglib-2.0.so.0)
#18 0x00007fe8a9d08f89 n/a (libglib-2.0.so.0)
#19 0x00007fe8a9d08fce g_main_context_iteration (libglib-2.0.so.0)
#20 0x00007fe8ab5fafc9 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
#21 0x00007fe8ab5a68cc _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
#22 0x00007fe8ab5aebc6 _ZN16QCoreApplication4execEv (libQt5Core.so.5)
#23 0x000056172b77fb0a main (sddm)
#24 0x00007fe8aafeb223 __libc_start_main (libc.so.6)
#25 0x000056172b77fe0a _start (sddm)

Stack trace of thread 397:
#0  0x00007fe8ab0b7c21 __poll (libc.so.6)
#1  0x00007fe8a9d08ee0 n/a (libglib-2.0.so.0)
#2  0x00007fe8a9d08fce g_main_context_iteration (libglib-2.0.so.0)
#3  0x00007fe8ab5fafc9 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5)
#4  0x00007fe8ab5a68cc _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5)
#5  0x00007fe8ab3efeb9 _ZN7QThread4execEv (libQt5Core.so.5)
#6  0x00007fe8abe81ba6 n/a (libQt5DBus.so.5)
#7  0x00007fe8ab3f9f65 n/a (libQt5Core.so.5)
#8  0x00007fe8aafada9d start_thread (libpthread.so.0)
#9  0x00007fe8ab0c2b23 __clone (libc.so.6)

20.10.18 19:31	systemd	sddm.service: Failed with result 'core-dump'.
20.10.18 19:31	kernel	kauditd_printk_skb: 3 callbacks suppressed
20.10.18 19:32	user@1000.service	Theme directory actions32@2x of theme breeze-dark has no size field

hope it is helpful in one way or the other.

sda1 8:1 0 499M 0 part
├─sda2 8:2 0 100M 0 part
├─sda3 8:3 0 16M 0 part
├─sda4 8:4 0 666.4G 0 part
├─sda5 8:5 0 256M 0 part /boot/efi
├─sda6 8:6 0 261.3G 0 part /
└─sda7 8:7 0 3G 0 part [SWAP]
I have separate efi partitions (One for Windows and other for Manjaro)
I followed the directions and get a solid black screen without a Lenovo logo until sddm loads.

Can I add the vendor to be shown during boot?

@Vitorvlv I don't know if this is your case, but have in mind that this logo thing only works with UEFI boot and not with old BIOS one.

About the resume error, you have to point the kernel to your swap partition in the bootloader options. Hopefully it's just that. If you don't have swap or don't wanna use hibernation, then remove "resume" from mkinitcpio HOOKS and Grub.
https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate#Hibernation

@xtristanx Oh man, I had the very same errors back when I did this, and I can't for the love of God remember what I did to solve it, it if was tinkering with some Grub parameter or what. I feel so sorry...

I can't find the direct relation, but I think my bad memory tells me that what I did was to load the KMS graphic driver module early in the initramfs? I'm not sure, but you can give it a try.

https://wiki.archlinux.org/index.php/kernel_mode_setting#Early_KMS_start

Check if there is an option in BIOS to show/hide logo.

Philm 's instructions say it does also in MSDOS.

Also grub-quiet has different default/grub, so pacsaves have to be merged.

It works in that you'll get a silent boot with no text output at all, but the beautiful manufacturer logo thing which is what I meant, needs UEFI if I'm not mistaken.

For certain it's that way in my BIOS/MBR setup.

1 Like

hi signalrunner,

thanks for your 'mental support', very appreciated :smile:

honestly, i went back to my old setup, too much hassle with sb right now.

i tried my best merging the (very differing) pacsave, but it even got worse after that. well, maybe next time.

1 Like

Re: Manufacturer's logo:
In my testing of grub-quiet (also latest version), both in uefi and bios-legacy. the manufacturer's logo is not seen in the desktop systems. But my desktop systems are not 'branded' systems. On the very old Dell laptop (bios-legacy) the Dell logo appears before grub kicks in both in grub-quiet and in 'normal' grub. But I think that's to be expected.

Re: GRUB_TIMEOUT=0
I see no difference using the 'normal' grub hide the grub menu using this way and grub-quiet. And I repeat my reservations about having GRUB_TIMEOUT=0. This could be problematic as shown in post 12 above if we cannot boot and needs another kernel or to amend kernel parameters.

1 Like

I don't know is this is what you mean, but I have Timeout at 0 and I can still use Shift key in order for Grub menu to appear and make selections.

If Grub is broken, it's broken, but if it is about selecting another kernel or changing the command line options, Grub with timeout=0 is still OK in my end.

Can you recheck your /etc/default/grub and see if GRUB_TIMEOUT=0 is there?
If it is there, can you do 'sudo update-grub' and try again with shift key?

Note here, and here shows shift key does nothing. If your experience is different, it will be interesting to note and after doing update-grub, can you post your /etc/default/grub ? Also a confirmation of "pacman -Ss grub | grep installed" to see if you have 'grub' or 'grub-quiet' will be good. Thanks.

There is no need to recheck, trust me, I am 100% sure of my setup. And I just rebooted and tried again, to be certain.

Oh yeah, I'm talking about "grub-quiet". Sorry, did you meant normal grub only? My bad.

Forum kindly sponsored by