Issues with BCM43228

Using the default wl driver results in connection dropouts. I recently upgraded to a 4.14 on KDE, but before (on an older kernel) I used Budgie and was able to install the b43 driver to gain normal WiFi access. Perhaps it is because of the new kernel or the different desktop environment and preinstalled software.

I have tried blacklisting wl after installing, but I can't get b43 to work on startup. If I run sudo modprobe b43, the wireless interface works, but lspci -k still returns that bcma-pci bridge is in use, as opposed to b43.

Is there a way to run sudo modprobe b43 on start up, or is it not installed completely despite saying that it is in pamac?

Running lspci -k results in:

03:00.0 Network controller: Broadcom Limited BCM43228 802.11a/b/g/n
        Subsystem: Broadcom Limited BCM43228 802.11a/b/g/n
        Kernel driver in use: bcma-pci-bridge
        Kernel modules: bcma, wl

Also, iw dev returns:

        Interface wlp3s0b1
                ifindex 3
                wdev 0x1
                addr xx:xx:xx:xx:xx:xx
                type managed
                channel 149 (5745 MHz), width: 2

Yes there is a way.

Create the file:


Add the following to the contents of /etc/modules-load.d/b43.conf


Then issue these commands:

sudo depmod -a                 

sudo mkinitcpio -P   

Reboot afterwards.

If it's still not working after restarting then please post some further info.

modprobe --showconfig | egrep "^install|blacklist" 
find /etc/modules-load.d /etc/modprobe.d /usr/lib/modprobe.d -type f -name "*.conf" -print -execdir cat '{}' \; -execdir echo \;
inxi -Fxxxz

I would also install and test newer and older kernel for improvement.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by