Issues with gaming on Manjaro i3 with Optimus

Hello! This is my first time posting on this forum so my apologies if I am repeating something, I believe there isn't anyone who has answered this specific question yet, but if I'm wrong, please point me in the right direction! The goal here is fixing the problem lol.

I just moved over to Manjaro from Ubuntu and I have been enjoying the experience greatly! I would like to think am well versed in linux as a platform for development, and i3 has definitely helped me be a more productive person! That said there are some challenges with running it on this laptop that i had not expected. Specifically, the presence of optimus and gpu switching in general. For day to day tasks this has not been an issue and I have acclimatized to simply using intel graphics and being okay with it. On my laptop screen its not an issue at all! Unfortunately, while working at my desk with an external monitor, I experience horrible screen tearing and I am altogether unable to take advantage of the reasonably powerful graphics card I have to do any kind of gaming! I am by no means a hardcore gamer, and i don't expect flawless at all times, but I would like to be able to get the same kind of performance i got while gaming on ubuntu, specifically in the Witcher 3 where i saw 50-60FPS pretty consistently at 1080p.

I spent a good bit of time on various forums, reading, testing, and generally mucking around with bumblebee, various xorg configurations, optimus-manager, etc. But nothing has allowed me to replicate the performance i was seeing previously. Its getting to the point where i am worried i am simply cluttering my laptop and am unaware of where the problem lies. If anyone has any experience setting up something like this, some guidance would be much appreciated! I am more than willing to answer any questions people have, but honestly i have tried so much at this point that listing it would start becoming repetitive quickly and would end up simply demonstrating a lack of understanding of my own setup :frowning:.

Thanks for any help i can get! I will end this post with some information about my laptop, I am more than willing to provide more if need be.

inxi -Fxz output:

System:    Host: amthy15-pc Kernel: 4.19.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: i3 4.16 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Notebook product: P95_HP v: N/A serial: <filter> 
           Mobo: Notebook model: P95_HP serial: <filter> UEFI: American Megatrends v: 1.05.12RLS2 
           date: 02/09/2018 
Battery:   ID-1: BAT0 charge: 53.0 Wh condition: 53.0/53.2 Wh (100%) model: Notebook BAT 
           status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake 
           rev: 9 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44944 
           Speed: 900 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1641 2: 900 3: 898 4: 1212 
           5: 900 6: 986 7: 924 8: 900 
Graphics:  Device-1: Intel vendor: CLEVO/KAPOK driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: CLEVO/KAPOK driver: nvidia 
           v: 415.27 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: nvidia 
           resolution: VIRTUAL1.447-1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.3.2 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.19.16-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK 
           driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 04:00.0 
           IF: enp4s0 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: d000 
           bus ID: 06:00.0 
           IF: wlp6s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 74.89 GiB (6.4%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO M.2 250GB size: 232.89 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB  
Partition: ID-1: / size: 211.10 GiB used: 23.58 GiB (11.2%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.10 GiB used: 54.8 MiB (0.3%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 69.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 214 Uptime: 2h 48m Memory: 15.55 GiB used: 1.57 GiB (10.1%) Init: systemd 
           Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.30 

if you want perfomance (and/or vulkan), don't use bumblebee.

edit:
why did you left ubuntu? was there a specific issue ?

Thanks for the reply! There was no issue on ubuntu, I just really enjoyed the few arch installs I had done for friends and wanted something close to the arch i3 experience. Manjaro was a bit cleaner for personal use but allowed me the freedom to make my own environment. Gaming is not my focus here, I am primarily a developer, but it would be nice to be able to play a few games here and there.

If bumblebee is not the correct solution, what is the best way to cleanly uninstall it and what should I be using instead? Ideally the way I want this system to function is by using the intel gpu primarily and switching to nvidia only when using HDMI output. I thought bumblebee was the way to go for that but if it isn't I'm well and truly lost.

What is your output of mhwd -l? I'm wondering you can do this sudo mhwd -i pci video-nvidia or sudo mhwd -i pci video-nvidia-390xx

Thanks to you as well!

my mhwd -l output is

e[1me[31m> e[m0000:01:00.0 (0300:10de:1c20) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
          video-nvidia            2018.08.09               false            PCI
    video-nvidia-390xx            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI


e[1me[31m> e[m0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI


e[1me[31m> e[m0000:00:02.0 (0300:8086:591b) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI

regarding the mhwd -i video-nvidia, that appears to fail because it conflicts with the bumblebee driver? should i uninstall that driver first? what would i need to do to switch between cards if bumblebee is not installed?

that's because it's only allowing one proprietary driver at a time. Yes switch to free and unistall bumblble then try to install the other one.

if it still fails I don't know. You'd be running into the same issue I had with the KDE gui tools. So maybe someone else does but please report whether or not the switch out worked.

also possible:
using modesetting or intel drvier for intel and nouveau for nvidia (if your nvidia gpu is somewhat properly supported by nouveau)
(see arch wiki link above)

Also worth to consider would be staying on ubuntu as imo there's not much difference between various distributions. Some have somewhat newer packages then other or newer/older kernel version or use other dm and de as default but basically they dont differ that much. Of course if you want to use arch/manjaro use that and one of the options above.
Also dont support nvidia when you buy your next laptop if you plan to use linux in the future unless they provide proper drivers (because the whole "nvidia-optimus-linux-situation" is pita)

best regards

1 Like

Could you please format this up as a #faq post so it can be linked to (and updated) instead of having to type it all out each time?

Title it something like "What are my options for Optimus graphics?"

That was actually incredibly helpful!!! I wish i had found a list like this before, I was continuously running into various individuals who swore by each of those solutions and couldn't figure out which one was for me. I'm going to try all four of those options and if none of them work I guess ill have to simply feel bad for my wallet, use Intel exclusively, and buy a ps4 for when I get bored XD.

Regarding your last 2 points: I know that ubuntu is a very good and user friendly distro but I was beginning to get bored with it and wanted to switch to arch + i3. Having set up arch on various other systems and having worked with LFS a bit with a group of students at my college, I thought this would be easy and it was in general. Getting everything set up for my day to day work was a breeze. I ran into issues when trying to play some casual games and not having a properly functioning driver has been annoying. Regardless of whether or not i fix this, I will def be getting a new laptop in the next year and its going to be an x1 carbon to make everything nice and easy.

I do hope that someone does what jonathon says and puts this in the FAQs, it seems like a weird problem but this made it very easy to understand and at least attempt to fix. Thanks for all the help from everyone!

That's exactly the same reason I got out of the Ubuntu world in fact I was just thinking about the fact that one of the reasons I can never go back is simply because of the package manager. Pacman feels so much easier to use because the common commands are shorter. Plus the AUR access.

I'll try tomorrow/upcoming weekend

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by