Issues with installing manjaro on a windows 10 uefi machine

All right I took some photos, here's what's happening

This is when I boot the usb on an older machine, which boots and works just fine

This is how I'm booting the USB in the Windows 10 machine

This is how it looks after that (I wander why this screen is it different from the older windows 7 machine?)

And this is where it gets stuck

Please help me, living with Windows 10 is horrible I can't do it :cry:

Hi @Nedkelly ,

did you also try the "nonfree" boot option (as written in the UEFI variant)?

The difference for the different boot screens is most likely the result of using the legacy boot variant on the Windows 7 machine whereas you are using the UEFI boot variant on the Windows 10 machine.

Bernhard

Hi Bernard,
I can't select any other options because as soon as I hit the arrow keys everything freezes. All I can do is to wait for the countdown to finish. At that point the first highlighted option will start - only to freeze again while loading.

Are there any special procedures to setup the machine via bios when you have windows 10 and uefi? Maybe I just missed a step?

Hi @Nedkelly,

Unfortunately I can't say that for sure as I don't have a Windows 10 system. But normally it is possible to switch to legacy mode in BIOS/UEFI. But I can't guarantee that Windows 10 will boot afterwards (at least without switching back).

I once had a similar problem with "freezing". In fact it had to do with USB 3.0 and an USB 3.0 stick. After I switched to an older non-USB 3.0 Stick I was able to boot. But this does not have the case for your system/stick. I assume my USB 3.0 stick was defective after all.

Do you have connected an external keyboard to your system? If so, please try it without it.

I hope someone else has some more ideas how to fix this.

Bernhard

Hi all,

Update: I tried Antergos and it goes past the first select menu but still freezes when loading te os
So I tried Fedora and it boots normally (I didn't install I'm in the try mode)

Is it a compatibility issue with arch then? Are there any ways I can diagnose what's wrong with the loading process?

And last but not least is it possible to make the developers aware of any hardware compatibility issues for future releases?

Thanks

Hi @artoo
Thanks for the heads up

The details of the Asus GL502VM are:

  • windows 10
  • i7 6700
  • nvidia gtx 1060 only (no integrated card)
  • 16gb RAM DDR4
  • Intel® HM170 Chipset
  • SATA3 SSD
  • no. 3 USB 3 adapters

What I've done is to burn the manjaro gnome ISO on a USB stick and tested it on a virtual machine (Where it worked like a charm).

After that I setup the bios disabling secure boot and fast boot, and then I tried to boot manjaro but I ran into the problems listed above.

What makes me suspicious about the distro is that fedora does boot but I really don't know because I'm really unfamiliar with uefi and windows 10 (and I can't figure it out by googling around)

I really hope someone can help me. There must be a way to diagnose what the issue is. Anyone? :cry:

If were you, I'd also try these dumb things that could be the issue, like verifying your ISO's checksum and trying with an other USB stick. I installed Manjaro again a few days ago, with an ISO that had the correct checksum, but the install would fail and/or the live session would freeze after a few minutes ; I burnt the very same iso on the very same key again and it fixed everything.

Fedora booting and arch based distros not booting would suggest problem with secure boot, but you already ruled that out and you should not be able to get to the bootloader in the first place if that was the case.

In that black bootloader screen, what happens when you press 'e'? This should give you kernel command line editor which could help you boot with nonfree drivers.

I would probably try a different iso. You could still install gnome version by using manjaro-architect installer.

Thanks @Chrysostomus
I tried pressing e and I can see the command line but it's all freezed so I can't change anything

Did I miss something during the creation of the live USB? Like, should I use the gpt partition scheme? How would you create te live USB if you were to use my system?

Sorry just tried gpt as opposed to mbr and I didn't see any changes in the behaviour of the installer it gets stuck in the same way.

I also tried a fresh downloaded ISO on another USB drive so we can exclude any defects in the ISO image and in the USB device. I also tried the very same USB on an older laptop and it works..

Just tried XFCE and ran into the same issue but this time it's slightly different. This is where it gets stuck if I leave the countdown going and start the first option (free driver install)

As you can see from the previous screenshots now it's slightly different. What's Plymouth anyway?

Plymouth is the graphical boot screen after the bootloader and before display manager (login screen) that is used to hide boot up messages. Usually causes all sorts of weird issues.

How exactly do you create your live iso? I think Rufus is the recommended method on windows and isousb/imagewriter/dd on linux.

If you have already grub installed from another Linux, you can also boot isos directly from grub without burning isos (also gives faster performance often).

Seems to be a graphic issue, "Plymouth errors" will crop up at boot whenever there's a graphic issue, of course (because the graphics not right).

Others too has the graphic issue with Asus ROG
But not clear why your keyboard won't work at boot menu.
Since I don't have Asus ROG or this type of graphic cards (and I'm not good in driver thingy), I'll have to pass on this. Hope others can help further.
Good luck.

[edit] - wrong link provided, corrected above, sorry.
And as for keyboard not working, there's a link (first link) in that search where avinab provided a solution

i gave acpi_osi=! acpi_osi="Windows 2009" in kernel boot parameters and it worked.

But please beware, I repeat, I personally do not know stuff like this. Just quoting.

According to @artoo, future manjaro isos are going to use grub instead of systemd-boot, so if this is caused by the bootloader, that might get fixed.

Hi. I think you can try to boot from iso file, see tutorial by @gohlip on this.


Maybe you will be able to set needed boot parameters that way.

Hi @kainonergon thanks for the link but that tutorial seems a bit too hard for me.
Maybe it is a graphic issue, and maybe it's because this laptop comes with an nvidia card "ONLY"?
Fedora does boot up but in 800x600 only (which won't let me install from graphical installer as I can't see the buttons in such a tiny screen!)

But this still wouldn't explain why the install menu freezes as soon as I press any key..

I'm happy to pay for someone to get it up and running but I'm not sure if I can find that someone in my city (Melbourne).

Hi @Nedkelly,

as it seems that other Distributions boot at least, you could try an older version of the Manjaro installation media.
If that works I would think that there exists some incompatibility between your Mainboard/CPU and the used kernel (4.9 on the newer medias I think).
If the boot works you could still install it from that media and upgrade afterwards to the newest packages.

Bernhard

Hi @dot

This is an excellent idea I'll try and let you know how it goes.
Just one thing though, where can I find older versions?

Forum kindly sponsored by