Issues with the Stable Update 2019/04/03

After updating and rebooting my system (Manjaro KDE),

  • my Desktop wallpaper isn't showing
  • Latte dock also isn't showing icons on the dock (although it is responding but no icons)
  • Screen tearing is also occurring too
  • Most of the Animations are not working, only few like fading on menus and on logging on screen are working only
  • Blur on terminal background is also not working.
[abhi@ABHI ~]$ inxi -Fzxc0
System:    Host: ABHI Kernel: 4.19.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: KDE Plasma 5.15.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP 245 G5 Notebook PC v: Type1ProductConfigId 
           serial: <filter> 
           Mobo: HP model: 81E5 v: KBC Version 73.16 serial: <filter> UEFI [Legacy]: Insyde 
           v: F.31 date: 04/18/2018 
Battery:   ID-1: BAT0 charge: 31.5 Wh condition: 38.2/38.2 Wh (100%) 
           model: Hewlett-Packard Primary status: Discharging 
CPU:       Topology: Quad Core model: AMD A6-7310 APU with AMD Radeon R4 Graphics bits: 64 
           type: MCP arch: Puma rev: 1 L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 15973 
           Speed: 998 MHz min/max: 1000/2000 MHz Core speeds (MHz): 1: 1023 2: 1109 3: 1006 
           4: 1137 
Graphics:  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard driver: radeon 
           v: kernel bus ID: 00:01.0 
           Display: x11 server: X.Org 1.20.4 driver: radeon FAILED: ati unloaded: modesetting 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: N/A v: N/A direct render: N/A 
Audio:     Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus ID: 00:01.1 
           Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Sound Server: ALSA v: k4.19.32-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Hewlett-Packard driver: r8168 v: 8.045.08-NAPI port: 3000 bus ID: 01:00.0 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek RTL8188EE Wireless Network Adapter vendor: Hewlett-Packard 
           driver: rtl8188ee v: kernel port: 2000 bus ID: 05:00.0 
           IF: wlp5s0 state: up mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 13.77 GiB (3.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-60VHAT0 size: 465.76 GiB 
Partition: ID-1: / size: 15.62 GiB used: 11.17 GiB (71.5%) fs: ext4 dev: /dev/sda5 
           ID-2: /boot size: 476.2 MiB used: 52.2 MiB (11.0%) fs: ext4 dev: /dev/sda2 
           ID-3: /home size: 76.89 GiB used: 2.55 GiB (3.3%) fs: ext4 dev: /dev/sda6 
           ID-4: swap-1 size: 4.88 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 52.5 C mobo: 0.0 C gpu: radeon temp: 52 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 161 Uptime: 38m Memory: 3.33 GiB used: 1.43 GiB (43.0%) Init: systemd 
           Compilers: gcc: 8.2.1 Shell: bash v: 5.0.2 inxi: 3.0.32 

Screenshot_20190404_234027

Could be related to mesa, but i have not much experience with AMD GPU's
downgrading mesa might help.

1 Like

can I downgrade with Pamac ?

See this part

2 Likes

pamac update --enable-downgrade
or
pacman -Syyuu
or
turn on Enable downgrade option in pamac GUI

1 Like

Check your mesa version first

pacman -Qi mesa | grep Version 

If it's 19.0.1 and you want to downgrade to 18.3.5 then:

cd /var/cache/pacman/pkg/
sudo pacman -U mesa-19.0.1+really+18.3.5-1-x86_64.pkg.tar.xz lib32-mesa-19.0.1+really+18.3.5-1-x86_64.pkg.tar.xz 

else use pacman -Syyuu to force the installation of 19.0.1

2 Likes

Problem solved now. I forced the update through -Syyuu command.

1 Like

This saved my day.

Thank You ! :smiley::wink::yum:

I have to chime in and say that I was also someone who was having a problem getting into my Gnome setup using an AMD Ryzen 5 2400G with integrated video. I was still able to drop down to the command-line interface to log in as root.

After seeing the advice in here and in a few other threads about using pacman -Syyuu, I gave this a try. This worked and here I am to testify that.

I forget which 5 packages were changed but all of those that were replaced had "+really+18.3.5" trailing within the names.

It's all good now.

Great.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by