I've had to downgrade Thunderbird 68 back to 60.

This week i gave up my fight of a couple of months with TB68 & downgraded it back to 60. From all my testing/fighting with it, IMO my problem will only be relevant for a small subset of other Manjaroos, at most. Preconditions:

  1. Decades of data accumulated in it.
  2. Said data comprises Emails AND Events AND Tasks [ie, Lightning is very intensively used]
  3. Within Tasks, must be large number of Completed as well as Incomplete Tasks [eg, hundreds]
  4. Within Tasks, must use the "Incomplete Tasks" filter [if all the preceding are met yet user does not use this filter, the problem will not be seen].

Anyone not meeting all those conditions can save their time & stop reading now. Otherwise, fyi fwiw, below are my accumulated filenotes on this problem & explanation for my reluctant recent d/g.

Only for patient people who don't mind reading...

2/9/19: The big update from 60.0 to 68.0 occurred yesterday, as part of the Manjaro "Testing Update 2019-08-31". Initially post-reboot, my new TB seemed fully tickety-boo [apart from the fact that multiple important Add-Ons*** are now disabled until/unless their Devs update them to suit the new TB].

Today however i discovered this peculiar bug. "Find" continues to work in Calendar, & in ALL the OTHER Task views EXCEPT for "Incomplete Tasks". This is an important frequently needed function for me, so this is a buggger.

Workaround: Til further notice [ie, it gets solved], any time i need to search "Incomplete Tasks", change temporarily to the "All" view. Once i've found my target Task/s, then can return to my usual "Incomplete Tasks" default view. Sassen frassen rassen...

Created this Task to memorialise the problem. Will set it to remind me in say 2 months' time, re is it fixed yet?

*** multiple important Add-Ons*** are now disabled...

  1. Calendar Tweaks
    Review comment by Topoldo on Sept. 26, 2019
    "Just to inform all of you that I contacted the author who told me that he doesn't use TB anymore and does not intend to update this extension for TB 68+"

  2. Extra Format Buttons

  3. Highlighter

  4. ReminderFox = "compatible" but nonetheless, barely works [& UI now sucks]

  5. Extension Options Menu

  6. Theme Font & Size Changer

4/11/19: Not only is the problem not fixed, it's actually become much worse. For the past 24 hours, following an edit i made to Task "Ring %%%", the "Incomplete Tasks" filter is completely broken; does not show anything. This is a much worse problem than the original one. ■■■■■ Also, that specific Task now no longer even appears in the "Today Pane" tasks list. Wtf?

Well, there was something weird with that specific task... i copied its text contents to Kate, deleted the task, noted that now the "Incomplete Tasks" view works again [albeit still cannot Find], manually recreated the contents in a new Task, & it's good. Wtf? How could the previous iteration of that task have completely broken the view?

17/11/19: ■■■■ it, lately the Tasks' "Incomplete Tasks" filter has completely broken again, once more showing nothing. I've had enough of this shyt, so decided to abandon this troublesome v68.x & Downgrade to 60.x.

[kdemeoz@GA-Z97-HD3-Tower ~]$ downgrade thunderbird
Available packages:

-   1)  thunderbird    60.4.0  1  x86_64  (remote)
    2)  thunderbird    60.5.0  1  x86_64  (remote)
-   3)  thunderbird    60.5.1  1  x86_64  (remote)
    4)  thunderbird    60.5.1  2  x86_64  (remote)
    5)  thunderbird    60.5.2  1  x86_64  (remote)
-   6)  thunderbird    60.5.3  1  x86_64  (remote)
    7)  thunderbird    60.6.1  1  x86_64  (remote)
-   8)  thunderbird    60.6.1  2  x86_64  (remote)
-   9)  thunderbird    60.7.0  1  x86_64  (remote)
-  10)  thunderbird    60.7.1  1  x86_64  (remote)
-  11)  thunderbird    60.7.2  1  x86_64  (remote)
-  12)  thunderbird    60.8.0  1  x86_64  (remote)
-  13)  thunderbird    68.0    1  x86_64  (remote)
-  14)  thunderbird    68.1.0  1  x86_64  (remote)
-  15)  thunderbird    68.1.1  1  x86_64  (remote)
-  16)  thunderbird    68.2.0  1  x86_64  (remote)
-  17)  thunderbird    68.2.0  1  x86_64  (local)
-  18)  thunderbird    68.2.1  1  x86_64  (local)
+  19)  thunderbird    68.2.2  1  x86_64  (remote)
+  20)  thunderbird    68.2.2  1  x86_64  (local)
21)  thunderbird    68.2.2  2  x86_64  (remote)

select a package by number: 12
[sudo] password for kdemeoz: 
thunderbird-60.8.0-1-x86_64                             35.8 MiB   728 KiB/s 00:50 [#] 100%
thunderbird-60.8.0-1-x86_64.sig                        310.0   B  0.00   B/s 00:00 [#] 100%
loading packages...
warning: downgrading package thunderbird (68.2.2-1 => 60.8.0-1)
resolving dependencies...
looking for conflicting packages...

Package (1)  Old Version  New Version  Net Change

thunderbird  68.2.2-1     60.8.0-1      -7.33 MiB

Total Installed Size:  148.87 MiB
Net Upgrade Size:       -7.33 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                                         [####] 100%
(1/1) checking package integrity                                                     [####] 100%
(1/1) loading package files                                                                 [####] 100%
(1/1) checking for file conflicts                                                        [####] 100%
(1/1) checking available disk space                                                 [####] 100%
:: Processing package changes...
(1/1) downgrading thunderbird                                                       [####] 100%
:: Running post-transaction hooks...
(1/3) Updating icon theme caches...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...
add thunderbird to IgnorePkg? [y/n] y
[kdemeoz@GA-Z97-HD3-Tower ~]$ 

This automatically also downgraded Lightning to the right version compatible with this older TB, & joy oh joy, now Tasks is once more fully functional -- yay + phew!

I was temporarily stunned to find however that heaps of my AOs now had become Disabled & marked as Incompatible, but this was easily solved by reinstalling them one by one which then fetched the compatible versions. So, atm, all's good with it.

The obvious future anxiety is for security... by now d/g'ing & freezing, will i become vulnerable to future security flaws? Otoh what practical choice did i have now -- retain the secure latest version but accept major breakage of my mandatory workflow, or do what i've done?

I have a similar issue with the Events panel staying blank even with events planned soon.
Only workaround effective so far is to keep a Calendar tab open at all times -- it's not necessary to keep it on the forefront.

In case that helps...

1 Like

@Kadee - now you have done it :musical_note: thunderbolts and lightning very very frightening me :musical_note:

Arrrrrrggggggghhhhhhhhhh :rofl:


Based on your OP, it's probably not an option...but have you ever contemplated breaking your email and calendar to separate apps?

1 Like

Not for this explicit bug, but simply for my daily workflow, my habit of years-standing is to always keep three tabs open; Email, Calendar & Tasks. When this v68 bug arrived, those extra tabs did not avert the symptom. Note - the symptom is very specific per my OP... all other aspects of TB & L work fine for me... but i am extremely reliant on availability of that "Incomplete Tasks" filter, hence its chronic malfunction in all dot-releases so far of v68 is untenable for me.

I love it... t/y... & a forum search would reveal that i also have been guilty of committing this same homage in other threads. :crown:

Indeed i have, & have previously done so. A year or two ago i stopped using TB/L for Tasks management, & adopted Task Coach for that [after a thorough review of alternatives]. I continued using TB/L for Email & Events. TC is good, & powerful, & for a long time i was satisfied...'ish. However, i learned time-management professionally in the late 80s / early 90s from Time Management Inc [as a customer, not staffer] during my plant engineer career, using initially their analogue Time Manager stationery ["elephant-bites"; anyone?], then later their windoze program of it. I learned the value, utility & power of tightly integrating Tasks with Calendar [an awareness i later parleyed into my >decade intensive usage of MS Outlook professionally & privately]. Hence, my latterday-separation of those two facets for the time i used TC, was never going to be able to survive permanently in my workflow, as the compromise & inefficiency of the functional separation constantly needled me & eventually triggered my resumption of my Tasks management back in TB/L. This tool has been pretty bullet-proof for me even with my decades of data in it... until v68, sadly.

PS: I hope sincerely nobody will take the following info as an excuse / invitation to now detour my thread into a debate of alternative PIM candidates... in previous years, albeit not recently i admit, i intensively trialled both Evolution & KOffice [especially KMail & KOrganiser] as alternatives to TB/L. Whilst each of them had various individual elements of merit, overall i judged them unsuitable for me. However in fairness i should add that a major part of their unsuitability for me was their [either] complete inability or otherwise inadequate means of importation of my vast MS Outlook data [email, calendar, tasks, addressbook & notes; foregoing all this was not negotiable], whereas because [as you can tell, the timing here was back during my migration from windoze to Linux] TB was available in windoze the data migration from Outlook to TB/L was reasonably straightforward to do in windoze, then that TB data was immediately reusable in Linux. I suspect a nightmare would await me now were i to endeavour migrating everything from TB/L to Evolution or KOffice [even without considering their individual flaws & deficiencies].

1 Like

I think that this bug report is referring to the "Incomplete Tasks" issue in Thunderbird:

It was reported about two weeks ago and its status is set to UNCONFIRMED at the moment.
Hopefully this issue will get fixed in newer releases of Thunderbird - at least there is information so that the development team can look at it and eventually fix it.

Regarding security, versions 68 and 68.2 of Thunderbird introduced some fixes to critical (as they call it in the release notes) vulnerabilities. You can find more about these here (see the bugs marked as "critical"):

As for the addons, it seems that most of them are not compatible with version 68.x of Thunderbird at the moment, but hopefully addon compatibility will improve over time. As mentioned in the comment you quoted, it's up to their developers to make the addons compatible with the latest version, so there isn't much you can do about it.

I would say that Thunderbird seems to be in a transitional stage at the moment, so I really don't know if upgrading it - for security reasons - or holding it back - to retain its features and functionality - is the best way to go. :man_shrugging:


Oh wow, thank you so much for this, i am very relieved to know now there's at least one other person on Earth also seeing this nuisance bug. I did not think to search Mozilla specifically [:woman_facepalming:] but only did a DDG search of the general web, which annoyingly had not given me this link, sigh [as an aside, IMO DDG years ago was much better than it seems to be these days].

A point of detail, not mentioned explicitly in my OP, nor at all in that Bug Report: If the TB/L database contains only a tiny number of Tasks [eg, i tested a clean installation of 68.x with only 4 new/dummy tasks], all the Tasks filters [ie, including "Incomplete"] still work. The bug manifests somehow once the total tasks quantity exceeds some threshold [given i have several hundreds, i seem to have sadly crossed this threshold].

Re the security & your remarks, yes it is a lousy choice atm. However despite my usual preference for security holistically, i chose to prioritise a NOW major adverse impact on my workflow higher than a FUTURE-MAYBE security problem, thus feel i must retain 60.x indefinitely til Mozilla fix v68+.

Once again, you have been a marvellous help thank you!

I added my input to the bug:


24/11/19: ■■■■ it, today's huge Manjaro Testing-branch Update broke my recently downgraded TB; it would not launch at all, with this error when trying from Konsole:

[kdemeoz@GA-Z97-HD3-Tower ~]$ thunderbird
XPCOMGlueLoad error for file /usr/lib/thunderbird/libxul.so:
libicui18n.so.64: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
[kdemeoz@GA-Z97-HD3-Tower ~]$

I then tested TB in all my MJ & CJ VMs in Tower, all of which now had the newest TB v68.2.2-2 from today's updates -- they all launched fine. Then tested TB v68.2.2-2 on Lappy after its update today -- also launched fine. Therefore, the only TB now broken = the only TB that i'd downgraded. Suspecting that my d/g version is now incompatible with newer libraries, i made a copy of my entire .thunderbird directory, called it .thunderbird_for_v60.x, unfroze TB in Pamac, allowed it to then be upgraded thus:

Synchronizing package databases...
Warning: android-tools: ignoring package upgrade (8.1.0_r33-1 => 29.0.5-1)
Resolving dependencies...
Checking inter-conflicts...
Downloading thunderbird (68.2.2-2)...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading thunderbird (60.8.0-1 -> 68.2.2-2)...
Running post-transaction hooks...
Updating icon theme caches...
Arming ConditionNeedsUpdate...
Updating the desktop file MIME type cache...
Transaction successfully finished.

, & was then able to successfully launch it ok... phew. So that's good, but the price i've had to pay is that now once more i cannot Find items in the Tasks' "Incomplete Tasks" filter. One small glimmer however is that this newest TB does at least once more actually show all the "Incomplete Tasks", even though i cannot search in them.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Thank you @cscs for kindly reopening this for my new post.

I'm happy to advise that very recently the TB Devs fixed this bug, & deployed that fix in Thunderbird 68.10.0. When i did my updates today [...btw :roll_eyes:], i got that one too, & i'm really pleased to see that yes indeed, the bug is quashed & the Incomplete Tasks filter now finally works again.

Just goes to show that if you nag some Devs long enough they eventually kneecap you in exasperation allocate the resources & solve the problem.


Forum kindly sponsored by