Jack and Audacity | No sound when Audacity is open | Xruns

So my problem is that even though I've replaced ALSA with JACK, in order to be able to record something in audacity and simultaneously listen to another audio source, as soon as I open up audacity JACK runs into infinite Xruns resulting in no audio what so ever. I actually managed to solve this issue a few months ago because audacity would pop up in CATIA or CLAUDIA and I was able adjust input and output but this time it does not. I've tried all possible adjustments (to my knowledge) in JACK and in audacity.

I followed the guide of crazyg4merz:

Thanks

Does Audacity Device Toolbar show 2 options - "JACK Audio Connection Kit" and "ALSA"?

What JACK / ALSA device(s) are selected in Audacity?

In Audacity Preferences>Recording are either of the 2 Playthrough options enabled?

presume from OP you are using Cadence rather than QjackCtl to control JACK?
what ALSA device(s) do you have set for recording and playback in Cadence?
Are you using Pulseaudio bridge or ALSA loopback?

Yes, under Preferences>Devices - there are two options JACK and ALSA.

I have set my USB mixer as the playback device and the onboard line in as recording device.
However under playback my USB mixer sometimes is listed and sometimes not..
Under the recording tab -Other tracks while recording (overdub) is checked, software playthrough is not.
I am using Cadence with the Pulseaudio bridge, in Configuration>Driver>ALSA - I have the device/interface set to hw:0, Input device as the analog in on the mainboard and the output device set to my USB mixer.

Manjaro has package pulseaudio-jack which will automatically load 2 connections in JACK

  • Puleaudio JACK Sink (audio from players and firefox)
  • Puleaudio JACK Source (microphone connection to voip)

Hit the main start button in Cadence and get this showing in Catia:



I haven't tried Cadence in Manjaro for a couple of years, never found any of the ALSA loopback options in Cadence worked well in Manjaro

Some USB mixers can be picky about whether they start first or pc, and whether usb should be plugged in. Only know a couple of people who use USB mixers, both found the USB problematic and went back to using onboard.

Suggest just use onboard device for input and output 'system' settings in Cadence/JACK
If can get onboard running ok without x-runs, add on USB playback later with command like this:

/usr/bin/alsa_out -j usbmixer -d hw:XXXX,0 -q 1 2>&1> /dev/null &

Ideally you want XXXX to be hardware name if the hw: number of mixer is likely to change
to get the correct name:

cat /proc/asound/cards

Settings for Frames/Period may need to be higher for both cards to keep x-runs down
Periods/Buffer set at 2 is usual for onboard devices or 3 for USB
(Cadence only shows block latency, multiply by Periods/Buffer number for full latency)

And try sample rates of 44100Hz and 48000Hz
pro-audio gear doesn't always perform well at 44100Hz

Oh okey, one thing that I noticed is that in audacity I have only JACK source available under playback devices and JACK sink as recording device..that should be the other way around, right? Could this be why no matter what I try I only run into Xruns once I start audacity?

Thanks, for you support :slight_smile: .

Tried using onboard, but know as soon as I start JACK the line in doesn't work.

Nevermind I got it working, if I use the onboard audio as IN and OUT, audacity works fine. So it was because of the USB mixer.. thanks.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by