Jack Audio Confusion

I am trying to setup my system to run Reaper linux and Bitwig Studio and am trying to get my audio setup properly. I have a Focusrite Saphire 24 Pro firewire interface.

I have Jack 0.9.2-1 installed but it will not start either through Cadence or through the Jack Audio connection kit.

I'm confused...First am I running the correct version of Jack? There is Jack, Jack-Dbus, Jack 2, and some others. I really don't want to hose my system through continuous trial and error. I was hoping someone could shed some light on this. As much as I have searched I can't seem to find anything definitive on which Jack version to use when, and for what reason.

I have switched over to a Real Time kernal and have configured my system per the github realtimecinfigquickscan.

I have a TI Firewire card that performs flawlessly under Windows and is on the Focusrite whitelist. I have installed the FFADO mixer. The Jack Audio connection kit said I needed the FFADO driver. Then when I installed the driver the mixer was uninstalled. This seems to be way more convoluted than it should be. Anyone with experience in this have some advice? I'd like to at least get pointed in the right direction as I have already tanked my system once using the trial and error method Timeshift saved me so at least I didn't have to start completely from scratch. It's crazy it should not have to be this complicated. I can see now why some normal users are reluctant to take a go at Linux. I'm stubborn and will probably figure it out (eventually) but I'm sure a lot of others would just give it up at this point.

Use jack2 & jack-dbus and set up cadence to auto start jack at login.
see also
How to replace Pulseaudio with Jack, Jack and PulseAudio Together as Friend

Great Stuff Robin. This should keep me busy for a while.

Any idea on where to get Jack2-dbus as it does not seem to be in the repository? This is what is referenced in the link. When trying to install jack-dbus Pamac tries to uninstall jack2. It looks lik ethey don't want to play nice with each other.

Making progress. I used the Jack2-git file on Pamac and was able to get the Jack server running and sending audio to Reaper.. Now I need to figure out how to get rid of the X-Runs and I should be set (fingers crossed).

Jack2-git takes the place of Jack2 and Jack2-dbus all in a single download from what I read.

Getting JACK off the launchpad can be a major pain
but once the correct settings to start are sorted out it will start no problem
(never failed for me on same Manjaro install for over 3 years now)

jack2 implicitly uses d-bus, and does not need a 2nd version like jackd

do not recall anyone on here having a firewire device so may only get general help with JACK
might be better chance of more specific help at either https://linuxmusicians.com/ or direct to http://www.ffado.org/

x-runs can be reduced by increasing setting for 'frames/period'
(but at cost of increased audio latency)

setting for frames/period is usually recommended to be set to '2' for internal devices and '3' for USB devices - suggest try both and see what works better
(bigger number = more latency here too, but cadence only shows block latency )

pro-audio devices usually do not work well at default 44100Hz sample-rate
48000Hz is usually good minimum

if you need firewire support you have to install ffado

I'm running Jack now with a Sample rate of 48000, Buffer Size of 256, and a Periods/Buffer of 2. This results in a latency of 5.3 ms.

Jack starts and Reaper will pick it up and will only work properly when Jack is selected as the audio system. ALSA and Pulse Audio work ridiculously slow if selected.

The xruns might be acceptable if they were only an occasional click but many are dropouts that last 2-5 seconds.

Oh, and I have the FFADO mixer for my firewire interface it seems to mimic the factory windows mixer. Albeit in a somewhat more simplistic fashion.

I'll see if anyone at Linux Musicians has any suggestions.

cadence only shows block latency
buffer latency = 5.3 x 2 = 10.6ms on qjackctl
but it is only a calculated figure for guidance
(there is a tool that can accurately measure round-trip-latency, but latency is not usually a problem in many situations)

suggest increase frames/period to 512

and try changing periods/buffer to 3 like USB devices

x-runs will still happen if loading and unloading packages
or any other heavy load on system that prevents realtime audio
need to have no x-runs during a live/recording session
do not run other tasks during session

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by