Japanese Input, and a few other gnome things

Gnome 3.26 Kernel 4.16

I am trying to figure out the best way to add Japanese Input to Manjaro Gnome. I did a search, but the methods listed were over a year old and mentioned changing config files. I was hoping there was something easier and more up-to-date. Is there a simple method?

I would like to remove mouse-over corner function, I use the super key so this is not necessary, plus it occasionally happens by accident. Is that possible?

Also, is there a way to disable the touch keyboard on screen? I disabled it in settings, but it still comes on randomly when I touch the screen?

You can use the No Topleft Hot Corner extension for this.

I haven't tested it, but the Block Caribou extension claims to solve this problem.

You could install some input method applications, like IBus, Fcitx, SCIM or UIM, then add Japanese input.
Read arch wiki for how to set up. Wiki for IBus, Fcitx, other just in page's right side.

1 Like

Thank you, I will check out the wiki. I installed Fcitx but when I click on it, it only shows English and then the drop-down menu snaps back up.

Is there a way I can do it with out extensions?

You need do some work to setup the input method (see wiki) otherwise it just have default english(or direct input).
Fcitx itself is just a framework, you need install packages which providing actual input function, some like fcitx-anthy, fcitx-mozc. Search 'fctix' in your package manager.

1 Like

I read through the arch wiki. I added the config tool and was able to add mozc as an option. However, when I click any of the drop-down arrows it drops down for a second and then goes back up. I ran fcitx-diagnose and have pasted result below.

Thank you for your help.

# System Info:
1.  `uname -a`:

        Linux fuji-pc 4.16.0-1-MANJARO #1 SMP PREEMPT Mon Apr 2 08:54:07 UTC 2018 x86_64 GNU/Linux

2.  `lsb_release -a`:

        LSB Version:	n/a
        Distributor ID:	ManjaroLinux
        Description:	Manjaro Linux
        Release:	17.1.7
        Codename:	Hakoila

3.  `lsb_release -d`:

        Description:	Manjaro Linux

4.  `/etc/lsb-release`:

        DISTRIB_ID=ManjaroLinux
        DISTRIB_RELEASE=17.1.7
        DISTRIB_CODENAME=Hakoila
        DISTRIB_DESCRIPTION="Manjaro Linux"

5.  `/etc/os-release`:

        NAME="Manjaro Linux"
        ID=manjaro
        PRETTY_NAME="Manjaro Linux"
        ANSI_COLOR="1;32"
        HOME_URL="https://www.manjaro.org/"
        SUPPORT_URL="https://www.manjaro.org/"
        BUG_REPORT_URL="https://bugs.manjaro.org/"

6.  Desktop Environment:

    Desktop environment is `gnome3`.

7.  Bash Version:

        BASH_VERSION='4.4.19(1)-release'

# Environment:
1.  DISPLAY:

        DISPLAY=':1'

2.  Keyboard Layout:

    1.  `setxkbmap`:

            xkb_keymap {
            	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
            	xkb_types     { include "complete"	};
            	xkb_compat    { include "complete"	};
            	xkb_symbols   { include "pc+us+us:2+inet(evdev)"	};
            	xkb_geometry  { include "pc(pc105)"	};
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us,us", ",", ""

3.  Locale:

    1.  All locale:

            C
            en_US.utf8
            POSIX

    2.  Current locale:

            LANG=en_US.UTF-8
            LC_CTYPE="en_US.UTF-8"
            LC_NUMERIC=en_US.UTF-8
            LC_TIME=en_US.UTF-8
            LC_COLLATE="en_US.UTF-8"
            LC_MONETARY=en_US.UTF-8
            LC_MESSAGES="en_US.UTF-8"
            LC_PAPER=en_US.UTF-8
            LC_NAME=en_US.UTF-8
            LC_ADDRESS=en_US.UTF-8
            LC_TELEPHONE=en_US.UTF-8
            LC_MEASUREMENT=en_US.UTF-8
            LC_IDENTIFICATION=en_US.UTF-8
            LC_ALL=

4.  Directories:

    1.  Home:

            /home/fuji

    2.  `${XDG_CONFIG_HOME}`:

        Environment variable `XDG_CONFIG_HOME` is not set.

        Current value of `XDG_CONFIG_HOME` is `~/.config` (`/home/fuji/.config`).

    3.  Fcitx Settings Directory:

        Current fcitx settings directory is `~/.config/fcitx` (`/home/fuji/.config/fcitx`).

5.  Current user:

    The script is run as fuji (1000).

# Fcitx State:
1.  executable:

    Found fcitx at `/usr/bin/fcitx`.

2.  version:

    Fcitx version: `4.2.9.5`

3.  process:

    Found 2 fcitx processes:

         1277 fcitx
         1293 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` works properly.

5.  DBus interface:

    Using `dbus-send` to check dbus.

    Owner of DBus name `org.fcitx.Fcitx` is `:1.58`.

    PID of DBus name `org.fcitx.Fcitx` owner is `1277`.

# Fcitx Configure UI:
1.  Config Tool Wrapper:

    Found fcitx-configtool at `/usr/bin/fcitx-configtool`.

2.  Config GUI for gtk2:

    **Config GUI for gtk2 not found.**

3.  Config GUI for gtk3:

    Found `fcitx-config-gtk3` at `/usr/bin/fcitx-config-gtk3`.

4.  Config GUI for kde:

    **`kcmshell4` not found.**

# Frontends setup:
## Xim:
1.  `${XMODIFIERS}`:

    **XMODIFIERS is not set**

    **Please set environment variable XMODIFIERS to "@im=fcitx" using the tool your distribution provides or add `export XMODIFIERS=@im=fcitx` to your `~/.xprofile`. See [Input Method Related Environment Variables: XMODIFIERS](http://fcitx-im.org/wiki/Input_method_related_environment_variables#XMODIFIERS).**
    Xim Server Name from Environment variable is fcitx.

2.  XIM_SERVERS on root window:

    Xim server name is the same with that set in the environment variable.

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    **Please set environment variable QT_IM_MODULE to "fcitx" using the tool your distribution provides or add `export QT_IM_MODULE=fcitx` to your `~/.xprofile`. See [Input Method Related Environment Variables: QT_IM_MODULE](http://fcitx-im.org/wiki/Input_method_related_environment_variables#QT_IM_MODULE).**

2.  qt5 - `${QT_IM_MODULE}`:

    **Please set environment variable QT_IM_MODULE to "fcitx" using the tool your distribution provides or add `export QT_IM_MODULE=fcitx` to your `~/.xprofile`. See [Input Method Related Environment Variables: QT_IM_MODULE](http://fcitx-im.org/wiki/Input_method_related_environment_variables#QT_IM_MODULE).**

3.  Qt IM module files:

    **Cannot find fcitx input method module for Qt4.**
    **Cannot find fcitx input method module for Qt5.**

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    **Please set environment variable GTK_IM_MODULE to "fcitx" using the tool your distribution provides or add `export GTK_IM_MODULE=fcitx` to your `~/.xprofile`. See [Input Method Related Environment Variables: GTK_IM_MODULE](http://fcitx-im.org/wiki/Input_method_related_environment_variables#GTK_IM_MODULE).**

2.  `gtk-query-immodules`:

    1.  gtk 2:

        Found `gtk-query-immodules` for gtk `2.24.32` at `/usr/bin/gtk-query-immodules-2.0`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.32

        Found fcitx im modules for gtk `2.24.32`.

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        Found `gtk-query-immodules` for gtk `3.22.28` at `/usr/bin/gtk-query-immodules-3.0`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.22.28

        Found fcitx im modules for gtk `3.22.28`.

            "/usr/lib/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

3.  Gtk IM module cache:

    1.  gtk 2:

        Found immodules cache for gtk `2.24.32` at `/usr/lib/gtk-2.0/2.10.0/immodules.cache`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-2.0 from gtk+-2.24.32

        Found fcitx im modules for gtk `2.24.32`.

            "/usr/lib/gtk-2.0/2.10.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

    2.  gtk 3:

        Found immodules cache for gtk `3.22.28` at `/usr/lib/gtk-3.0/3.0.0/immodules.cache`.
        Version Line:

            # Created by /usr/bin/gtk-query-immodules-3.0 from gtk+-3.22.28

        Found fcitx im modules for gtk `3.22.28`.

            "/usr/lib/gtk-3.0/3.0.0/immodules/im-fcitx.so" 
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*" 

4.  Gtk IM module files:

    1.  gtk 2:

        All found Gtk 2 immodule files exist.

    2.  gtk 3:

        All found Gtk 3 immodule files exist.

# Configuration:
## Fcitx Addons:
1.  Addon Config Dir:

    Found fcitx addon config directory: `/usr/share/fcitx/addon`.

2.  Addon List:

    1.  Found 27 enabled addons:

            fcitx-autoeng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-imselector
            fcitx-ipc
            fcitx-ipcportal
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-mozc
            fcitx-notificationitem
            fcitx-pinyin
            fcitx-pinyin-enhance
            fcitx-punc
            fcitx-quickphrase
            fcitx-remote
            fcitx-spell
            fcitx-table
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  Found 1 disabled addons:

            fcitx-qw

3.  Addon Libraries:

    All libraries for all addons are found.

4.  User Interface:

    Found 2 enabled user interface addons:

        fcitx-classic-ui
        fcitx-kimpanel-ui

## Input Methods:
1.  Found 2 enabled input methods:

        fcitx-keyboard-us
        mozc

2.  Default input methods:

    You have a keyboard input method "fcitx-keyboard-us" correctly added as your default input method.

# Log:
1.  `date`:

        Sat Apr  7 20:49:07 HST 2018

2.  `~/.config/fcitx/log/`:

        total 0

3.  `~/.config/fcitx/log/crash.log`:

    `~/.config/fcitx/log/crash.log` not found.

Try open a GTK3 application(not in terminal or Qt app) which you can type in something. Ctrl+Space to change input method. Does this work?

You have only en_US locale currently, try add ja_JP locale, in some applications it's needed. Open manjaro-settings-manager, in locale settings, add Japanese locale, apply.

Yes, go to Control Center or Settings and enable the Always Show Universal Access, that will show then the icon on the Panel. Once there, disable the Screen Keyboard if enabled ...

https://s17.postimg.org/z9bkk9vkf/image.png

I recommend iBus since it's the easiest to configure and use. Just install ibus-anthy package, then you do as directed in the Initial setup and the Configuration sections of the ArchWiki. And magic happens こんにちは. Ta-dah!

You can install Japanese fonts here. If you have trouble with KDE/Qt apps, install ibus-qt and search for that part in the ArchWiki.

You can try other Japanese input method engines like ibus-kkc and ibus-mozc (AUR). The latter requires a 580MB download and a very long time to build :frowning: though.

thanks, I will give that a try.

1 Like

Does that work for actually turning it off? I was able to turn it off in settings, but it still kept coming back on.

Yes, it should turn off, but then you must be sure that once you are logged out from Gnome Desktop, while in the login screen, to turn off Screen Keyboard there too, because that it seems to be handled by the Shell itself, not the user settings ... Then see the settings i was mentioning previously. Do a reboot and see if that works.

It's possible to use fcitx. See https://archlinux-blogger.blogspot.co.uk/2016/02/ibus-mozcfcitx-mozc.html
You also need to install fcitx-mozc (for example), or fictx-mozc-ut2 in aur.

Since you're using gnome (like me), you'll need to change its settings:
gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/IMModule':<'fcitx'>}"
either with this command on in dconf.

Also, if you use wayland, either you add

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx
export DefaultIMModule=fcitx

in /etc/environmentas the archwiki states, or (like me) in .bashrc or .zshrc.
Then it just works!
がんばって!

Cheers,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by