JBL TUNE500BT bluetooth headset microphone doesn't work and kills the speakers

I have this Bluetooth stereo headset that connects without problems and the speakers work on A2DP by default, but when I try to activate the mic from pulseaudio the speakers stop working, the speakers stop working and the mic never worked on this machine, and when it's not working the test on the gnome control panel shows a mono device as a speaker. If I change from A2DP to HSP/HFP the speakers stop too, I then need to turn off the mic and change back to A2DP on pulseaudio to get the speakers back working.

I thought maybe the system is picking the mic as a speaker and the speaker as a mic but I don't know how to test/fix that

 ltadeu6@manjaro ~ $ inxi -Fx
System:    Host: manjaro Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: Gnome 3.36.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: SAMSUNG product: 300E5M/300E5L v: P08RED serial: <root required> 
           Mobo: SAMSUNG model: NP300E5L-KF2BR v: SGL8947A09-C01-G001-S0001+10.0.14393 
           serial: <root required> UEFI [Legacy]: American Megatrends v: P08RED.021.181123.ZW 
           date: 11/23/2018 
Battery:   ID-1: BAT1 charge: 33.1 Wh condition: 33.1/43.1 Wh (77%) 
           model: SAMSUNG Electronics SR Real Battery status: Full 
CPU:       Topology: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP arch: Skylake rev: 3 
           L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16006 
           Speed: 611 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 609 2: 605 3: 603 4: 622 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Samsung Co driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.org 1.20.8 driver: i915 resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.0.7 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Samsung Co driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Samsung Co driver: r8169 
           v: kernel port: e000 bus ID: 01:00.0 
           IF: enp1s0 state: down mac: 98:83:89:70:20:ad 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Samsung Co 
           driver: ath10k_pci v: kernel port: e000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: f8:28:19:6a:85:7f 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-5:3 
Drives:    Local Storage: total: 894.25 GiB used: 62.12 GiB (6.9%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37960G size: 894.25 GiB 
Partition: ID-1: / size: 492.37 GiB used: 61.68 GiB (12.5%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 37.0 C mobo: 37.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 224 Uptime: 9m Memory: 7.69 GiB used: 1.60 GiB (20.8%) Init: systemd Compilers: 
           gcc: 10.1.0 Shell: fish v: 3.1.2 inxi: 3.0.37 

the systemctl show this

systemctl status bluetooth -l                                   22:40:17
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2020-06-30 22:20:18 -03; 19min ago
       Docs: man:bluetoothd(8)
   Main PID: 661 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 9429)
     Memory: 2.7M
     CGroup: /system.slice/bluetooth.service
             └─661 /usr/lib/bluetooth/bluetoothd

jun 30 22:20:18 manjaro bluetoothd[661]: Starting SDP server
jun 30 22:20:18 manjaro bluetoothd[661]: Bluetooth management interface 1.15 initialized
jun 30 22:20:35 manjaro bluetoothd[661]: Endpoint registered: sender=:1.81 path=/MediaEndpoint/A2DPSink/s>
jun 30 22:20:35 manjaro bluetoothd[661]: Endpoint registered: sender=:1.81 path=/MediaEndpoint/A2DPSource>
jun 30 22:20:51 manjaro bluetoothd[661]: /org/bluez/hci0/dev_B8_F6_53_FD_EC_6F/sep1/fd0: fd(39) ready
jun 30 22:20:51 manjaro bluetoothd[661]: Control: Refusing unexpected connect
jun 30 22:20:52 manjaro bluetoothd[661]: connect error: Connection refused (111)
jun 30 22:34:21 manjaro bluetoothd[661]: Unable to get io data for Headset Voice gateway: getpeername: Tr>
jun 30 22:34:22 manjaro bluetoothd[661]: /org/bluez/hci0/dev_B8_F6_53_FD_EC_6F/sep1/fd1: fd(38) ready
jun 30 22:34:22 manjaro bluetoothd[661]: connect error: Connection refused (111)

I tried using blueberry and the bluetoothctl to conect to the device and it the problem persist, I also tried pavucontrol without sucess.

hey. still no fix for this? I'm encountering the same problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by