Jerky mouse scrolling

Hi,

I use Manjaro-i3, and I had the same problem with Manjaro-KDE, and I have this problem everywhere (when I use chromium, terminal, or any other software).

When I use the mouse (external wireless mouse) the scroll goes up and down quickly and doesn't scroll in the right direction, and I have to click the scroll bar by clicking and drag it down or up to be able to scroll using the mouse. However, when I use the Touchpad, it's perfectly fine to scroll down and up smoothly.

I thought it might be a hardware error, but when I used the same mouse on Fedora it was fine and scrolled smoothly exactly like the touchpad.

Any Ideas how to solve this problem?

Thanks :smile:

2 Likes

From terminal run this:
sudo ln -s /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/10-evdev.conf
reboot and test the scrolling

3 Likes

Thank you very much, the problem is solved :smile:

I'm having the same kind of issue and am going to try your solution as well. I'm just wondering what that line of code does exactly?

@bogdancovaciu well whatever it does it worked. The scrolling is smooth again. or not.... it's back and jittery again.

After you reboot the jittery things comes back?
I see you are on plasma, try to change the Composite to OpenGL 3.1 as rendering backend and the scale method to Smoth (it might be on Accurate by default)

1 Like

Hey I am facing the same issue, I tried the solution given here but it didn't work.
"it’s back and jittery again."

Honestly it seems like it's working here.
Chrome scrolls super smooth now.
Why isn't this standard?

Now trying to figure out how to get the back and forth buttons on my mouse to work. (Button 8 and 9)

Figured out everything now.
imwheelrc was killing the back and forth buttons.

So for fast, smooth and non-jerky scrolling the following things have to be done in basically every linux distribution (still don't know why):

sudo ln -s /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/10-evdev.conf

Install imwheelrc

nano .imwheelrc

".-chrome"
None, Up, Up, 3
None, Down, Down, 3
#google chrome example

Create imwheel.desktop file in .config/autostart (with thumb button fix)

[Desktop Entry]
Terminal=true
Type=Application
Categories=System;
StartupNotify=false
Name=Imwheel
Exec=/usr/bin/imwheel -b 45
Icon=imwheel

Reboot
Now scrolling is fast and smooth and back and forward buttons still work.

I'm having a similar issue to this while using libinput. Is there a way to fix it similar to this fix for evdev?

Forum kindly sponsored by