Jitsi unable to share single application window but can share entire screen

$ inxi --full --verbosity=7 --filter --no-host
System:    Kernel: 5.4.52-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Predator PH315-51 v: V1.26 serial: <filter> 
           Mobo: CFL model: Sienta_CFS v: V1.26 serial: <filter> UEFI: Insyde v: 1.26 
           date: 03/27/2019 
Battery:   ID-1: BAT1 charge: 22.4 Wh condition: 40.4/48.9 Wh (83%) volts: 16.2/15.2 
           model: LG PABAS0241231 type: Li-ion serial: <filter> status: Charging 
Memory:    RAM: total: 7.62 GiB used: 1.71 GiB (22.4%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake 
           rev: A L2 cache: 9216 KiB bogomips: 52815 
           Speed: 4000 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 3999 2: 4000 3: 4001 
           4: 4000 5: 4000 6: 4000 7: 3979 8: 4000 9: 4000 10: 3999 11: 3999 12: 4000 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx 
           avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 
           cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority 
           flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb 
           ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor 
           movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb 
           pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep 
           smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
           tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
           xsaveopt xsaves xtopology xtpr 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Display: x11 server: X.Org 1.20.8 driver: intel compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.3 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI 
           driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0fb9 
           Sound Server: ALSA v: k5.4.52-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
           port: 5000 bus ID: 00:14.3 chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 bus ID: 06:00.1 
           chip ID: 10ec:8168 
           IF: enp6s0f1 state: down mac: <filter> 
           WAN IP: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 142.82 GiB (13.6%) 
           ID-1: /dev/sda vendor: SK Hynix model: HFS128G39TND-N210A size: 119.24 GiB 
           speed: 6.0 Gb/s serial: <filter> rev: 1P10 scheme: GPT 
           ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
           speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A3J0 scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 86.76 GiB used: 21.64 GiB (24.9%) fs: ext4 dev: /dev/sda7 
           label: N/A uuid: f862f40b-3214-4d99-a3ec-37c5006163a4 
           ID-2: /boot/efi size: 499.0 MiB used: 308 KiB (0.1%) fs: vfat dev: /dev/sda6 
           label: N/A uuid: 3A04-5656 
           ID-3: /mnt/c94d185c-f75f-453b-bc8b-aff8bc598341 size: 915.89 GiB 
           used: 121.19 GiB (13.2%) fs: ext4 dev: /dev/sdb1 label: N/A 
           uuid: c94d185c-f75f-453b-bc8b-aff8bc598341 
           ID-4: /var/lib/snapd/snap/core18/1880 raw size: 55.0 MiB size: <root required> 
           used: <root required> fs: squashfs dev: /dev/loop0 label: N/A uuid: N/A 
           ID-5: /var/lib/snapd/snap/snapd/8542 raw size: 29.9 MiB size: <root required> 
           used: <root required> fs: squashfs dev: /dev/loop1 label: N/A uuid: N/A 
Unmounted: ID-1: /dev/sda1 size: 100.0 MiB fs: vfat label: N/A uuid: 0C8D-CF7C 
           ID-2: /dev/sda2 size: 16.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-3: /dev/sda3 size: 29.38 GiB fs: ntfs label: N/A uuid: 4E169E32169E1AD3 
           ID-4: /dev/sda4 size: 513.0 MiB fs: ntfs label: N/A uuid: 389C237F9C2336B2 
           ID-5: /dev/sda5 size: 100.0 MiB fs: <root required> label: N/A uuid: N/A 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s 
           chip ID: 1d6b:0002 
           Device-1: 1-5:2 info: Quanta HD Webcam type: Video driver: uvcvideo interfaces: 2 
           rev: 2.0 speed: 480 Mb/s chip ID: 0408:a060 serial: <filter> 
           Device-2: 1-14:3 info: Intel type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 
           speed: 12 Mb/s chip ID: 8087:0aaa 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
           chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 61.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 295 Uptime: 2h 09m Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.18 running in: konsole inxi: 3.0.37

I'm using jitsi flatpak and it is unable to list any open application window to share. It can share entire screen tho.
Same thing happens when I use browser, firefox doesnt show allow button to share a window but can share entire screen same thing with chromium and brave browser. can anyone halp?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by