Kann updates nicht fertig machen

Hey,

hab nen Problem mit den Paketen aus dem AUR und normalen Repo egal welches ich kann nichts updaten.
jedes mal wenn ich ein update von irgendeinem Paket machen möchte kommt es immer zu diesen beiden Fehlern:

resolving dependencies...
looking for conflicting packages...

Packages (13) adobe-source-code-pro-fonts-2.030ro+1.050it-3  adobe-source-han-sans-cn-fonts-1.004-2  adobe-source-han-sans-jp-fonts-1.004-2  adobe-source-han-sans-kr-fonts-1.004-2  adobe-source-han-sans-otc-fonts-1.004-2
              adobe-source-han-sans-tw-fonts-1.004-2  adobe-source-han-serif-cn-fonts-1.001-1  adobe-source-han-serif-jp-fonts-1.001-1  adobe-source-han-serif-kr-fonts-1.001-1  adobe-source-han-serif-otc-fonts-1.001-1
              adobe-source-han-serif-tw-fonts-1.001-1  adobe-source-sans-pro-fonts-2.020ro+1.075it-2  adobe-source-serif-pro-fonts-2.000-1

Total Download Size:   410.72 MiB
Total Installed Size:  646.24 MiB

:: Proceed with installation? [Y/n] j

Drücken Sie eine beliebige Taste um fortzufahren...

und AUR:

vulkan-caps-viewer 1.4-1  (2017-05-29 13:22)                                                                                                                                                                                                 
( Unsupported package: Potentially dangerous ! )                                                                                                                                                                                             
==> Edit PKGBUILD ? [Y/n] ("A" to abort)                                                                                                                                                                                                     
==> ------------------------------------                                                                                                                                                                                                     
==> j                                                                                                                                                                                                                                        
                                                                                                                                                                                                                                         
Please add $VISUAL to your environment variables                                                                                                                                                                                             
for example:                                                                                                                                                                                                                                 
export VISUAL="vim" (in ~/.bashrc)                                                                                                                                                                                                           
(replace vim with your favorite editor)                                                                                                                                                                                                      
                                                                                                                                                                                                                                         
==> Edit PKGBUILD with:                                                                                                                                                                                                                      
                                                                                                                                                                                                                                         
/usr/lib/yaourt/util.sh: line 227: PKGBUILD: command not found                                                                                                                                                                               
==> vulkan-caps-viewer dependencies:                                                                                                                                                                                                         
 - vulkan-icd-loader (already installed)                                                                                                                                                                                                     
 - qt5-base (already installed)                                                                                                                                                                                                              
 - qt5-x11extras (already installed)                                                                                                                                                                                                         
                                                                                                                                                                                                                                         
                                                                                                                                                                                                                                         
==> Continue building vulkan-caps-viewer ? [Y/n]
==> --------------------------------------------
==> j

==> Building and installing package
==> Making package: vulkan-caps-viewer 1.4-1 (Thu Jun 22 14:00:48 CEST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found vulkan-caps-viewer.desktop
  -> Found android_icon_256.png
  -> Downloading vulkancapsviewer_1_4_linux64.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                             Dload  Upload   Total   Spent    Left  Speed
100  164k  100  164k    0     0   233k      0 --:--:-- --:--:-- --:--:--  233k
==> Validating source files with sha1sums...
vulkan-caps-viewer.desktop ... Passed
android_icon_256.png ... Passed
==> Validating source_x86_64 files with sha1sums...
vulkancapsviewer_1_4_linux64.tar.gz ... Passed
==> Extracting sources...
  -> Extracting vulkancapsviewer_1_4_linux64.tar.gz with bsdtar
bsdtar: Failed to set default locale
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issue...
==> Creating package "vulkan-caps-viewer"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
bsdtar: Failed to set default locale
  -> Compressing package...
bsdtar: Failed to set default locale
==> Leaving fakeroot environment.
==> Finished making: vulkan-caps-viewer 1.4-1 (Thu Jun 22 14:00:50 CEST 2017)
==> Cleaning up...
==> Exporting vulkan-caps-viewer to /var/cache/pacman/pkg/ directory
[sudo] password for lucy: 
'/tmp/yaourt-tmp-lucy/PKGDEST.q51/vulkan-caps-viewer-1.4-1-x86_64.pkg.tar.xz' -> '/var/cache/pacman/pkg/vulkan-caps-viewer-1.4-1-x86_64.pkg.tar.xz'

==> Continue installing vulkan-caps-viewer ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==> j

loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) vulkan-caps-viewer-1.4-1

Total Installed Size:  0.39 MiB
Net Upgrade Size:      0.03 MiB

:: Proceed with installation? [Y/n] j
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-lucy

Drücken Sie eine beliebige Taste um fortzufahren...

Hallo LucyDemoon,

versuch mal mit "y", oder wenn du ein englisches Tastaturlayout eingestellt haben solltest, mit "z" zu quittieren.

Grüße
Josef

tastatur layout ist auf deutsch sowie gesamte sprache alles auf DE

[LucyDemoon] ~ $: locale
LANG=de_AT.UTF-8
LC_CTYPE="de_AT.UTF-8"
LC_NUMERIC=de_AT.UTF-8
LC_TIME=de_AT.UTF-8
LC_COLLATE="de_AT.UTF-8"
LC_MONETARY=de_AT.UTF-8
LC_MESSAGES="de_AT.UTF-8"
LC_PAPER=de_AT.UTF-8
LC_NAME=de_AT.UTF-8
LC_ADDRESS=de_AT.UTF-8
LC_TELEPHONE=de_AT.UTF-8
LC_MEASUREMENT=de_AT.UTF-8
LC_IDENTIFICATION=de_AT.UTF-8
LC_ALL=
[LucyDemoon] ~ $: localectl
   System Locale: LANG=de_AT.UTF-8
   VC Keymap: de-latin1-nodeadkeys
  X11 Layout: de
   X11 Model: pc105
 X11 Variant: nodeadkeys
[LucyDemoon] ~ $: 

Seit dem letzten update funktioniert irgendwie nurnoch die hälfte,
Steam systemtray geht nicht mehr, Updates da spinnt die sprache herum, Octopi Anzeigefehler mit AUR, KDE themes machen auch einige probleme..

Update mit Y statt J funktioniert ka warum sich dass geändert hat

Hallo LucyDemoon,

schau mal in der /etc/vkonsole.conf, dort sollte in der ersten Zeile

KEYMAP=de-latin1-nodeadkeys

stehen.

Zu den anderen Problemen kann ich nichts sagen, weil ich Steam und KDE nicht verwende.

Auf de.manjaro.org sind einige Treats zu Steam. Vielleicht kann dir dort wer helfen.

Grüße
Josef

Es geht hier nicht um die Tastaturbelegung. Die Systemsprache ist bei dir auf Englisch gesetzt, deshalb wird auch y/n abgefragt. Auch alle anderen Terminalausgaben sind ja in Englisch! :wink:

resolving dependencies...
looking for conflicting packages...
...

@oberon dann erklär mir mal wo da bitte English als Systemsprache steht? zudem ist KDE komplett in Deutsch soweit es halt übersetzt ist. Außer ich hab was übersehen was ich mir nicht vorstellen kann. Und warum ändert ein Update die Sprache?

Was steht in
cat /etc/locale.conf ?

Fast das selbe wie bei locale

[LucyDemoon] ~ $: cat /etc/locale.conf
LC_IDENTIFICATION=de_AT.UTF-8
LANG=de_AT.UTF-8
LC_MEASUREMENT=de_AT.UTF-8
LC_TELEPHONE=de_AT.UTF-8
LC_PAPER=de_AT.UTF-8
LC_TIME=de_AT.UTF-8
LC_ADDRESS=de_AT.UTF-8
LC_NAME=de_AT.UTF-8                                                                                                                                                                                                                                
LC_NUMERIC=de_AT.UTF-8
LC_MONETARY=de_AT.UTF-8

Plasma benutzt wohl außerdem auch noch eine ~/.config/plasma-localerc ... Passt die auch?

plasma-localerc:

[Formats]
LANG=de_AT.UTF-8

[Translations]
LANGUAGE=de

plasma-locale-settings.sh:

# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=de_AT.UTF-8
export LANGUAGE=de

wieder was dazu gelernt das wusste ich zb noch nicht das Plasma 5 extra Dateien dafür hat aber die sind auch alle auf Deutsch.

Fällt mir jetzt dann allerdings auch erst mal nichts mehr ein. Hast du kürzlich deinen Computer mal neugestartet?

ja mehrmals nach dem update, wenn ich sehe das Kernel mit updatet mach ich immer ein Neustart,
Das aktuelle Update sowie das vorherige, die 2 sind komisch, haben bei mir einige Fehler ins System geschmissen paar konnte ich schon beheben aber bei dem hänge ich fest, um die anderen 2 Fehler kümmere ich mich nach dem hier.

Wirklich seltsam ist das:

Das eine Englisch und dann Deutsch...

Ist was wir da oben sehen auch pacman oder beides yaourt?
Für den Fall dass in den Sprachdateien was kaputt wäre könntest du noch versuchen yaourt neu zu installieren, gegf auch pacman...

Beides pacman sowie yaourt in der reihen folge oben.

hm kann man pacman neu installieren mit pacman?

Ja kann man. :wink: :slight_smile:
Aber ich kann mir eigentlich nicht wirklich vorstellen dass es daran liegen würde...

Ansonsten sehe ich grade dass bei einem Update von glibc, was kürzlich der Fall war, automatisch locale-gen ausgeführt wird... Auf die Weise könnte es also da zu irgendwelchen Änderungen oder auch ev. Fehlern kommen.
Vielleicht möchtest du einfach nochmal sudo locale-gen ausführen nachdem du sichergestellt hast dass die Zeile de_AT.UTF-8 in /etc/locale.gen aktiviert ist?

1 Like

hm da ist english ganz oben aktiv und weiter unten de_AT ich deaktiviere mal das en und probier es dann.

Ok habe aus der locale.gen Datei 2 Einträge mit en_US.UTF-8 auskommentiert und die de_At.... aktiv gelassen
dann sudo locale-gen ausgeführt dann neu gestartet das funktionierte nicht auf Anhieb also nochmal locale-gen und ab-und angemeldet und jetzt passt wieder alles Danke @oberon

wenn ich mit den anderen 2 Fehlern nicht weiter komme gibt es nen neuen Thread dazu ^^

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by