KDE 18.03 installs, then boot to grub rescue, every time, on Dell inspiron 1525 (Resolved by installing 18.04)

As above. Booted from live-usb, liked what i saw, installed with encryption, rebooted , got grub rescue prompt. Tried installing without encryption in case it was the culprit (despite needing it, since it's a mobile device) and the exact same result. More than slightly annoying. Been wanting to try Manjaro, but this is not encouraging. Zero issues reported during install, and this laptop (Dell Inspiron 1525) has installed and booted multiple ubuntu variants (Kubuntu, Mint, etc), PCLinuxOS, Fedora, etc, with no real issue, but Manjaro seems to be struggling with this. I'm baffled as to why.

Have tried using suggestions here, but it fails at first step of "
grub> search.file /etc/manjaro-release root", insisting "error: no such device /etc/manjaro-release"

I'm really wanting to try this out on my laptop, but this is making it hard, when it won't do the most basic of tasks (boot). It's sitting behind me after trying yet AGAIN, same error, and i'm on the verge of giving up, but figured asking couldn't hurt. None of the suggestions in the link seem to apply to this, and it won't do even the first damn step right. And yes, I AM double-checking what i type, exactly. Multiple times. Hence the frustration. It works great live, just refuses to boot. Has a 500GB drive all to itself, so NO dual-boot involved. Suggestions?

Mapping for encypted partition is different.
Search for issues on encrypted systems.
Try 18.04. I think it is resolved there.


18.0.3 has encryption issues

try this one as @gohlip suggested

1 Like

Thanks. Will download shortly and try out. Was very much hoping I could get this to work, I prefer to keep my laptops encrypted, in case of loss or theft.

i would too if i actually ever traveled with this laptop but i dont and so i avoid all the potential issues that come along with encryption. so come of the newer SSD's come with decent hardware encryption, though not many.

I can now confirm that 18.04 does work with encryption, and boots fine. Now i can happily try out Manjaro on a live system, and see if it all adds up to what i kept reading about. Promises to be interesting at least. Cheers


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by