KDE advanced mouse settings not visible

Hello,

my mouse, an Logitech MX Anywhere 2, has a way to fast mouse double click or phantom clicks.
I want to slow the double click, but when i want to set it in:
Settings -> System Settings -> Mouse, but there is no option for that.
After some searches i added a custom config:

ls -1 /etc/X11/xorg.conf.d
00-keyboard.conf
10-mouse.conf
30-touchpad.conf
90-mhwd.conf

The 10-mouse.conf hast the following content:

Section "InputClass"
Identifier "evdev-mouse"
MatchIsPointer "yes"
Driver "evdev"
EndSection

And i think its loaded:
grep -e "Using input driver " /var/log/Xorg.0.log
[ 14.782] (II) Using input driver 'libinput' for 'Power Button'
[ 14.835] (II) Using input driver 'libinput' for 'Video Bus'
[ 14.912] (II) Using input driver 'libinput' for 'Power Button'
[ 14.962] (II) Using input driver 'evdev' for 'Logitech MX Anywhere 2'
[ 14.966] (II) Using input driver 'evdev' for 'Logitech MX Anywhere 2'
[ 15.028] (II) Using input driver 'libinput' for 'HP Wide Vision HD Camera: HP Wi'
[ 15.101] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[ 15.139] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[ 15.208] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[ 15.271] (II) Using input driver 'libinput' for 'HP Wireless hotkeys'
[ 15.324] (II) Using input driver 'libinput' for 'HP WMI hotkeys'
[ 15.441] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[ 15.516] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[ 15.628] (II) Using input driver 'libinput' for 'HP Wide Vision HD Camera: HP Wi'

But no advanced settings for me :frowning:

So any further help is much appreciated :slight_smile:

From where did you get that or is just something you invented on the spot ? :slight_smile:
Take a look at the discussion here

2 Likes

Mouse-advanced
I followed this guide last month - great stuff bogdancovaciu <3

1 Like

Thanks for the answers :slightly_smiling_face:
No, i did not invented that on the sport, it was found here:
https://forum.kde.org/viewtopic.php?t=153755

I added the files and content what was suggested, at least i thin so :sweat:
/etc/X11/xorg.conf.d/11-evdev.conf
Section "InputClass"
Identifier "evdev pointer catchall"
MatchIsPointer "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

It its loaded i think:
grep -e "Using input driver " /var/log/Xorg.0.log
[ 14.819] (II) Using input driver 'libinput' for 'Power Button'
[ 14.871] (II) Using input driver 'libinput' for 'Video Bus'
[ 14.941] (II) Using input driver 'libinput' for 'Power Button'
[ 14.994] (II) Using input driver 'evdev' for 'Logitech USB-PS/2 Optical Mouse'
[ 14.998] (II) Using input driver 'libinput' for 'HP Wide Vision HD Camera: HP Wi'
[ 15.066] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[ 15.117] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[ 15.185] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[ 15.248] (II) Using input driver 'libinput' for 'HP WMI hotkeys'
[ 15.288] (II) Using input driver 'libinput' for 'HP Wireless hotkeys'

But still no advanced tab in mouse settings.

but you did removed your files and reboot the system?

Yes, i removed my file and i rebooted several times already.
I tried the same on my virtualbox vm, where it works.
The difference between both installations is:
VM:
Full Manjaro KDE installation
ls /etc/X11/xorg.conf.d/
00-keyboard.conf 11-evdev.conf 30-touchpad.conf

The Notebook:
Minimal Manjaro KDE installation
ls /etc/X11/xorg.conf.d/
00-keyboard.conf 11-evdev.conf 30-touchpad.conf 90-mhwd.conf

Ok, but now pay attention to this:

1 Like

I have disabled the touchpad over a keybind and or the kde setting and or removing the 30-touchpad.conf.
I think there was on a leftover somewhere that I'm missing;
[ 14.313] (II) Using input driver 'libinput' for 'Power Button'
[ 14.366] (II) Using input driver 'libinput' for 'Video Bus'
[ 14.433] (II) Using input driver 'libinput' for 'Power Button'
[ 14.481] (II) Using input driver 'evdev' for 'Logitech USB-PS/2 Optical Mouse'
[ 14.486] (II) Using input driver 'evdev' for 'Logitech MX Anywhere 2'
[ 14.492] (II) Using input driver 'libinput' for 'HP Wide Vision HD Camera: HP Wi'
[ 14.556] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[ 14.593] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[ 14.668] (II) Using input driver 'libinput' for 'HP Wireless hotkeys'
[ 14.738] (II) Using input driver 'libinput' for 'HP WMI hotkeys'

That was extreme. If you want to keep the touchpad functional, you will need that file.

better rename it to keepa copy - in terminal mv 30-touchpad.conf 30-touchpad.conf.bak

But there might be copies in an old timeshift config too.

Is up to OP what does on their system. I'm here only to give some humble advice that can be ignored also, no problem. :slight_smile:

Thanks for the input :slight_smile: i was a bit unprecise at the point, i removed that file from that folder, not from my system, just a a mv to my Desktop.

I guess you dragged it from Dolphin, right?

You know if you click it (once) and hit F2, then you can type (start with arrow left or right - end of line, if you don't want to destroy the filename) BAK. Same place new name.

I did a mv over the terminal, but thanks for your tip :)!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by