KDE Device Notifier and Smartphone - Do nothing / charge only?

I just switched from XFCE+Openbox to KDE Plasma.

When I connect my phone (Asus Zenfone 5Z/Android 10) to my PC via USB, the KDE Device Notifier (running in the system tray) keeps popping up and disappearing. This happens too quickly to even see what the options are. At the same time, my phone continually switches modes between charging and running off battery power.

Most of the time, I just want to use my PC's USB port to charge the phone. Sometimes I would like to transfer files between the phone and PC. But since the typical use-case is just charging, I'd like KDE to do nothing. I can't seem to figure out how to prevent the annoying/useless behavior described above, and how to tell the system to just let the phone charge.


Bump. Anyone?

This worked for me: Mobile phone don't charge when connect it to usb port? (SOLVED) NEW BEST SOLUTION

Where it says:

You must edit (as root) the file “/etc/default/tlp” and modify:

So, instead of modifying USB_AUTOSUSPEND (global), it is better to modify the line about USB_BLACKLIST_PHONE

where is said:
must said:

save and reboot …

Important: where it says "edit the file /etc/default/tlp", it didn't exist in my system, so I found this other topic USB port will not send power to mobile phone where somebody kindly suggests editing the file "/etc/tlp.conf" instead, which was perfectly right in my case.

So, first difficulty I find in using Manjaro, and I solved it in a minute thanks to this community. I'm really happy with having switched from Ubuntu and Ubuntu-based distributions, especially happy about the management of system resources (CPU heat, battery life...). Manjaro rocks!

1 Like

Thank you. This was what I was looking for.
Although reboot is not necessary. Just
$ sudo tlp start

$ man tlp
       start  Initialize tlp and apply power saving settings according to the actual power source. Also use to apply a changed configuration.

Forum kindly sponsored by