[KDE Edition] Installer USB crashes when it reaches desktop

Hello,
So, I've been trying to install Manjaro KDE but I am having issues booting into it. Everything seems to load okay during plymouth bootup, but as soon as it starts to load the desktop session it crashes my PC (turns it off).

I have tried re-making the installer both using the DD command and Etcher.

If you guys can provide any insight, I would be very grateful :slight_smile:
Thank you

edit: posted the wrong inxi info :smile:

Have you manually added "splash" to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub to enable

???

I dunno :confused: I assumed the installer uses Plymouth by default, I haven't made any changes to the installer at all. I've installed manjaro KDE before, but I removed it to try another distro out for a while.

Here is the link with information to plymouth:

https://wiki.manjaro.org/index.php?title=Plymouth

I don't believe that plymouth has been added to the standard-iso.

So let's understand your issue more in detail:

  1. From where did you get the iso and was it the BIOS or EFI version?
  2. Have you checked the file checksum?
  3. Have you a dual boot system (e.g. with WIN or another OS?
  4. Are you installing in BIOS or EFI mode?
  5. Occurs the problem during start of LIVE USB or system boot?
  6. Do you have Nvidia graphics?
  7. Anything else special we should know?

Here's the answers:

  1. I got the ISO from the official manjaro website (It was the EFI version)
  2. I have checked the checksum (SHA1)
  3. I am not dual booting (I am replacing the distro I have installed now)
  4. I am installing in EFI mode (I have not tried to install in legacy mode)
  5. The issue occurs during start of LIVE USB
  6. I do not have NVIDIA graphics, just Intel onboard
  7. The system does not always crash at the same point during boot, sometimes it's during the desktop splash screen, and other times it's before that.

Don't know if it's useful, but I'm currently using Deepin EFI.

again, thanks for helping :slight_smile:

I guess your USB stick has normal size and speed? Do you have other sticks to compare? Also please provide output of lsblk -f, if possible.

The usb stick is only USB2 and I don't have access to another one (it's worked perfectly for other distributions). Here is the out put of lsblk -f:

NAME   FSTYPE  LABEL    UUID                                 MOUNTPOINT
sda                                                          
├─sda1 vfat             4502-E8CC                            /boot/efi
├─sda2 ext4             0abec894-5df7-4f00-ba73-0a2eea257905 
├─sda3 swap             5f45033a-2906-4ab2-bdde-a239ee22d465 [SWAP]
└─sda4 ext4             fe1b2214-147a-4e31-9d36-acf2dffd7dfe /
sdb    iso9660 M1804    2019-03-12-09-50-33-00               
├─sdb1 iso9660 M1804    2019-03-12-09-50-33-00               
└─sdb2 vfat    MISO_EFI F464-EFAB                            

sda2 was used for another distro, I just deleted the partition

Right, I've managed to boot into it now, waited till the splash screen came up and switched to another tty session and logged in then used startx. Seems okay now.

I guess sdb is the stick you want to use. As far as I know you have to put the iso on the drive and not in a partition. This won't work.

(Furthermore I also assume you downlaoded the 64bit version.)

Have you changed something in the procedure?

Yeah, used the 64bit version. I've booted up now (dunno why I had to switch session) and I didn't make the installer onto a partition. I used /dev/sdb when using DD.

OK, congrats if this worked, I would have bet two partitions is a no-go for a boot-stick.

1 Like

I used the same USB I created (I didn't make a new one). All I did this time was when the desktop splash screen came up, I pressed Ctrl+alt+F2 and logged in, then I typed startx.

1 Like

OK, good.

The one thing I would have made differently in my installation is preparting the partitions upfront with gparted as Calamares messed up my partitions a bit, but this was a special case as I installed it as a dual boot in an extended partition and I had hidden primary partitions which are now logicals in the extended partition.

2 Likes

Thank you very much for your help. Not only one of my favourite distributions, but also the best community.

2 Likes

Yes, isn't it? Enjoy and see you here whenever you have a question. :hugs:

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by