KDE fonts settings got ignored by GTK programs

Well, at least that is right direction, since it's multi-lingual font including CJK...

I think we should try some our older isos to see correct behavior, i'll try to find one...Probably something radical have changed lately

1 Like

I just loaded up an old Manjaro Mate VM that I hadn't use in a long time. It had Firefox 65 installed which places it's last update at ~February 2019. Same behavior exists there.

1 Like

Well...I could point out to manjaro-deepin-18.0.2-stable-x86_64.iso but that's way too old for test? :sweat_smile:

I'm trying older KDE isos now

I am downloading kubuntu 16.04 from April of 2016. We can check there.

2 Likes

That maybe too old, in there you would have to use KDE settings of GTK fonts (it was controlled separatly from qt fonts before)

That is how it is in several of the things I have tried. That change was fairly recent. 5.18 I think

Even when I made the change in both the gtk and qt fonts they still weren't reflected.

1 Like

OK, I have now journeyed all the way back to Firefox 48 and KDE 5.5. :scream:

I can't find this working that way anywhere. I am wondering if the cause of your issue isn't with something else....

2 Likes

I've tested Manjaro KDE isos back to 18.0.1...No luck so far too :woozy_face:

Dammit - this is complete voodoo magic, i can swear i have seen today with my own eyes it working correctly on KDE dev! And now i can't repeat it...wtf

But even then - it's still a big problem that needs to be solved and it's not only Firefox, i'll try to explain why a little later in case it's not obvious...

But first will try few more .isos

1 Like

Got it! Found it!

Just live / install, don't update anything.

Firefox 64.0


On start, Noto Sans / Noto Mono:
1

Close Firefox, change fonts to DejaVu Sans / DejaVu Sans Mono:
2

See? It correctly inherits as it should always do! :upside_down_face:


Why it's huge problem if it doesn't work this way?

Some of us are web-designers, including myself, and if it happens that we need to do some bilingual work with some common system fonts, well... :laughing:

Here's example of bilingual test page https://twitter.com/goode108/status/1262396082270724098 (look at this phrase on top, which is written in russian / english for example, which my friend have sent for common example of problem)

Here's very wrong current KDE rendering with defaults and not inherited Noto Sans:
5
Part of phrase renders as Bitstream Vera Sans, and part as Nimbus Roman (which looks totally nuts)

Here's correct rendering on Deepin with Noto Sans / Noto Mono:
3

Here's correct rendering on Deepin with DejaVu Sans / DejaVu Sans Mono:
4


Sublime text 3 rendering problems

Check for example that test file:

skynet.sh

#!/bin/bash

echo "+--------------------------------------------------------+"
echo "+                 133 COMPLETE INSTALLER                 +"
echo "+--------------------------------------------------------+"
echo "+                                                        +"
echo "+    ██████  ██ ▄█▀▓██   ██▓ ███▄    █ ▓█████▄▄▄█████▓   +"
echo "+  ▒██    ▒  ██▄█▒  ▒██  ██▒ ██ ▀█   █ ▓█   ▀▓  ██▒ ▓▒   +"
echo "+  ░ ▓██▄   ▓███▄░   ▒██ ██░▓██  ▀█ ██▒▒███  ▒ ▓██░ ▒░   +"
echo "+    ▒   ██▒▓██ █▄   ░ ▐██▓░▓██▒  ▐▌██▒▒▓█  ▄░ ▓██▓ ░    +"
echo "+  ▒██████▒▒▒██▒ █▄  ░ ██▒▓░▒██░   ▓██░░▒████▒ ▒██▒ ░    +"
echo "+  ▒ ▒▓▒ ▒ ░▒ ▒▒ ▓▒   ██▒▒▒ ░ ▒░   ▒ ▒ ░░ ▒░ ░ ▒ ░░      +"
echo "+  ░ ░▒  ░ ░░ ░▒ ▒░ ▓██ ░▒░ ░ ░░   ░ ▒░ ░ ░  ░   ░       +"
echo "+  ░  ░  ░  ░ ░░ ░  ▒ ▒ ░░     ░   ░ ░    ░    ░         +"
echo "+        ░  ░  ░    ░ ░              ░    ░  ░           +"
echo "+                   ░ ░                                  +"
echo "+                                                        +"
echo "+--------------------------------------------------------+"
echo

Here's how it should look on Deepin with Noto by default (no settings changed, so it's inherited from System):
6

Here's how it looks like by default on KDE (which is also Bitstream Vera Sans Mono btw):
Screenshot_20200520_213220

But more importantly, if you manually set Noto Mono in current KDE Sublime Text 3 settings:
Screenshot_20200520_213357

Which is exactly the font which is set on Deepin 2 pics above...Very different render i'd say, but that particular difference maybe is connected to something like Kerning problem @stephane mentioned above or font itself have changed radically through time...

P.S. @dalto please say that you see same on Deepin .iso too and this is not simulation i'm trapped inside alone :rofl:

1 Like

Latest XFCE Stable also affected by this issue... :woozy_face:

So all Official editions

Literally every distro I tested was impacted by the issue. Arch, Solus, pclinuxos, nixos and kubuntu(new and old). The only thing we have found that isn't impacted is an old deepin ISO.

Yeah...But at the same time this is obviously only correct behavior, so how to find out the cause?

Maybe diff /etc/fonts ?

There are two possible solutions to this problem:

  1. Correctly change the fonts based on system settings, like on that old Deepin image.
  2. Have good default values.

While the first option is ideal, I think the second one is good enough.

Well, problem is - you can't change default values for all GTK programs it seems (at least on KDE), as they doesn't seem to be inherited correctly...So on program by program basis it's impossible task

So we should seek for real solution which is 1 with sane defaults like Noto.

For as long as I've been using KDE (which is probably more than 6 years now), I've had problems with GTK applications and many of them I had to configure manually. It sucks, but one gets used to it.

Yes, Noto should be the default in pretty much everything. If it is not good enough, it should be up to the user to change it.

Not only GTK though :face_with_raised_eyebrow:, check out squlitebrowser in settings looks like it picks up Bitstream Vera Sans too, although it's qt.

So...Anyone figured it out?

https://bugs.kde.org/show_bug.cgi?id=423995

Probably connected

So....Apparently, while reading stuff on last update, i became aware of that.

Guess which values Firefox and some programs like squlitebrowser use?

Right, those ones:

fc-match Sans
fc-match Seriff
fc-match Mono

@dalto
I guess then questions are:

  • Ain't it better to set defaults as Noto / Noto CJK, to cover all possible locales, since we mainly use them as system fonts anyway (that was the case with older Manjaro Deepin :upside_down_face:)?

  • Not sure if that's Manjaro or KDE duty (probably latter), but maybe it's a good idea to make fontconfig's defaults Sans / Seriff / Mono to follow system settings?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by