KDE, Network Manager, and L2TP VPN

I've had this working before but am on a different machine now and cannot seem to figure out how to get this working.

Short version: I need to be able to configure and test L2TP vpn connections from my manjaro kde desktop and laptop. I can do this in windows all day long but it would be nice to not have to remote into another machine to test my configurations on firewalls :slight_smile: I suppose I could also install a VM for testing, but at this point, i want to get this figured out natively.

I have added the l2tp network manager package, and I have the option to add that type of vpn in network manager. The type we are using have credentials from active directory, so adding that part is just as easy as knowing the user account info. I have the preshared key for eveyr VPN i set up, so that's no issue.

When i try to activate the connection, i get an error message something to the effect of "starting the service providing the vpn connection failed."

Anyone able to assist me in finding simple instructions for setting up L2TP vpn connections in network manager? I do recall not having to resort to cli to do this before, at least not for anything other than installing a package or two, i must be missing something quite simple but obscure....

Thanks

Do you remember now? :slight_smile:

Thanks :smile: guess i still have the same issue of not searching for the right thing.

I checked the journal after reading some other articles and found this:

Perhaps this will magically work as it used to after i replace Openswan. The Arch Wiki says to install that but i guess it may be a bit dated

Just documenting the process so if I come across this again, if i ever find the answer, i'll have something to refer back to...

Right now, it seems my biggest issue is this error: "starting the service providing the vpn connection failed."

A little deeper digging revealed this:

So now I am trying to figure out what xl2tpd will not start.... I think perhaps if that service will start, i'll be in business...

Dude this isn't Facebook. Quit posting pics on technical support threads.

Only post text outputs with proper formatting for proper readability and text can also be pasted into search engines.

Please format any terminal output with three ``` backticks before and after, as shown in this picture:

Please read this thread on how to post required information properly:

UPDATE: I got it to work through trial and error after looking at logs, etc.

I ended up removing all the VPN stuff and starting from scratch. Now, in my case, this was for an L2TP VPN from a UniFi USG router, so some of the security config steps may be different for you. Here's what i did, so i can refer to this again if needed.

  1. Install networkmanager-l2tp from AUR using your prefered method
  2. Install strongswan
  3. Configure the VPN connection in NetworkManager

specifics for myself: for this type of VPN, go to IPsec Settings in the connection manager. Check Enable IPsec tunnel to L2TP host and fill in the preshared key. Uncheck "Enforce UDP encapsulation." Under PPP Settings, only allow MSCHAPv2 authentication methods and leave the rest at its defaults. Be sure to fill in the search domain in the IPv4 section

I could NOT get it to work with libreswan, for whatever reason.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by