KDE on Dell XPS 9570 - stuck trying to boot from USB

Hi there! I recently received my new XPS 9570 and decided to try out Manjaro (used Ubuntu 16.04 before). However, I have run into trouble with the installation.

The steps I took:
I used etcher to create burn the manjaro-kde-17.1.11-stable-x86_64 onto a USB (I checked the ISO file with sha1).

Went to BIOS and set UEFI mode, disabled secure boot and set AHCI instead of RAID as suggested in the guide for XPS 9560: https://gist.github.com/MeirBon/c99ae4e9e40f7e542361f646e4f637f5
Then, I got into the boot menu for Manjaro, set drivers to nonfree and went into kernel parameters by pressing 'e' and tried first the configurations from the aforementioned guide and afterwards various combinations from this thread: forum.manjaro .org/t/dell-xps-15-9570-help/51283 (wont let me post more than 2 links when i submit post)

For example, I tried setting acpi_rev_override=1 nouveau.modeset=0 and also just nouveau.modeset=0 which seemed to be the takeaway from the thread above. However, I always seem to get stuck at 'Started TLP system startup/shutdown.'! The following screenshot is after I had all the parameters mentioned in the guide on github together with the parameters acpi_rev_override=1 nouveau.modeset=0


I am running out of ideas, and I would be very grateful if anyone could guide me in the right direction!

Have you checked the other forum threads yet? https://archived.forum.manjaro.org/search?q=9570

These lead through to:

which might work.

I saw that thread, and I am not sure what the takeaway is for me. How do I:

  • Create file /etc/modprobe.d/blacklist.conf and write content blacklist nouveau when I cannot boot?

I suspect you'll be able to switch to a text console with CTRL-ALT-F2, then log in with your normal username and password.

I am unsure when I can do this. I tried both in the grub menu (no results) and also while trying to boot normally (both before and after it freezes), but without any effect. Suggestions? (Thank you for trying to help me btw!)

Does it boot from runlevel 3? Here's a guide.

1 Like

Yes, that works. Thank you. I just spent a couple of hours again now trying to follow the advice frm the thread Jonathon suggested, but my newbieness is a big issue!


I first got the output above, and figured it is probably because I am not connected to wifi! But connecting to WiFi is causing me endless troubles. I do not know why. I am trying to connect to an unencrypted network, but even though I get no errors when typing iw dev connect , it just does not connect. I don't know if this error report tells anything


That's a bold assumption!!.. totally unjustified in my opinion..
Try startx and watch for errors.
Please read this before you continue

You can post errors here, even from TTY (if network is working) avoiding images that make things difficult.

after iw dev xxx connect, what does ip a show?

Whoops! Well, at least I learned a little from it..

In my frustration yesterday I decided to try out XFCE instead of KDE and the installation worked out quite well without really doing anything special, and then I followed the guide Jonathon suggested ( https://archived.forum.manjaro.org/search?q=9570 1) and got all the way to doing reboot, but then just as I thought everything was going according to the plan, the reboot failed, and now I cannot boot Manjaro. I get this error:

ACPI Error : Method parse/execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20170728/uteval-103)
ACPI Exception: AE_NOT_FOUND Evaluation _PRS (20170728/pci_link-176)
ACPI Exception: AE_NOT_FOUND Evaluation _PRS (20170728/pci_link-176)
ACPI Exception: AE_NOT_FOUND Evaluation _PRS (20170728/pci_link-176)
starting version 239
/dev/nvmen1p8: recovering journal
/dev/nvme0n1p8: clean, 255226/144221312 files, 2957964/56854528 blocks
iTCO_wdt: can't request region for resource [mem 0x00c5ffc-0x00c5ffff]
psmouse serio1: synaptics: Unable to initialize device. ```

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by