KDE screen artifacts - Nvidia GeForce MX250

New Acer Aspire 5 with GeForce MX250. In KDE get horizontal lines appearing in some apps. Notably konsole and kpatience. If I run the same apps in gnome, no problem. I have seen several references to changing nvidia advanced settings but I don't have that option available in my nvidia X server settings.
I have tried all combinations under compositor including disabling it to no effect. Have tried lts and latest kernel.

Hope that helps. Screenshot_20200704_083232


konsole does this - gnome-terminal does not (if that is helpful)

System:    Kernel: 5.7.0-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 
           info: latte-dock wm: kwin_x11 dm: GDM 3.34.1, SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A515-54G v: V1.17 serial: <filter> 
           Mobo: CML model: Doc_WC v: V1.17 serial: <filter> UEFI: Insyde v: 1.17 date: 01/21/2020 
Battery:   ID-1: BAT1 charge: 34.6 Wh condition: 48.0/48.9 Wh (98%) volts: 15.6/15.2 model: LGC AC14B8K type: Li-ion 
           serial: <filter> status: Discharging 
Memory:    RAM: total: 7.50 GiB used: 1.40 GiB (18.7%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP arch: Kaby Lake rev: C L2 cache: 6144 KiB 
           bogomips: 33615 
           Speed: 500 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 569 2: 596 3: 559 4: 513 5: 600 6: 542 7: 514 8: 600 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 
           bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
           est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp ibpb ibrs ibrs_enhanced ida 
           intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
           pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep 
           smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer 
           vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
Graphics:  Device-1: Intel UHD Graphics vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:9b41 
           Device-2: NVIDIA GP108M [GeForce MX250] vendor: Acer Incorporated ALI driver: nvidia v: 440.82 bus ID: 02:00.0 
           chip ID: 10de:1d13 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:02c8 
           Sound Server: ALSA v: k5.7.0-3-MANJARO 
Network:   Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 chip ID: 8086:02f0 
           IF: wlp0s20f3 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: kernel port: 3000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: down mac: <filter> 
           WAN IP: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 106.76 GiB (22.4%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM512GDJTNG-8310A size: 476.94 GiB speed: 15.8 Gb/s lanes: 2 
           serial: <filter> rev: 80002C00 scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / size: 147.23 GiB used: 15.15 GiB (10.3%) fs: ext4 dev: /dev/nvme0n1p4 label: N/A 
           uuid: c0cc1776-fade-4317-9a52-41d3320d7242 
           ID-2: /boot/efi size: 96.0 MiB used: 50.0 MiB (52.1%) fs: vfat dev: /dev/nvme0n1p1 label: ESP uuid: CC18-84B8 
           ID-3: /mnt/data size: 325.74 GiB used: 91.57 GiB (28.1%) fs: ntfs dev: /dev/nvme0n1p3 label: Acer 
           uuid: F20C1A150C19D587 
Unmounted: ID-1: /dev/nvme0n1p2 size: 16.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-2: /dev/nvme0n1p6 size: 1024.0 MiB fs: ntfs label: Recovery uuid: FE801B23801AE247 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-4:2 info: MosArt 2.4G Wireless Mouse type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 1.1 
           speed: 12 Mb/s chip ID: 062a:4102 
           Device-2: 1-5:3 info: Chicony HD User Facing type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
           chip ID: 04f2:b64f serial: <filter> 
           Device-3: 1-7:4 info: Elan Micro ELAN:Fingerprint type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 
           speed: 12 Mb/s chip ID: 04f3:0c03 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 32.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 266 Uptime: 1m Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 running in: konsole 
           inxi: 3.0.37 

dmesg | grep 'nvidia'
[    1.418088] audit: type=1400 audit(1593846853.466:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=358 comm="apparmor_parser"
[    1.418942] audit: type=1400 audit(1593846853.466:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=358 comm="apparmor_parser"
[    1.435482] nvidia: loading out-of-tree module taints kernel.
[    1.435488] nvidia: module license 'NVIDIA' taints kernel.
[    1.451200] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    1.458579] nvidia-nvlink: Nvlink Core is being initialized, major device number 242
[    1.458983] nvidia 0000:02:00.0: enabling device (0006 -> 0007)
[    1.622754] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  440.82  Wed Apr  1 19:41:29 UTC 2020
[    1.624115] [drm] [nvidia-drm] [GPU ID 0x00000200] Loading driver
[    1.624117] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:02:00.0 on minor 0
[    3.662622] nvidia 0000:02:00.0: Enabling HDA controller
[    4.193011] nvidia 0000:02:00.0: Enabling HDA controller

I think I have found the answer - I had global scaling at 125%. (1920x1080 display on a laptop). when I set it to 100% it has no artifacts. I put it at 125% because this was recommended in windows for readability. Gnome doesn't have this option so I had set screen resolution to 1600x900. Setting KDE at 1600x900 at 100% scaling works fine. Strange that artifacts occur in just a couple of apps....

Regarding line artefacts in Konsole, that's definitely connected with fractional scaling in KDE, combined with transparency settings in Konsole.

I use fractional scaling on one of my desktops, and the way I solved that problem is by replacing the launch command for Konsole with:

QT_SCREEN_SCALE_FACTORS=1 /usr/bin/konsole

Thank you - that solved the problem on both of my examples!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by