KDE: ssh agent is not started on startup: 'Could not open a connection to your authentication agent'

This is not a recent thing.
My current (KDE-)install is from february of this year and I installed keychain loosely following the arch wiki (https://wiki.archlinux.org/index.php/SSH_keys#Keychain) to manage ssh-agent.

If that is true than it was fixed and broken again.

I installed some version of KDE Manjaro onto my small 256 ssd for testing( a few months ago?) It has no issues with ssh.

But KDE 18.1.0 and 18.1.2 do have this issue. I do not believe it should be the default experience.

Maybe we misunderstood each other: I'm saying using ssh-agent didn't work out of the box in my current installation and I took explicit steps to make it work for me.

To be clear: there were no issues using ssh. Only using an authentication agent for ssh-keys. Most of all keeping one agent loaded/accessible between multiple terminal instances.

Yes, the ssh agent is not started on startup/not setup.

To be more clear, the auth agent is not working. SSH probably works fine out of the box, but I do almost all my work with private repos.

I have the same issue. It's been present for a long time, see this post I made a long time ago about it: SSH agent on Manjaro KDE missing causing issues with VSCode

I recently did a fresh install of manjaro GNOME and can confirm the issue is absent from there. However I switched to Manjaro KDE right after and the problem still exists on new installs today.

1 Like

Just tested the 18.1.3 KDE iso. The auth agent service is still broken. ssh-add does not work.

Tested 18.1.5 KDE iso. Still not working. Posting to keep topic open.

UPDATE: figured it out - ssh prompts unless stdin is /dev/null - so apparently I messed up the ssh-add < /dev/null command somehow

I'm finding that https://wiki.archlinux.org/index.php/KDE_Wallet#Using_the_KDE_Wallet_to_store_ssh_key_passphrases does not quite work. The problem for me is the SSH_ASKPASS does not seem to be recognized by git. If I execute it directly, it does run and it does have the password saved in it.

image

I'm having the same issue and I think this started recently as I often use git via SSH to manage my blog and haven't encountered any issue until recently.

I came across this:

https://wiki.archlinux.org/index.php/KDE_Wallet#Using_the_KDE_Wallet_to_store_ssh_key_passphrases
and

It sounds like KDE has always had on/off issues with ssh-agent not starting properly?

Honestly I wouldn't know. Only started using KDE for a few months now.

Did you find an open bug report for this on kde's gitlab?

No not anything official. I haven't got a chance to really dive into this and fix it up. When I have done so I'll update in this post.

Hi all, there is updated on this? I use several ssh-keys for my daily work, so I don't need just to start the agent each time, but also run 'ssh-add -l' and enter the password everytime I open a console. This, in practice, make this distro unusable.

I have a similar issue, and the problem was that I was importing ~/.ssh/config file from an older OpenSsh version.
Find my solution here.

That was not my issue. I was copying ssh keys from another machine, but not the config.

Just wanted to share my solution.

I installed plasma-ssh-agent (not sure if required) and systemd-ssh-agent (AUR). then activate it

$ systemctl --user enable ssh-agent.service

and reboot.

That package just got removed from the repo in an effort to clean up:

Removing the Plasma SSH-Agent broke ssh agent for me once again on KDE. I spent the past 2 days fixing it with the solutions from the archwiki but without success. Can someone tell me how this is done now.

Solution 1: systemd as a user
https://wiki.archlinux.org/index.php/SSH_keys#Start_ssh-agent_with_systemd_user

Solution 2: 2 boot scripts in the plasma workspace folder and autostart folder
https://wiki.archlinux.org/index.php/KDE_Wallet#Using_the_KDE_Wallet_to_store_ssh_key_passphrases

both without success, I always have to manually start the agent and add my key again:

ssh-agent
eval $(ssh-agent)
ssh-add ~/.ssh/id_rsa </dev/null

But I run into a second issue. Even if I start it manually, Filezilla isn't finding the ssh key. It seems like it needs a SSH-AUTH_SOCK variable but I included this line into my .zprofile
SSH_AUTH_SOCK DEFAULT="${XDG_RUNTIME_DIR}/ssh-agent.socket"

Seems not to work, though so I really wonder what everyone else is doing to fix all this? Like I said, I worked with the plasma-ssh-agent package.

1 Like

Did you try my solution at the top of the forum?

You posted that your workaround is to use the systemd service as a user but that didn't work for me (see solution 1 I posted). For some reason it still doesn't start the ssh agent. Not sure if I'm missing a small detail?
As I said, everything worked before plasma-ssh-agent got removed from the repos.

I have the same problem after removing plasma-ssh-agent :frowning:

Forum kindly sponsored by