KDE Wallet always asks for password at login

KDE Wallet always asks for my password when I login. WiFi and stuff like Skype doesn't work without it, which is expected, not a big deal. Anyway, is there a way to make the wallet not need a password? It's a bit of a pain to have to enter my password every single time I log in.

It should be opened at login ... unless you have autologin.

It does open, I just want a way to not have to type my password into it at login. Autologin is off if that helps.

I meant it should be unlocked at login.
There are 2 requirements for that - wallet has same password as user/login, and autologin is disabled.

If you meet both of those requirements and still get prompted to unlock wallet then there is some sort of configuration issue.
Did you install Manjaro-KDE, or try to migrate to it?

inxi -Fxxxza --no-host

How to provide good information in your posts

https://wiki.archlinux.org/index.php/KDE_Wallet

I did the Manjaro KDE minimal install. I do have the two requirements you mentioned above as well.

Double check settings and such as shown in arch wiki

1 Like

I'm only seeing stuff about auto unlock of KDE Wallet for i3 --
https://wiki.archlinux.org/index.php/KDE_Wallet

Here's a picture of what I'm seeing: https://photos.app.goo.gl/jSeJfRKv8SW6aUw37

Sorry for the link, transferring photos directly to my PC from my phone to do a direct upload to here isn't working.

Well yes .. I assumed you meant the wallet prompt when you said kde wallet asks for your password.

But I meant can you check off on this:

Note:

    kwallet-pam is not compatible with GnuPG keys, the KDE Wallet must use the standard blowfish encryption.
    The wallet cannot be unlocked when using autologin.
    The wallet cannot be unlocked when using a fingerprint reader to login
    The wallet must be named kdewallet (default name). It does not unlock any other wallet(s).
    If using KDE, one may want to disable Close when last application stops using it in KDE Wallet settings to prevent the wallet from being closed after each usage (WiFi-passphrase unlock, etc.).
    It may be needed to remove the default created wallet first, thus removing all stored entries.
    If the kwallet Migration Assistant asks for a password after every login, rename or delete the ~/.kde4/share/apps/kwallet folder.

And further this stuff:

Configure PAM

The following lines must be present under their corresponding sections:

auth            optional        pam_kwallet5.so
session         optional        pam_kwallet5.so auto_start

Edit the PAM configuration corresponding to your situation:

    For SDDM no further edits should be needed because the lines are already present in /etc/pam.d/sddm

...

So can you check all that stuff?

...

Also you still didnt return your inxi.

Perhaps you could provide some logs as well:

sudo dmesg

Please use proper formatting when posting terminal outputs.

Here's the stuff regarding that --

System:    Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=06a0a2e9-a695-46da-9f3a-ce1c7b0d1eef rw quiet 
           resume=UUID=48989b61-13ce-4d84-ae0e-9b5ab1ccab2a udev.log_priority=3 
           Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 15-bs2xx v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 84D4 v: 94.27 serial: <filter> UEFI: Insyde v: F.60 date: 05/17/2019 
Battery:   ID-1: BAT1 charge: 12.9 Wh condition: 28.2/31.1 Wh (91%) volts: 10.6/10.9 model: COMPAL PABAS0241231 type: Li-ion 
           serial: <filter> status: Discharging 
CPU:       Topology: Dual Core model: Intel Celeron N4000 bits: 64 type: MCP arch: Goldmont Plus family: 6 model-id: 7A (122) 
           stepping: 1 microcode: 32 L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 4378 
           Speed: 802 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 1172 2: 1161 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 605 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3185 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:0e.0 chip ID: 8086:3198 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Intel driver: iwlwifi v: kernel port: 2000 bus ID: 00:0c.0 chip ID: 8086:31dc 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: 1000 bus ID: 01:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 21.49 GiB (4.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST500LM030-1RK17D size: 465.76 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: RSM7 scheme: GPT 
Partition: ID-1: / raw size: 457.37 GiB size: 449.19 GiB (98.21%) used: 21.35 GiB (4.8%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.10 GiB used: 141.3 MiB (1.7%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 52.0 C mobo: 20.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 197 Uptime: 15h 25m Memory: 3.68 GiB used: 2.14 GiB (58.1%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.17 running in: konsole inxi: 3.0.37

Excuse my ignorance but regarding that stuff you wanted me to check off, I wasn't really sure what you wanted me to do.

You want the whole log? It's huge

@cscs so just blockquote?

What you had done was quote.
What I did was wrap it using the 'code' </> button.
Otherwise you can use three tics at the beginning and end: ```

2 Likes

Open System Settings
Navigate to Personalization > Account Details > KDE Wallet
Uncheck the box "Enable the KDE wallet subsystem"
Click Apply and enter your credentials.

...but...the wallet is what stores your passwords in an encrypted fashion.
Without the wallet one, or both, of two things happen:

  • you must enter your password for many many things (and not just the first time!)
  • passwords that are saved somehow .. will usually be done in plain-text (readable) format

So unless you have something to add beside simply disabling wallet .. I will stamp that with a
" bad idea :tm: "

1 Like

Yeah, I need the wallet for many apps, mainly Skype which just requires me to log back in every time I log in/out or reboot, which is a pain when combined with the 2FA I set up. So yeah, disabling KDE Wallet isn't an option.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by