KeePassXC monospaced font for notes not applied in Manjaro

I have been using KeePassXC on various systems (win10, ubuntu 18, ubuntu 16, manjaro) for a while now and am really happy with it. One nice feature is the option to choose to have the font for the Notes-section in the entries in monospaced font. This allows some level of formatting. However, in Manjaro, choosing this option in KeePassXC settings has no effect on the Notes-section font. It is the regular font of Manjaro.

This issue does not exist on any of the other tested systems.

I have messed around a bit with the appearance of Manjaro and have thus attempted to reset the appearance of manjaro by copying the content from /etc/skel/* to my ~/ directory. This resulted in a reset but did not solve the issue with KeePassXC.

I suspect that there is some sort of themes/appearance-related override form the parent system that interferes with the "local" font setting in the software itself. i would loke to mitigate this but I do not know how.

Any suggestions?

Here is some system info:

$ keepassxc --version
qt5ct: using qt5ct plugin
KeePassXC 2.5.4
$ inxi --full --verbosity=7 --filter --no-host
System:
  Kernel: 5.4.44-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Latitude E6430 v: 01 serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0CPWYR v: A00 serial: <filter> UEFI: Dell v: A24 
  date: 08/08/2019 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa tty: N/A 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.0.7 compat-v: 3.0 direct render: Yes 

[ADDED]

KeePassXC info:

KeePassXC - Version 2.5.4
Revision: dcca5aa

Qt 5.15.0
Debugging mode is disabled.

Operating system: Manjaro Linux
CPU architecture: x86_64
Kernel: linux 5.4.44-1-MANJARO

Enabled extensions:
- Auto-Type
- Browser Integration
- SSH Agent
- KeeShare (signed and unsigned sharing)
- YubiKey
- Secret Service Integration

Cryptographic libraries:
 libgcrypt 1.8.5

I can duplicate what you are seeing. The option to apply monospace fonts isn't working.

However, this probably isn't an issue with Manjaro/Arch but with keepassxc. I would report it upstream to keepassxc.

I know you say it works on Ubuntu but there is probably a different version of keepassxc there. The disadvantage of bleeding edge software is that we get the new bugs first.

I don't have the issue on plasma 5.19.2

I am on the same versions and I do see the issue.

Is our test the same? Uncheck the option for monospace note fonts you get the system font in the notes box. Check the box and it switches to a monospace font?

For me, it doesn't matter if that box is checked or not. I always get the normal font.

for me it works.

With normal font set (unchecked monospace option)
image

with monospace option checked.
image

sometimes it does not "refresh" correctly.

That is interesting it works for me now too and it didn't a few hours ago :face_with_monocle:

I have made no changes to my system nor rebooted. That is almost unexplainable.

yes.. it seems not constant.. it's why I "deleted" my post just before.. as I had doubt it really worked.
it seemed sometimes it forgot.. or I don't know...

1 Like

I have reset and restarted the software, the system, etc. Still no luck. Perhaps it is a matter of XFCE?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by