Kernal Panic after upgrade


Help me out :frowning: I've been searching and it seems nothing works with me. After I installed Android Studio, i did pacman-Syu. It did asked me some questions about some packages whether to replace them and I just did yes to all of them (cuz I was sleepy and didn't even read it) :frowning: . And then next day morning, when I opened my laptop, this happened, I am new to arch, so plz understand my noob skills.

What have you tried so far that's not working?

Are you dual-booting with another OS or you have only Manjaro installed?

Did you try another TTY?


You might have updated your kernel. Do you have any other kernels in grub? Can you boot from them?
If not, you'll have to use live-cd and check pacman.log for any conflicts you had missed.

No init found...

You could try to chroot into your manjaro, re-install your kernel, install systemd, run mkinitcpio -P run update-gruband try again. :thinking:

Yes I'm dual booting with kali

  • I've tried the live usb in order to chroot and it said
    sh: can't access tty; job control turned off

  • I've tried appending in grub by pressing e (advice from other posts)

  • I checked the symlinks from kali and they exist as well

I've tried that too

I don't have another kernel and when I used live USB, it said
So what should I do next?

So, can I chroot from kali? I don't wanna mess this as well :sweat_smile:
Can u give me some details plz

update **
now i can chroot to my manjaro. :smile:

If you are booting up Manjaro from Kali's grub (looks like it), then you need to (or better and easier, no, just easier) to use Manjaro grub to boot as default. Otherwise booting Manjaro from Kali's grub will result in kernel panic (without modification).

Here's two ways you can use.
ps: 2 links above.

Oh.. don't forget to 'grub-install /dev/sda' and 'update-grub' after you boot up manjaro.

In my case, manjaro is already default and I've also tried a similar one it takes me back to the kernal panic error :disappointed_relieved:

Oh yeah!!! I did it!!! Thanks everyone for your advices and kindness :smiley:
Screenshot from 2017-12-11 23-40-14
Now it is running perfectly like it used to be

How i fixed my problem

  • i did chroot from kali and first i thought i have to reinstall the kernal but i thoroughly read the pacman log again and realized it might be virtualbox headers

  • so i removed all virtualbox packages

  • run pacman -Syu again

  • as u guys suggested, installed systemd

  • and then run mkinitcpio -P and update-grub

  • and then generating grub config successfully done

  • exited chroot and reboot and everything works fine again

Again, thanks a lot :smiley:

1 Like

[message not specifically to OP]
Isn't Kali Debian based?
How is it possible to chroot from a Debian based OS, and do pacman and mkinitcpio?

Can anybody explain?

I really don't know the details but I got in :smile:
Steps taken are from this
Chroot Arch

AFAIR with (any) chroot you work in and on the chrooted system except some network interlinking to the host.


The problem you discribed could also derive from a kernel-update or otherwise running update-grub in kali (depending on how you set-up the dual-boot system). The update-grub in Debian (or other non-Arch Linux') might not recognize that Manjaro needs two images in the initrd line. Then the grub.cfg generated by kali will probably look like this:

menuentry 'Manjaro Linux' .....  {

	initrd	/boot/intel-ucode.img

Instead of this:

menuentry 'Manjaro Linux' .....  {

	initrd	/boot/intel-ucode.img /boot/initramfs-4.15-x86_64.img

Note that in the first case /boot/initramfs-4.15-x86_64.img is missing and this will lead to the kernel panic.

For solving this type of problem you could also go as follows:

  • boot into your second Linux; kali in your case
  • mount Manjaro's partition (for opening its grub.cfg)
  • copy the initrd-line of Manjaro's grub.cfg to the Manjaro section in your second Linux' grub.cfg (note that the name of initramfs will change depending on your kernel)
  • save the modified grub.cfg and reboot into Manjaro (do not update your 2nd Linux or run update-grub before rebooting)
  • in Manjaro run sudo grub-install /dev/sdX (with X being the HDD used for installing grub)
  • Note: depending on your set-up sudo update-grub might already be sufficient

Best regards,

P.S.: You could of course also use grub's editing mode to add the missing part if you alreday know the name of the .img file to add and boot directly into Manjaro.

Forum kindly sponsored by