Kernel 4.19.0-3. Not Network after suspending - Gnome Edition

Hello, install the kernel 4.19.0-3 to test it and I found that after restore the computer from a state of suspension, there is no network. To fix it I have to restart the computer. With the kernel 4.18.12_rt7-1 it also gives me the same error. Only with the kernel 4.14.78-1 the equipment works correctly. Thanks

Inxi -F:

System:    Host: federico-pc Kernel: 4.14.78-1-MANJARO x86_64 bits: 64 Desktop: Gnome 3.30.1 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: H87M-D3H v: x.x serial: <root required> 
           BIOS: American Megatrends v: F10 date: 07/16/2014 
CPU:       Topology: Quad Core model: Intel Core i5-4670 bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 1099 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 987 2: 1006 3: 1001 4: 992 
Graphics:  Device-1: AMD Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.3 driver: amdgpu resolution: 1920x1080~60Hz 
           renderer: AMD Radeon HD 8800 Series (PITCAIRN DRM 3.19.0 4.14.78-1-MANJARO LLVM 7.0.0) 
           v: 4.5 Mesa 18.2.3 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio driver: snd_hda_intel 
           Device-2: AMD Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] 
           driver: snd_hda_intel 
           Sound Server: ALSA v: k4.14.78-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 94:de:80:ba:92:27 
Drives:    Local Storage: total: 1.36 TiB used: 288.96 GiB (20.7%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-00BN5A0 size: 931.51 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD5000AAKX-001CA0 size: 465.76 GiB 
Partition: ID-1: / size: 292.75 GiB used: 22.65 GiB (7.7%) fs: ext4 dev: /dev/sda6 
           ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: amdgpu temp: 32 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 187 Uptime: 6m Memory: 7.72 GiB used: 1.24 GiB (16.1%) Shell: zsh inxi: 3.0.27 

You will likely need to write a systemd service file.

I have other threads along the same lines if you search the forum.

@tbg Thank you, I had tested your solution before but it had not worked, I had to give them the necessary permissions to work, now it seems to work correctly. regards

1 Like

If you found a solution using a systemd service please post your working solution on my systemd thread:


@tbg I am using your solution now, but today the network failed again. The equipment would have been suspended for 2 hours or so and the failure returned, I had to restart to make it work again. I do not know why it will be, you see that the problem is not solved 100% and sometimes another fails, because with kernel 4.14 works without problems. Thank you.

Are you also unloading your modules and your adapter before suspending. That could make it more reliable.

How do I do that?

systemctl stop NetworkManager.service; ip link set enp2s0 down; modprobe -r r8169

Your adapter ID and driver may be different.

You would have to post:

inxi -n

To find out your particulars.

This is me inxi -n:

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full

Thanks for the help.

The script I posted was for the r8169 driver. You are using the r8168 driver. Follow the instructions on the post where you found my fix. on that post is instructions to blacklist the r8168 driver and switch to the r8169 driver.

You have only followed part of the procedure that is probably why it is not working reliably.


I blacklisted the r8168, now I'm using the r8169. For now everything works correctly, I will continue testing these days if there is an error. Thanks for your help.

Please mark your thread solved when you are satisfied this issue is resolved. Another happy customer using my systemd services to fix their suspend issues. That makes me very happy to hear.

Glad you got it working. :smile:

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by