Kernel panic after updating a fresh stable install

Hi guys!

I'm a developer, and I'm doing the classic Windows (20 years) => Ubuntu (1 year) => arch linux.

Specifically, I want to use manjaro, and I'm already totally in love with it, great job.

But, I can't use it properly right now because it keeps going on kernel panic and I cannot figure out why.


  1. install Manjaro 18.04 XFCE MINIMAL and restart
  2. try to restart again to check if it boots correctly
  3. update all the packages (424 by today and almost 800MB)
  4. restart, kernel panic and blinking leds :frowning: , I tried the same steps 3 times but no success.


I have 3 1TB SSDs.

  1. Windows with EFI partition
  2. Ubuntu with EFI partition
  3. manjaro ONLY, and when I install manjaro it asks me where to put the EFI partition and I select the Windows SSD one as it does not allow me to select the 3rd SSD because it as no UEFI configuration on it, I think. (in the end the windows SSD has 2 EFI partitions)

What I am doing wrong? Should I try another ISO? Maybe the XFCE normal or XDE?

The post lacks hardware info.

You can also try 18.10.rc9 and see what happens.

And: which grub from which distro do you use?

Hardware infos:


I'm using the manjaro GRUB, as manjaro was the last thing I installed.

Ok, I'll try the 18.10 then.


You should post logs:

sudo dmesg  | grep -Ei 'error|segf|fail|broke|warn|dump|denied|firm|oops|bug|qos|regdom|wmi|rtl|wl|ath|b43|bcm|brcm|eth|enp|r816|blue|deauth' | grep -viE 'acpi|ras'

HW info:

inxi -Fxxxza --no-host
1 Like

where should I run this command as I cannot run the manjaro machine?

the only thing I can imagine is by booting with an sub, chrooting to the manjaro one and the running it?

(I mean the first command ofc)

You would need to chroot for dmesg, but the inxi output can be run from the live environment.

Can you post the kernel error?

Sorry was working.

this is the inxi from inside the manjaro broken image.

12System:    12Kernel 4.19.30-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 8.2.1 
           12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC driver=free 
           nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 misobasedir=manjaro 
           misolabel=MJRO1804 quiet systemd.show_status=1 
           12Console N/A 12wm xfwm4 12dm N/A 12Distro Manjaro Linux 
12Machine:   12Type Laptop 12System LENOVO 12product 20EN0006MZ 12v ThinkPad P50 12serial <filter> 12Chassis 
           12type 10 12serial <filter> 
           12Mobo LENOVO 12model 20EN0006MZ 12v SDK0J40705 WIN 12serial <filter> 12UEFI LENOVO 
           12v N1EET70W (1.43 ) 12date 07/12/2017 
12Battery:   12ID-1 BAT0 12charge 79.1 Wh 12condition 80.6/90.0 Wh (90%) 12volts 12.2/11.2 12model SMP 00NY493 
           12type Li-poly 12serial <filter> 12status Discharging 
12CPU:       12Topology Quad Core 12model Intel Core i7-6820HQ 12bits 64 12type MT MCP 12arch Skylake-S 
           12family 6 12model-id 5E (94) 12stepping 3 12microcode C6 12L1 cache 256 KiB 12L2 cache 8192 KiB 
           12L3 cache 8192 KiB 
           12flags avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 12bogomips 43408 
           12Speed 3229 MHz 12min/max 800/3600 MHz 12Core speeds (MHz) 121 3200 122 3261 123 3272 124 3204 
           125 3200 126 3231 127 3273 128 3262 
           12Vulnerabilities 12Type l1tf 
           12mitigation PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           12Type meltdown 12mitigation PTI 
           12Type spec_store_bypass 
           12mitigation Speculative Store Bypass disabled via prctl and seccomp 
           12Type spectre_v1 12mitigation __user pointer sanitization 
           12Type spectre_v2 12mitigation Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
12Graphics:  12Device-1 Intel HD Graphics 530 12vendor Lenovo 12driver i915 12v kernel 12bus ID 00:02.0 
           12chip ID 8086:191b 
           12Device-2 NVIDIA GM107GLM [Quadro M2000M] 12vendor Lenovo 12driver nouveau 12v kernel 
           12bus ID 01:00.0 12chip ID 10de:13b0 
           12Display 12server 1.20.5 12driver intel,modesetting 12unloaded nouveau 
           12alternate fbdev,nv,vesa 12tty N/A 
           12Message Advanced graphics data unavailable for root. 
12Audio:     12Device-1 Intel 100 Series/C230 Series Family HD Audio 12vendor Lenovo 
           12driver snd_hda_intel 12v kernel 12bus ID 00:1f.3 12chip ID 8086:a170 
           12Sound Server ALSA 12v k4.19.30-1-MANJARO 
12Network:   12Device-1 Intel Ethernet I219-LM 12vendor Lenovo 12driver e1000e 12v 3.2.6-k 12port efa0 
           12bus ID 00:1f.6 12chip ID 8086:15b7 
           12IF enp0s31f6 12state down 12mac <filter> 
           12Device-2 Intel Wireless 8260 12driver iwlwifi 12v kernel 12port 4000 12bus ID 04:00.0 
           12chip ID 8086:24f3 
           12IF wlp4s0 12state up 12mac <filter> 
12Drives:    12Local Storage 12total 1.95 TiB 12used 5.68 GiB (0.3%) 
           12ID-1 /dev/nvme0n1 12vendor Samsung 12model MZSLW1T0HMLH-000L1 12size 953.87 GiB 12block size 
           12physical 512 B 12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12serial <filter> 12rev 3L0QCXY7 
           12ID-2 /dev/nvme1n1 12vendor Samsung 12model MZSLW1T0HMLH-000L1 12size 953.87 GiB 12block size 
           12physical 512 B 12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12serial <filter> 12rev 3L0QCXY7 
           12ID-3 /dev/sda 12vendor Samsung 12model SSD 840 EVO 1TB 12size 931.51 GiB 12block size 
           12physical 512 B 12logical 512 B 12speed 6.0 Gb/s 12serial <filter> 12rev DB6Q 
           12ID-4 /dev/sdb 12type USB 12vendor Kingston 12model DataTraveler 3.0 12size 115.52 GiB 
           12block size 12physical 512 B 12logical 512 B 12serial <filter> 12rev PMAP 
12Partition: 12ID-1 / 12raw size 931.51 GiB 12size 915.89 GiB (98.32%) 12used 5.60 GiB (0.6%) 12fs ext4 
           12block size 4096 B 12dev /dev/sda1 
12Sensors:   12System Temperatures 12cpu 63.0 C 12mobo N/A 12gpu nouveau 12temp 47 C 
           12Fan Speeds (RPM) 12cpu 2988 
12Info:      12Processes 258 12Uptime 3m 12Memory 62.65 GiB 12used 1.20 GiB (1.9%) 12Init systemd 12v 242 
           12Compilers 12gcc 9.1.0 12Client Unknown Client: kworker/6:0-events 12inxi 3.0.35

this is the kernel error with the command above

sudo dmesg  | grep -Ei 'error|segf|fail|broke|warn|dump|denied|firm|oops|bug|qos|regdom|wmi|rtl|wl|ath|b43|bcm|brcm|eth|enp|r816|blue|deauth' | grep -viE 'acpi|ras'
[    1.118344] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    9.989303] VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.PEG0.PEGP handle
[   10.049795] [drm] Finished loading DMC firmware i915/skl_dmc_ver1_27.bin (v1.27)
[   10.132235] e1000e 0000:00:1f.6 eth0: (PCI Express:2.5GT/s:Width x1) 50:7b:9d:97:e6:0a
[   10.132240] e1000e 0000:00:1f.6 eth0: Intel(R) PRO/1000 Network Connection
[   10.132289] e1000e 0000:00:1f.6 eth0: MAC: 12, PHY: 12, PBA No: 1000FF-0FF
[   14.280576] e1000e 0000:00:1f.6 enp0s31f6: renamed from eth0
[   14.468124] iwlwifi 0000:04:00.0: enabling device (0000 -> 0002)
[   14.578375] iwlwifi 0000:04:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
[   14.673441] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208
[   14.759046] iwlwifi 0000:04:00.0: base HW address: a4:34:d9:93:28:c1
[   14.847453] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   14.848045] thermal thermal_zone3: failed to read out thermal zone (-61)
[   14.878966] iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
[   15.464529] Bluetooth: Core ver 2.22
[   15.464542] Bluetooth: HCI device and connection manager initialized
[   15.464544] Bluetooth: HCI socket layer initialized
[   15.464546] Bluetooth: L2CAP socket layer initialized
[   15.464550] Bluetooth: SCO socket layer initialized
[   15.583857] Bluetooth: hci0: Bootloader revision 0.0 build 2 week 52 2014
[   15.588900] Bluetooth: hci0: Device revision is 5
[   15.588901] Bluetooth: hci0: Secure boot is enabled
[   15.588902] Bluetooth: hci0: OTP lock is enabled
[   15.588903] Bluetooth: hci0: API lock is enabled
[   15.588904] Bluetooth: hci0: Debug lock is disabled
[   15.588905] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[   15.632940] Bluetooth: hci0: Found device firmware: intel/ibt-11-5.sfi
[   15.796687] psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3
[   16.109998] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   16.110000] Bluetooth: BNEP filters: protocol multicast
[   16.110003] Bluetooth: BNEP socket layer initialized
[   16.581935] IPv6: ADDRCONF(NETDEV_UP): enp0s31f6: link is not ready
[   16.819342] IPv6: ADDRCONF(NETDEV_UP): enp0s31f6: link is not ready
[   16.821880] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   16.837422] Bluetooth: hci0: Failed to send firmware data (-38)
[   17.079739] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   17.351062] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   17.664900] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   24.151835] Bluetooth: hci0: Bootloader revision 0.0 build 2 week 52 2014
[   24.156884] Bluetooth: hci0: Device revision is 5
[   24.156885] Bluetooth: hci0: Secure boot is enabled
[   24.156885] Bluetooth: hci0: OTP lock is enabled
[   24.156903] Bluetooth: hci0: API lock is enabled
[   24.156904] Bluetooth: hci0: Debug lock is disabled
[   24.156904] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[   24.157056] Bluetooth: hci0: Found device firmware: intel/ibt-11-5.sfi
[   25.583565] Bluetooth: hci0: Waiting for firmware download to complete
[   25.583820] Bluetooth: hci0: Firmware loaded in 1398964 usecs
[   25.583919] Bluetooth: hci0: Waiting for device to boot
[   25.594824] Bluetooth: hci0: Device booted in 10709 usecs
[   25.613250] Bluetooth: hci0: Found Intel DDC parameters: intel/ibt-11-5.ddc
[   25.616832] Bluetooth: hci0: Applying Intel DDC parameters completed
[   30.000577] Bluetooth: RFCOMM TTY layer initialized
[   30.000583] Bluetooth: RFCOMM socket layer initialized
[   30.000587] Bluetooth: RFCOMM ver 1.11
[   45.175723] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   49.332241] wlp4s0: authenticate with f2:9f:c2:fb:56:1d
[   49.345415] wlp4s0: send auth to f2:9f:c2:fb:56:1d (try 1/3)
[   49.354790] wlp4s0: authenticated
[   49.355388] wlp4s0: associate with f2:9f:c2:fb:56:1d (try 1/3)
[   49.360696] wlp4s0: RX AssocResp from f2:9f:c2:fb:56:1d (capab=0x411 status=0 aid=2)
[   49.362464] wlp4s0: associated
[   49.439532] IPv6: ADDRCONF(NETDEV_CHANGE): wlp4s0: link becomes ready
[  111.765240] SGI XFS with ACLs, security attributes, realtime, scrub, no debug enabled

There you have it... You must disable Secure Boot. Manjaro does not support that.

1 Like

Ok, I just checked in the bios, and the Secure Boot is ALREADY disabled.. that's weird, why it logs as it was enabled?

Just checking...

It may not be.. (you are on UEFI) system may still be using Ubuntu's grub.
If the first OS entry is Manjaro, then it is likely it is from Manjaro grub
But if the first OS entry is Ubuntu, then it is likely from Ubuntu grub.

Never mind, suggest you use this first post to boot into Manjaro. You don't need to use livecd but you can use the grub prompt (from Ubuntu grub, it is also fine), start from

grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg

after you get to grub prompt.

As in the very recently revised post, suggest you install grub-vanilla.
Whatever, make manjaro the default grub by doing the 2 Additional UEFI commands].

Good luck.

This could be your issue. If you can shut your wifi off in your bios that would be an easier test method than removing your wifi card. You both have Intel iwlwifi adapters, so this could very well be your problem.

Downgrading your iwlwifi firmware also might be a way of avoiding taking your wifi adapter out (if youre not comfortable doing that kind of thing).

1 Like

I saw the link. But I wonder if this can be a 'happy happenstance'. If there is no network or wifi, wouldn't the system boot up anyway (without wifi)? Are there more cases like this?

You're the go-to person on this issue. Appreciate your input.

There have been no other reported cases of this recently, but that is probably because the average user would never connect the dots. I rarely check logs on boot help requests to spot this type of wifi complication.

Yes there are other issues exactly like this with other adapters in the past. This is not common, but it is certainly not unique. As a matter of fact it is probably far more common than reported because most would never suspect or properly diagnose the cause.

1 Like

Ok, what I tried:

  • totally formatting my 3 hd
  • reinstalling windows to one
  • installing manjaro XFCE (normal one, not the minimal this time) to one

Same behavior as before, so definitely wasn't because of messed up partitions (I know you already knew, but it was really messed up so I wanted to dismiss this option)

Still kernel panic.

As I cannot disable WIFI from Bios and I cannot remove the wifi adapter, I'll try to just update the kernel to very latest one before applying any update and cross fingers.

It was 100% manjaro GRUB, as it had the manjaro logs on the behind and it was the first entry.

Anyway, now I have only Windows & manjaro but still kernel panic.. :frowning:

Secure boot. - Recheck your bios setting again. Need saving. Some motherboards need to set security or password to save. And if tbg has something on network, listen to him. He's da man.

1 Like

If you needed to I guess you could always blacklist the iwlwifi module by booting to a TTY in run level 3.

Eh guys, now it works. finally.

this time I installed directly 18.1.0 RC10 which didnt ask me to update anything and already has kernel 5.2

I don't know if it was a faulty package or kernel 5.2 that fixed, but at least it works, I am so happy.

@gohlip you are all da man for me.

btw, what do you think about these scripts I made?

they install all my necessary stuffs on ubuntu or manjaro :smiley:


This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by