Kernel panic amd-ucode

Hi . I can no longer boot into manjaro after ubuntu grub update.
(kernel panic not syncing:VFS:unable to mount root fs unknown-block(0,0)
triple boot machine win10, manjaro, ubuntu.

Does the menu entry look Ok or does it need to be edited ?
thanks for any info.

menuentry 'Manjaro Linux (17.1.12) (on /dev/sda8)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-1c47824e-a169-4f21-a4e6-ec4b1e13d1e9' {
insmod part_gpt
insmod ext2
set root='hd0,gpt8'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt8 --hint-efi=hd0,gpt8 --hint-baremetal=ahci0,gpt8 1c47824e-a169-4f21-a4e6-ec4b1e13d1e9
search --no-floppy --fs-uuid --set=root 1c47824e-a169-4f21-a4e6-ec4b1e13d1e9
linux /boot/vmlinuz-4.14-x86_64 root=UUID=1c47824e-a169-4f21-a4e6-ec4b1e13d1e9 rw quiet splash resume=UUID=a82a3639-cf94-4a89-a882-13774bf8acca
initrd /boot/amd-ucode.img

Ubuntu's grub cannot boot manjaro. You must use manjaro's grub.
There are a few ways to fix this. Have a look here:
[TOC] Boot-GRUB problems

I have been booting into manjaro using ubuntu grub entry for 18 months
why did it stop working just now?

I did this as per instructions from philm

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:
sudo pacman -Syyu
sudo pacman -S amd-ucode

could this be the reason it stopped working.

For now add Manjaro initrd by the amd-ucode line and stop using Ubuntu grub.
Install grub from Manjaro and always use this.

The reason it worked before is that you did not update-grub in Ubuntu after installing amd-ucode in manjaro.

thanks for the reply
how to?.. add Manjaro initrd by the amd-ucode line

thanks for the reply
is there a way to fix this

Well, I fixed this after installing ubuntu along with Manjaro and Win10 (i knew it would happen) with simply using my Super Grub stick (Manjaro live stick will do as well) and boot into Manjaro. Issue

$ sudo grub-install
$ sudo update-grub

You will then be able to boot all OS's on your computer. Funny thing is, when I installed Ubuntu, it took over my Manjaro Grub Theme.

Edit: After you booted into your INSTALLED Manjaro, remove the stick before you run the grub commands. Otherwise there will be some things like booting a Mac Version. This is because it is supported by your boot stick.

Edit2: This is true at least for GPT partitioning.

Edit3: Yes, this happens to me too after updating ubuntu. This makes it more of a nuisance than win10 itself.


Awesome. I was having the issue after install Linux Mint. I have Win10 / Manjaro / Mint and I was having Mint bootloader popup and had to restart my computer so that it could see Manjaro. This fixed it.

To help with Win10 and Linux stuff, seperate drives do help which is how my setup is here.

This is because Mint is based on Ubuntu. There is just something with their boot process Manjaro does not do. For myself I call it "aggressive". @gohlip can surely tell us more about that. There is actually no need to run everything on seperate drives. In my box is actually no space for another drive (surface pro).

thanks for all the info.
removed amd-ucode ..will keep using ubuntu grub bootloader for now .
If system becomes unstable may be forced to use manjaro grub.

Au contraire, there is something that Manjaro (& Arch) does that others don't do.

And not because it has a newer version.

What ever. It's different.

For the heck of it, I installed amd-ucode in my intel-ucode enabled system,
Here's what I got in my initrd line of my grub.cfg

echo	'Loading initial ramdisk ...'
		initrd	/boot/intel-ucode.img /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img

Boots fine.
But a devaju moment. From an old post.

I wonder when amd-ucode gets introduced, how is Arch and Manjaro going to handle this. Probably the same way.
initrd /boot/intel-ucode.img /boot/amd-ucode.img /boot/initramfs-4.55x86_64.img


1 Like

thanks for that .
reinstalled amd-ucode
added..... initrd /boot/amd-ucode.img /boot/initramfs-4.14-x86_64.img to grub.cfg
Don't know if amd-ucode is working properly..... but it boots ok

Check with

dmesg | grep microcode

dmesg | grep microcode
[ 0.620976] microcode: CPU0: patch_level=0x07030105
[ 0.620990] microcode: CPU1: patch_level=0x07030105
[ 0.621090] microcode: Microcode Update Driver: v2.2.

Did some reading, internet full of micrcode info.
still don't know if my system is patched properly,its beyond my pay grade
but computer runs great ,

➜  ~ dmesg | grep microcode
[    0.000000] microcode: microcode updated early to revision 0x20, date = 2018-04-10
[    0.875709] microcode: sig=0x306a9, pf=0x2, revision=0x20
[    0.875803] microcode: Microcode Update Driver: v2.2.

Wow, I understand nothing, too. :slight_smile:

I don't have amd processors anymore
and I think it is working because it does not have a message asking you to upgrade.
Though you do not have a "microcode updated early" message and I am not sure if it has been updated "early".
Perhaps @jonathon or others who have amd can confirm for you.


It is working fine. You have...

and you have intel.

1 Like


old AMD :wink: (2009)

~ >>> dmesg | grep microcode
[    1.284124] microcode: CPU0: patch_level=0x01000095
[    1.284131] microcode: CPU1: patch_level=0x01000095
[    1.284140] microcode: CPU2: patch_level=0x01000095
[    1.284148] microcode: CPU3: patch_level=0x01000095
[    1.284204] microcode: Microcode Update Driver: v2.2.

Forum kindly sponsored by