Kernel Panic Boot error: switch_root failed to execute /sbin/init: exec format error

Dear all,
this is my very first hello in this forum so I hope I am in the right section for this problem. I am a fairly new user to Manjaro and am running the most recent stable release it its KDE spin on my thinkpad. That is, until it broke this week. I am no longer able to book and my system halts with a Kernel Panic.

After an unexpected shutdown my machine refused to start up again. At first I was greeted by a kernel panic (similar to the one below but more elaborate). Since this whole thing happened in the middle of a meeting, I just shutdown the machine. Since then, on most of the reboots the screen stays black after grub. I initially blamed some filesystem errors for it due to the shutdown. But e2fsck on my partition did not return any errors. Also a search for bad blocks did not return any errors.

I installed Manjaro on a 250GB SSD, using a dual boot with Windows. The whole system is using luks for encryption. I have no problem acessing all my files on the drive or boot into windows, so I guess there is no partition or hardware defect involved. Could it be that some update went wrong?

Does anyone have an idea what to do about this particular problem?
Here is a picture I've taken from the screen:

What sticks out to me (apart from /sbin/init: exec format error) are things like the "code: bad RIP value" and the Kernel Panic: Not syncing - attemped to kill init!". Could something be wrong with the init system for some reason?

Thank you all!

1 Like

Hello fellow manjaroian, welcome to the forum! :slight_smile:. This is the right place to post.

Since you mention unexpected shutdown, I would attempt to repair your install via chroot

Tutorial: How to magically fix most computers that will not boot after a manjaro update!

Thanks for troubleshooting on your own before posting :slight_smile:. Hope this works, if not, just leave a comment.

I have the exact same issue. Yesterday manjaro would not shut down even after 10 minutes, so I forced shutdown using power button. And this morning the same screen welcomed me as in the original post.

Since I have luks encrypted drive, the following tutorial worked for me to be able to chroot using live Manjaro:

Then I tried to upgrade system and update grub according to this tutorial:

However system upgrade failed to find linux-419 kernel, then also update-grub had problems locating the kernel.

So instead of upgrading system and updating grub, I installed an older kernel version:

sudo mhwd-kernel -i linux414

Then rebooted and selected linux414 kernel from grub. It booted successfully, so I removed linux419 kernel then reinstalled it. Now I can also boot linux419 again.

For me the lesson is that I should always keep an old, working kernel, just in case. A few months ago, when linux419 seemed to be stable, I removed linux414, just to free up some disk space on boot partition, because unfortunately it is only 200 MB.

1 Like

Thank you both for the help, it was wuite helpful. But now I am still stuck:
After chrooting into my installation I executed a "sudo pacman -Syyuu" and got around 222 packages (~2,2 GG) to update. One conflicted occured right away: libmariadbclient conflicted with extra/mariadb-libs. I chose to replace the former with the latter.
Then unfortunately, I was greeted with list of hundreds of problem. all inthe fashion of:

"systemd: /usr/share/zsh/site-functions/_systemctl exists in filesystem"
I got this for lib32-systemd and systemd-sysvcompat as well. The systemd call must be hundreds of lines since I cannot even access all of them in bash(Konsole).

I did a "pacman -Qo halt init" out of curiosity and got a:

error: No package owns /usr/bin/halt
error: No package owns /usr/bin/init

I don't wanna force pacman to install because I fear something fundamentally is wrong here. Any ideas?

I think you can skip system upgrade, at least it did not work for me for other reasons. Just install another kernel and reboot. Manually choose that other kernel from grub and once your system is up and running just reinstall the kernel that you previously encountered kernel panic with, reboot and it should be able to boot now.

Hi all,

Also quite new to the Manjaro forums, now it seems I have a similar problem. Complaining about missing and goes into kernel panic. Tried to bootfailsafe but no avail. Kernel 4.19.16-1

Will try to follow the chroot suggestion and see how that goes. Thanks in advance for your suggestions above.


So, I tried to go along with the install of a new Kernel, for which I picked 4.20 as it was recent and available. Unfortunately, this didn't work, as the install ran into quite some issues. Have a look at this pastebin:

For me it seems like all issues I run into might be related to each other. Any ideas?

can you return

sudo journalctl -b0 -p err ( or -b -1 or -b -2 )

So I tried some fixing here, concentrating on the upper errors. Looking up

ldconfig: File /usr/lib32/ is empty, not checked.

suggested something wrong with those packages in general and as systemd and how its installed on my machine was/is also probably the initial source ofmy problems, I opted to try to reinstall all of that.
But a "sudo pacman -Syu" was aborted, throwing a lot of errors. I then try to update my mirrors, using "sudo pacman-mirrors -g", which resulted in this:

From the looks of it my chroot session has no connection to the internet. Which is weird because the same thing just works once I exit the chroot.
So as of now:
-I cannot update any mirrors or package databases
-I cannot reinstall any of the software installed
-I cannot install any new kernels.

Any ideas?


As you see it returned absolutetly nothing.

you will have to re install

backup your /home ,
if /home partition exists , re-install only /

your system is broken , pacman also

How broken is it? Is there any way of reviving the current install?

last try
launch on USB install
open a terminal

manjaro-chroot -a ( select 1 if 0 appears )
inxi -Fxxx ( check EFI or Bios appears )
mhwd-kernel -li ( list ) 
mkinitcpio -P
pacman -Syyu
exit ( for quit chroot )

if any trouble appears ask on forum , and return lines errors

Can report success on the chroot suggestion for my part. There were a couple of missing systemd packages that were installed. Thanks a bunch!

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by