Kernel panic in Manjaro after updating the system

Try this.

1 Like

I suspect several misconceptions...
To make clear what others suggested already:

  • Boot to Live Manjaro installer
  • Use manjaro-chroot to get into your installed Manjaro
  • Run
mhwd-kernel -i linux50
  # or this, whichever you have not already installed
mhwd-kernel -i linux419
mkinitcpio -P
update-grub
exit
  • Reboot

If it still fails, use @gohlip 's link to restore grub

when I type

  1. boot up livecd in the right mode, uefi or bios-legacy
  2. Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).
grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg

those commands (mentioned above)in grub> show me my Grub with everything in order but when I choose manjaro for starting I have the kernel panic and when I choose kali
the console says:
gave up waiting for root file system device.
Alert! /dev/sdc5 does not exist dropibg to a Shell

(initranmfs) _

how do I get into my manjaro with manjaro-chroot,
the live Cd menus just let me use a terminal with *grub> I can not enter in anyway to my OS

then when I tried:

Blockquote You may want to check out this link first if the ‘comprehensive’ details here are confusing.
Warning: the link is not that easy either.

Install media versions 17.0.1 and above is using grub as boot mechanism.
Therefore we can use this grub to boot our installed OS’s in case our OS bootloader fail for whatever reason. To do this…

  1. Take the manjaro livecd and start it up in the same mode as your installation (uefi or bios-legacy).
  2. Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).
  3. To be sure you’ve started up livecd in the right mode, at grub prompt, check output of
grub> echo $grub_platform

If output is pc , you’ve booted up in bios-legacy.
If output is efi , you’ve booted up in uefi.
If you’re in the wrong mode, reboot livecd in the right mode.

  1. If there are multiple Manjaro’s or if there is a separate boot partition,
    See sections below for required command changes, otherwise proceed right here.

And if the bootloader is broken due to a messed up manjaro grub.cfg itself,
the configfile method won’t work as configfile will just bring up the bad grub.cfg itself.
Then we will need to boot to the kernels directly.

grub> search.file /etc/manjaro-release  root
grub> probe -u $root --set=abc
grub> ls ($root)/boot/

  1. copy down kernel and initrd file, say vmlinuz-4.14-x86_64 and initramfs-4.14-x86_64.img
    Use the right kernel below like 4.18 or 4.19 or…
grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.19-x86_64.img
grub> boot

Blockquote
at the end the kernel panic apperas again saying that failed to execute /init (error -2)
kernel panic - not syncing: no working init found

I thought it was clear enough, but.. you can never know how/if what you write, others will read.

  • Boot to Manjaro Live environment (don't press C to go to grub prompt)
  • Start a terminal and run manjaro-chroot -a(press enter after writing this in terminal command-line)
    If it lists one installation with (0) number, press number 1 and enter.
    Then the rest of the commands, pressing Enter after each one.
    :man_shrugging:
3 Likes

Just to note, if following these sorts of instructions is not working then reinstalling is a quick and easy solution.

2 Likes

I did what you suggest:

  • Boot to Manjaro Live environment (don't press C to go to grub prompt)
  • Start a terminal and run manjaro-chroot -a (press enter after writing this in terminal command-line)
    If it lists one installation with (0) number, press number 1 and enter.
    Then the rest of the commands, pressing Enter after each one.

but the system show me kernel panic instead of a terminal is there anyway to acces terminal in my installed system from the live Cd running?

could I just reinstall the system without loosing my data?

Depends how you partitioned your drives and if you have a backup of your data.

I separate my / and /home onto different partitions so reinstallation is trivial.

1 Like

Did you select "Boot to Manjaro" at the main screen (where there are choices like "free" drivers, Timezone etc?

yes, I did it, after pressing "e" it sends me to a edit the manjaro line, and then I press Crtl+C or F2 and I enter to the GRUB> not to the Terminal /console.

grub> manjaro-chroot -a

does not work.

You're not reading the instructions correctly. Read them again, carefully.

1 Like

ok, I boot to Manjaro Live enviroment and I see options:
the hour
time zone
keytable
language
driver=free
boot Manjaro.x86_64 gnome
help
memtest
install BIOS-system on hd0,msdos5
reboot.

press enter to boot selected OS
up and down arrows navigation
(E) edit selection
(C) GRUB command line


how do I start a terminal from this point?

Select "Boot Manjaro.x86_64 Gnome" using the arrow keys and press enter. When the live system has booted start a terminal as usual.

1 Like

ok, im in a terminal typing and i got until this command:

Blockquote [manjaro-gnome /]# mhwd-kernel -i linux50
error: could not open file /var/lib/pacman/local/yelp-3.32.0-1/desc: No such file or directory
:: Synchronizing package databases...
core 149.8 KiB 138K/s 00:01 [######################] 100%
extra 1807.1 KiB 452K/s 00:04 [######################] 100%
community 5.2 MiB 636K/s 00:08 [######################] 100%
multilib 184.9 KiB 644K/s 00:00 [######################] 100%
The following packages are out of date, please update your system first: apache at-spi2-core boost boost-libs breeze cheese chromium cups-filters device-mapper discover dunst electron evolution evolution-data-server file-roller firefox fzf ghostscript giflib gjs glib-networking glm glslang gnome-calculator gnome-characters gnome-desktop gnome-disk-utility gnome-getting-started-docs gnome-notes gnome-shell gnome-system-monitor gnome-terminal gnome-user-docs gnome-weather gobject-introspection gobject-introspection-runtime grub gtk-update-icon-cache gtk3 gvfs gvfs-afc gvfs-goa gvfs-google gvfs-mtp gvfs-smb harfbuzz harfbuzz-icu hplip icu imagemagick jack2 jbig2dec kactivitymanagerd kde-cli-tools kdecoration kfilemetadata khotkeys kmenuedit knetattach kscreenlocker ksysguard kvantum-manjaro kwin lib32-glib2 lib32-icu lib32-libxml2 lib32-mesa lib32-nvidia-utils lib32-util-linux libbluray libc++ libc++abi libcdr libcroco libdazzle libe-book libffado libfreehand libical libinput libkscreen libksysguard liblouis libmagick libmbim libmspub libnotify libphonenumber libqalculate libqmi libqxp libreoffice-fresh libsoup libsynctex libutil-linux libva libvisio libwbclient libxml2 libzip libzmf linux419 linux419-nvidia linux419-r8168 lua52-luajson lvm2 manjaro-settings-manager manjaro-settings-manager-notifier mesa mhwd-nvidia milou mutter nano nodejs nvidia-utils openjpeg2 papirus-icon-theme pepper-flash perl-xml-libxml pixman plasma-desktop plasma-integration plasma-nm plasma-workspace playerctl polkit-kde-agent portaudio powerdevil python-pillow python-setuptools python-sip-pyqt5 qca qt5-base qt5-location qt5-webengine qt5-webkit raptor re2 simple-scan smbclient steam-manjaro systemsettings talloc tlp tracker tracker-miners unrar util-linux vlc vte-common vte3 webkit2gtk wget xfsprogs xmlsec yay yelp zeromq
Do you want to continue anyway? [y/N] y
resolving dependencies...
error: could not open file /var/lib/pacman/local/yelp-3.32.0-1/desc: No such file or directory
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (1:418.56-1) breaks dependency 'nvidia-utils=1:418.43' required by linux419-nvidia


I tried the other command (mhwd-kernel -i linux419) and it said that is already installed, so I proceeded :slight_smile:

mkinitcpio -P
update-grub
exit
reboot.


after rebooting and select the disk in my bios , it shows me : 
 
grub>

and now?

this is bad , if you cant install grub

  • check disk
  • save data

You have multiple issues with your system. These are fixable but need you to read and follow instructions carefully.

The easy alternative is for you to reinstall.

Please let us know which approach you want to try.


@SlayerProof32 @stephane Please read the existing posts before linking in more threads (which has steps which have already been tried) or asking for extra information (which doesn't follow the issue at hand).

As advised previously:

Good luck!

1 Like

@baxtard If you do take this path, you would be able to boot the Live environment (NOT the grub commandline!) and use the graphical file manager to copy your files onto another storage medium such as another USB drive. I recommend just copying /home/ as it gets all your data. Programs, a few settings, etc will be lost. If you have a lot of storage, I'd reccomend having the regular boot partiiton, swap, and then having a 20GB-50GB partition for your root / and the rest of the space for your user folders, mounted as /home. This makes reinstallation a breeze. I've already used this strategy over three times.

1 Like

Forum kindly sponsored by